Image Map Image Map
Results 1 to 5 of 5

Thread: Zenith sopersPORT 8085 adventures

  1. #1

    Default Zenith sopersPORT 8085 adventures

    I recently acquired a Zenith supersPORT ZWL-184-02 in a non-working condition. It would not power on and the plastic was broken in several places. To fix the electronics I replaced the fuse (duh) and repaired the display connector (one pin had worked itself out of the plastic) after which it booted up. Unfortunately it had a modified BIOS, which required a password for access. I disassembled the BIOS and after de-crypting the contents, disabled the offending code. After formatting the (original) hard disk and installing DOS, the system worked, until it didn't. The hard disk failed. It appeared that the 5 electrolytic caps on the hard disk board had been leaking, so after removing the caps, cleaning the board and replacing the corroded solder in the affected areas (and repairing one via) I soldered on new caps. Now the hard disk works again.

    Note: when checking for corrosion you poke the solder and when it chips off, you need to replace the whole joint. you have to remove the old solder mechanically, because it no longer melts, scrape until you see the copper pads, and re-solder the joint. Use flux liberally.

    Repairing the plastic is a work in progress. For now it is a solid unit, although not pretty. I am missing the plastic shutter under the display, which I intend to 3d-print when I find pictures of the original (somebody?). The double hinge system needs attention. Also the unit is yellowed badly, albeit quite evenly. I can't do anything about that; no sun to speak of.

    Another note: This unit has no tabs holding the shells together. after unscrewing top and bottom you can lift the top off effortlessly. The same goes for the display. After removing the 2 bottom screws you slide the LCD down about 3 mm (1/8 inch) and the shells separate. In my case a previous owner forced the display open causing the locks to break off.

    One question, did someone ever replace the EL backlight on displays of this type? Any guidance on how to, preventing catastrophic failure?


  2. #2


    wow! that's some serious work. impressed that you could fix the bios!

  3. #3


    It's not that hard, just very tedious.
    I used the IDA free dis-assembler. You just look at the code, start at the beginning F000:FFF0 and follow along. Name parts you (think) you recognize and keep at it. I am not that well versed in 8086 code, but knowing 8080 and some help from looking up instructions I didn't recognize, I got on fairly quickly.
    I learned that most of the added code was located in the HDC ROM and "encrypted" by XORing with a 2 byte secret word. So I wrote a shell script XOR-ing the whole HDC ROM with itself, shifted by 2 bytes. This removed the secret code. I did the same with phrases from the signon message and located these phrases in the code. I extracted the secret word and then de-crypted the whole thing.
    Then more disassembly and finally I found that I needed to only change 2 addresses, One in each ROM to make it behave normally.
    Like I said, tedious, but doable.
    Added bonus: I learned a lot more 8086 code in the process. Programming skills are like learning a foreign language. You need to read a lot of other peoples work.

    PS. Who spotted the error in the thread header? 8085 should -off course- be 8088

  4. #4


    When the old solder is too hard, you can melt new solder onto (into?) it and it will allow the old-new-solder-mix to flow, enabling the removal with a solder-sucker or wick. Its similar to adding antifreeze to water and changing it's freezing point.

    Sorry that I don't have answers to your questions, it sounds like you are doing a great job to date. Super cool workaround for the BIOS issue.

  5. #5


    Solder isn't old it is corroded by the E-cap electrolyte. it no longer melts using a soldering iron. It needs to be removed physically, as does the corrosion of the copper pads. I had one via which had to be cleaned out similarly. This is scary, because you might have lost the connection to an eventual inner layer. Through-hole metalization is typically thin. It worked out OK though.

    Bummer, the disk failed again.... More work ahead for me.

    Does someone know of a solid state replacement for these 26 pin RLL disks? I have them for SCSI and IDE, but have trouble finding one for an ALPS drp020a11b, which is similar to a JVC JD3824T00-1, I believe.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts