Image Map Image Map
Results 1 to 3 of 3

Thread: Corona PPC-XT [Luggable 8088 PC]

  1. #1

    Default Corona PPC-XT [Luggable 8088 PC]

    Hi All,

    I picked-up a Corona PPC-XT (appears identical to PPC-400) luggable machine in pretty good condition with the carrying bag. It's a really neat machine with a built-in amber-CRT, 360k HH Floppy Drive and 10MB Cogito Hard Drive with Corona HDD controller - everything is in factory original condition with no apparently upgrades or modification -- a true gem! Apparently the computer sat in an attic for 30 years before the house it was in was demolished.

    I'm struggling with getting it to boot... when I turn it on, it successfully completes a memory test (512k), cycles the floppy drive and then attempts to boot from disk. After a moment, it gives me a boot failure error message and says to push ctrl-alt-del and try again (or hit the reset button). I have a known good Corona boot disk (boots fine with another machine) which thankfully has all the proper drivers for the hard drive, etc -- but the Corona PC does not appear to read it. I've tried a couple other known-good floppy drives with the same result. When it tries to boot, it selects the floppy drive (light on, drive spinning), but the heads do not move, even if they're not on track-0. I've tried different floppy cables, jumper settings DS0 and DS1, and with/out termination, all with no positive results. I'm starting to think that the floppy controller chip might be fried (on-board floppy controller) or some other bizarre issue.

    Anyone have any other ideas or suggestions? I'd love to get this machine working again.

    Also, another question -- when inspecting the HDD controller card (Corona branded), I don't see any ROM chips... considering that and the fact that the boot floppy has drivers for the card, I'm guessing the machine is not capable of booting from the hard drive? Anyone else have experience with this particular machine?

    Thanks!

    Chris

  2. #2

    Default

    I have an 8088 Corona PPC-22(?) model with a Western Digital controller and ST-251 replacement for one of the floppy drives. It boots from the HDD and from a normal MS-DOS boot floppy without anything special. (Would love to know what sort of custom goodies might be on your Corona floppies, though!)

    You mention that the floppy drive lights up but the heads don't move I've had similar issue with a few of my older systems. The floppy rails either gum up or dry out and the motor doesn't have enough oomph to overcome the friction. When you move the heads along the rail, it should move pretty effortlessly. If it doesn't, then it could be just lubrication. I first use a q-tip with isopropyl alcohol to clean the rails, then another q-tip to apply an extra-thin, nearly invisible layer of silicon grease. Any lubricant will attract grime over time, so less is better. White Lithium grease might work also. The read/write head chassis is plastic, so just be sure to use lubricant that isn't harmful to plastic. WD-40 and other petroleum based products are no-no. And, be extra careful not to get any on the read/write head. And definitely don't spray anything around the heads.

    This procedure has cleared up the "won't seek" problem for me on more than one floppy drive. See if this brings you some joy before attacking it as an electrical or motor problem.

    P.S. Very nice find, by the way! Post some pics when you get a chance.
    Last edited by normanator; October 21st, 2019 at 02:28 PM.
    “The Bex religious impulse does have its collective side. As in, collect everything and hold on to it whether you remember where it came from or not.”
    —Alberto Fossa, Privateer 2

  3. #3
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    3,295

    Default

    Quote Originally Posted by cchhrriiss11 View Post
    I have a known good Corona boot disk (boots fine with another machine)
    Would that other machine happen to have a 1.2mb drive? 360k (low density) disks tend to become unreadable in genuine 360k drives after they have been written to by a 1.2mb drive.

    Quote Originally Posted by cchhrriiss11 View Post
    I've tried a couple other known-good floppy drives with the same result.
    Could you elaborate on that? After cleaning as stated above, If the drives in the machine have a standard shugart style interface, I'd try them connected to another machine and verify their operation. Unfortunately, if the drives test fine then troubleshooting is quite a bit harder.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •