Image Map Image Map
Page 19 of 20 FirstFirst ... 9151617181920 LastLast
Results 181 to 190 of 199

Thread: Unique S-100 computer (Z-80/Vector Graphic/Micropolis)

  1. #181
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,349

    Default

    Quote Originally Posted by deramp5113 View Post
    You can pick out the pattern even with an incandescent bulb. Not as obvious as fluorescent, but it’s there.

    Mike
    True enough, but incandescents are getting as hard to find as 'real' fluorescents and certainly not nearly as clear. But if that's all you've got...

    BTW, Mike, let me take this opportunity to thank you for your many contributions to the hobby!

    m

  2. #182

    Default

    LOL I did do this with a real fluorescent fixture - I had one for plants/seed starting - not CFL or LED. I swear I can't make out any pattern at all.

  3. #183

    Default

    We can rough check timing with a scope. Measure sector to sector time by monitoring test point 3, negative edge triggered. Note you’ll have a half-sector time slip in periodically at the index pulse. What interval do you measure?

  4. #184
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,349

    Default

    Quote Originally Posted by nullvalue View Post
    LOL I did do this with a real fluorescent fixture - I had one for plants/seed starting - not CFL or LED. I swear I can't make out any pattern at all.
    Well, there is the possibility that the speed is too far off; time to check it the hard way as Mike suggests

  5. #185

    Default

    Quote Originally Posted by deramp5113 View Post
    We can rough check timing with a scope. Measure sector to sector time by monitoring test point 3, negative edge triggered. Note you’ll have a half-sector time slip in periodically at the index pulse. What interval do you measure?
    I'm not sure I have my scope set up to capture this correctly, maybe you can make sense of this? I've recorded what TP3 looks like during the boot loop. Volts/Div is set to 1V, Time/Div is 2ms.

    https://www.youtube.com/watch?v=Q72uuYmHDow
    Last edited by nullvalue; May 31st, 2020 at 04:01 PM.

  6. #186

    Default

    The flicker is the full rotation index pulse at 1/2 the sector time that you have to ignore. Looks to me like that drive is about 5.2 divisions or 10.4ms. That’s way too quick, nominal is 12.5ms (300 rpm, 16 sectors). See if you can adjust R89 enough to get the drive to 12.5ms (6.25 divisions). Then you should be able to see the strobe pattern and do final adjustments.

    Mike

  7. #187

    Default

    Thank you, that helped me get it dialed in! I couldn't see a pattern at all, frustrated I tried under my normal LED bulb lighting and behold, a spinning pattern! I adjusted until the pattern holds steady, as can be seen in this video:

    The outer pattern holds still (that's what we wanted, right?)
    https://www.youtube.com/watch?v=kt9ZcF1eL2U

    However, I went through the whole disk creation process now - twice - and same results as before. Disk writes successfully, but then (B)oot just sits there spinning the disk. It finds track 0 but then just spins.

  8. #188

    Default

    See what the boot ROM checksum is. Type "Q F800 F8FF"

    Mike

  9. #189

    Default

    Yep already tried that.. it's "BC"

  10. #190

    Default

    Well damn, yep, that’s correct. Post pictures of the Micropolis controller board mods. If the motor mod is done (that one stops the motor about four seconds after the drive is deselected), but the “ready mod” is not done, CP/M disks don’t work. Did you ever try the “ CPM22A-MikeD.VGI” disk images instead?

    Mike

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •