Image Map Image Map
Results 1 to 4 of 4

Thread: Did I fry my DS1287 or maybe my motherboard?

  1. #1

    Default Did I fry my DS1287 or maybe my motherboard?

    Hi there. New on the forums.

    I just got hold of a IBM PS/2 Model 30 (it has some kind of 386sx update, I think).

    Of course it had the 161 and 163 error at bootup, because of no battery for BIOS.

    I took the DS1287 chip out, and modded it to a 3V battery, like several guides show online.

    The mod looked ok. But when I inserted it back, I accidently flipped it 180 degrees, and turned the PC on. Nothing came on screen at bootup, no beep. I discovered my error, and flipped it back. Booted up, and again blank screen, nothing. I waited a bit, and touched the DS1287 chip, and it got hot quickly. I quickly turned off the PC again, and tried 2 mins. later, with same issue. I tried disconnecting my new 3V battery mod, and tried again. Same issue. Nothing.

    What concerns me is that the DS1287 kinda gets how within 30 sec. when booting.

    Question:
    1. Could I have fried the chip like this by flipping it 180 degrees making the pins align wrong on my first try? Did I do that? My 3V battery mod was installed when doing that first try.
    2. Could I have accidentaly ruined the whole motherboard, making this PS2 unusable forever?
    3. Should I just order a new DS1287 and try again?
    4. Shouldn't the IBM boot even though there isn't a clock in there? That's why Im thinking I may have fried the whole motherboard?

  2. #2
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,750

    Default

    You have probably destroyed the DS1287, most ICs won't survive being installed backwards. Probably not the motherboard though, since there's only 5V logic on the DS1287. You will have to buy a replacement. You should be able to use a DS12887 in there, I know for sure my PS/2 Model 30/286 is fine with the 12887 and I'm pretty sure my plain Model 30 was, too. Don't bother with a DS12887 from China, they're almost universally relabels/fakes and will have dead or weak batteries. You can still get the DS12887 from regular components places like Mouser. Of course,my personal preference is for my own GW-12887-1 module:



    It's a little board that mounts on top of a Dallas/Maxim DS12885, which is the chip inside a DS12887. You can still get these too -- I only use new ICs from Mouser. My board has a socket for a CR1225 battery though, which means you never have to replace the module ever again, just the battery. I do have them on Tindie if you decide to go that route:

    https://www.tindie.com/products/glit...cement-module/

    The board design is open source, so you can also run your own circuit board on e.g. OSH Park and make your own GW-12887-1!

  3. #3

    Default

    That sounds super. Im going to order one from you then.

    One more question before Im starting to invest in this computer:

    Before I messed up the chip, it did boot fine to HDD. And I was able to access 1.44 floppy discs (it is a 1.44 drive), although I got a lot of Bad Sectors. Not a single floppy (+10) was without a lot of bad sectors. I tried "Format A:" and MS-DOS 3.30 asked me to insert disktte and press ENTER. But after that I always got a "Wrong Parameter" (my DOS is in danish, and I think this is the english translation). So there was something wrong with Format.

    I later tried formating these 1.44 HD floppies with the "Format a:/4"-command, which somehow formats them into a smaller disc. And they worked fine after format, but only being 300.000 kb space.

    Reading up on the problems with no battery, I came to the following conclusion and solution to all these problems. Do you agree:

    The system is not recognizing my 1.44 drive, hence cannot acceess these sectors, resulting in Bad Sectors all over the place.
    Solution being:
    1. Fix the battery.
    2. Use original IBM 700 kb. disc setup (download), and setup the drive for correct 1.44
    3. Solved.

    Does this sound like a plan? What do you think?

    (My floppy drive has not been modded with new capacitors or anything. But seems to kinda work)

  4. #4
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,750

    Default

    "Seems to kinda work" is what PS/2 floppies do before completely failing from bad capacitors, in my experience. Do be sure to replace all of the surface mount electrolytics, I've had two PS/2 1.44 MB drives come through the shop this year that were too ruined by cap leakage to be saved. I don't remember if there's any setup options for drive type or not, but regardless, you should definitely recap your drive before it's too late. I recap them for folks, I don't know if anyone else does it as well. Not a particularly difficult job, if you're familiar with surface mount soldering.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •