Image Map Image Map
Results 1 to 4 of 4

Thread: IBM 5150 troubleshooting

  1. #1
    Join Date
    Nov 2019
    Location
    Northern California
    Posts
    17

    Default IBM 5150 troubleshooting

    I just picked up an IBM 5150, but it doesn't appear to power on (no "short beep" as described in the IBM Guide to Operations). How can I troubleshoot it? What should I be looking for? I'm an absolute novice to PC and PC compatibles having stuck to Apple so far, so sorry about any dumb questions!

  2. #2

    Default

    How long did you wait? The 5150 doesn't show the memory count during self-test, and getting to the point of the beep might take a few minutes if you have maxed out the memory.

  3. #3
    Join Date
    Jun 2015
    Location
    Sioux Falls SD
    Posts
    362

    Default

    There is a lot of useful information including troubleshooting a 5150 at

    http://www.minuszerodegrees.net/index.htm

  4. #4
    Join Date
    Apr 2019
    Location
    Ottawa, Canada
    Posts
    20

    Default

    Quote Originally Posted by lafos View Post
    There is a lot of useful information including troubleshooting a 5150 at

    http://www.minuszerodegrees.net/index.htm
    I second this. I repaired a broken 5150, had multiple shorted tantalum capacitors. One was on the motherboard, another was on one of the floppy drive.

    The tantalum on the motherboard had a slight crack/hole on the top so it was an easy guess as to which one failed. A lot of times they just look normal though.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •