Image Map Image Map
Results 1 to 10 of 10

Thread: MSC-234 CPU card (486) CPU card not booting: trying to figure out what is wrong

  1. #1

    Default MSC-234 CPU card (486) CPU card not booting: trying to figure out what is wrong

    Hello,

    I was recently lucky enough to acquire a CNC machining center from 1989. It was sold with a known fault: sometimes the CNC controlling system would start, and sometimes not.

    To make a long story short, I moved the machine to my shop (2200km return!), put it back under power, and to my susrprise it started the very first time I tried. I could see the POST screen, and the dedicated CNC controlling software (Sharnoa Tiger 5) even started! Well, not for long: the computer kept resetting itself and booting over again after a few seconds. But at least I saw it alive.

    When I came back the next day (and any other subsequent day FWIW), the system failed to boot. Knowing (from the POST screen I had a chance to see a few times that first evening), I knew it was 486DX based. I digged into the control cabinet, and found a huge ISA backplane, with several cards plugged into it
    -Input/Output cards
    -Axis/motion control cards
    -Network card (looks like an NE2000 clone to me)
    -Graphic board
    -...and a CPU card, identified as a Mitac MSC-234:

    Mitac MSC-234 - Front.jpg

    Mitac MSC-234 - Rear.jpg

    Trying to figure out why it didn't boot anymore (or at least not so often), I started to unplug all cards but the CPU card and the graphics card. It didn't help - no beep, nothing. I checked all voltages on the ISA bus, and they were all present. So I reckoned the next step was to read the POST codes to figure out a little bit better what happens, and what doesn't.

    The board runs an AMIBIOS:
    Bios chips.jpg

    Well, today the POST diagnostic card (chinese stuff) finally showed up in the mail, and of course I plugged it in the machine as soon as I could get close to it.

    The board is definitely at least somewhat alive, as this is the stream of POST codes I get:

    03
    05
    07
    09
    06
    0D
    0F
    11
    13

    Now I am stuck a this step for now: I do not know exactly which AMIBIOS version the board is running. I found several lists of AMIBIOS POST codes online, but cannot figure out which is the right one, as I do not know the exact BIOS version. Plus, most importantly, most of these list have nothing listed for code 13 - which, as the last being shown, semms to be the trouble-making step...

    Can someone help me figure out what is wrong - and move a little bit closer to the step where I'll be able to get the machine to move for the first time!

    Thanks for you time reading this!
    Pierre-Yves

    [EDIT: typos]
    Last edited by Pierre-Yves; November 25th, 2019 at 11:13 AM.

  2. #2

    Default

    I looked it up in "The PC Engineer’s Reference Book Vol 1 – The BIOS Companion", and found this table:

    2019-11-25 21_50_15-pc_engineers_vol1_BIOS.pdf - Adobe Acrobat Reader DC.jpg

    Not sure that this version is the proper one, however based on the BIOS chip tag (dated 93), this could be the right one.

    In this list, 13 means "Disable Video display and initialise port B. Chipset init/auto memory detection about to begin."

    So, a memory problem? Does this hypothesis make sense?

  3. #3
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,543

    Default

    Welcome to these forums.

    I suggest that you try re-seating everything on the CPU card that is in a socket. For the DIL type chips, be careful that a leg does not get bent up under the chip when returning the chip back to its socket.

    One of the POST tests will be of the first part of the RAM. If you remove the RAM SIMM's, does the POST still stop at test 13, or does it stop earlier ? If 13, maybe 13 is the early-RAM test, but of course, it could be that the early-RAM test is a later one.

  4. #4
    Join Date
    Apr 2015
    Location
    Austin, Texas
    Posts
    1,860

    Default

    You could have a failed tantalum capacitor, they don't always explode when they fail and can cause weird problems.

  5. #5
    Join Date
    Oct 2008
    Location
    Kamloops, BC, Canada
    Posts
    5,944
    Blog Entries
    44

    Default

    Perhaps the first concern is why the machine started resetting after a while. How is the ventilation in the cabinet? Is it at all possible you can overhaul the power supply to eliminate the possibility of unstable DC power?

    Again, the fact that everything worked on the first try without touching anything and only started failing once things warmed up makes me think you don't have an (initial) issue with bad ram or another bad IC or a tantalum issue (yet) but something is overheating until it starts glitching or thermal latch-up.
    [Need something to waste time on? Click here to visit my YouTube channel CelGenStudios]
    --------------------------------------------------------------------------------------------
    [No time for videos? Click here to visit my Twitter feed @CelGenStudios]

    = Excellent space heater

  6. #6

    Default

    Hi all,

    Thanks for the replies!

    @adam7: I went back to the shop early this morning before going to work, and tested again without the SIMM's in place. The POST codes sequence doesn't change at all: it still hangs on step 13. Next step will be to reseat everything as suggested. I realized btw that the first SIMM slot (nearest to the card's edge) was pretty dirty from the adjacent fan's airflow. This will be cleaned as well.

    @GiGaBiTe: didn't know these could be troublesome. IIRC these are the drop-shaped ones - there are plenty of them on the CPU board as well as on the backplane (between ISA slots). I'll keep that in mind.

    @NeXT: From the previous owner, the pattern was that the machine would sometimes start, and sometimes not. If it failed to start, you would have to try again later and hope for better luck (could be working a few minutes later... or only days). I wasn't informed however that the machine would reset itself once started. To my best knowledge, it was running smoothly once started. However this doesn't look like what I observed myself after moving the machine.

    The only day I got it started, it resetted itself pretty quickly - wasn't up for a full minute at all (POST, Dos starting, than the CNC software welcome screen, and shortly after that, reset). So there was very little time for any sort of overheating. Ventilation in the cabinet is very good (well built machine), and currently temperature in my shop is around 10C. As the system gets stuck at code 13 in its POST like 10s after power is applied, I do not feel there is enough time for overheating problems. I remember running 486DX2-66 without any sort of cooler back in the days, and this one has one installed.

    Regarding the power supply, I have no means to actually make sure it adequately stable (it is already a modified ATX power supply, as this system requires -5V as well). So replacing it by a new, good quality one (with the same mod for -5V) can be done, and is probably my only way to rule out power supply problems.

  7. #7

    Default

    Quote Originally Posted by NeXT View Post
    Again, the fact that everything worked on the first try without touching anything and only started failing once things warmed up makes me think you don't have an (initial) issue with bad ram or another bad IC or a tantalum issue (yet) but something is overheating until it starts glitching or thermal latch-up.
    I would go in the same direction your are suggesting, if the machine had accepted to start agin (possibly resetting the same way right away) the days after, once it had fully cooled again. It didn't, not a single time. Hum...

  8. #8

    Default

    This week-end, I was able to bring the board back home. I thoroughly cleaned the memory slots as well as the memory sticks themselves (isopropylic alcohol rub, good rinse in demineralized water, gentle blow, and hours on slow heat to dry it all). I also unplugged then reseated every socketed IC (it means in this case 10 cache chips, the CPU, and the 2 ICs for the BIOS). Apart from the memory slots near the fan (before cleanup), everything looked clean and corrosion free.

    I'm just back from the shop, and I can confirm that there is no improvement nor change in the system's behavior after this treatment. Oh well.

    Next attempt will be to change the power supply. The first ISA slot on the backplane is an 8 bit slot, in which a "power supply" card is plugged. In fact this board is managing a 6V lead-acid battery acting as an UPS

    UPS_board-front.jpg

    This seems to only deal with +5V, while -5V, 12V, -12V and GND are plugged into another connector, directly into the backplane.

    So, I think I might buy an ISA backplane with an usual AT connector (I still have some AT power supplies lying around). This would allow me to test further - at home and not in the shop, taking the power supply and this "UPS" board out of the equation, as well as the current backplane (which sports its fair share of tantalum capacitors...).

    I'm thinking of something like this:
    https://www.advantech.com/products/1...f-a01f5a486285

    (This model seems to allow an ATX power supply as well, however my system need the -5V - so an AT power supply seems the easy way to go...)

    Py

  9. #9

    Default

    Dear moderators, I posted a reply (including pictures) to this thread last sunday. However, it still hasn't shown up. Is there a problem with my post?

    Please let me know if it the case!


    Thanks,
    Py

  10. #10

    Default

    I only skimmed this thread so I apologize if this has been touched on...

    If I were you I would replace the Dallas RTC/CMOS chip and see what happens. You may already know that this is the battery, clock, and I believe the actual CMOS memory too. I have had numerous boards that wouldn't even POST once this went dead, perhaps yours is on the brink? Plus... it could probably stand to be replaced if the battery state is unknown. I think they are around $10+/- from Digikey or Mouser.

    Since many of the AMI post code 13's seem to relate to chipset initialization, and the CMOS memory is where the settings are stored (which are retrieved and written to chipset registers during POST), and a new RTC is cheap... maybe worth a try?

    Good luck!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •