Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: Windows 2K Workstation Revived With Problems

  1. #1

    Default Windows 2K Workstation Revived With Problems

    I've had this Dell Precision 620 for some time and decided to get it running again. I did a clean install of Windows 2000 and it runs but there are several problems that I can't seem to work out.

    The machine consists of the following

    --Dual P3 Xeon 1000/133/256 Processors
    --36 GB SCSI Hard-Drive for OS and Applications
    --3 GB Ram (4 x 512, 4 x 256)
    --Windows 2000 SP4
    --BIOS Revision A12
    --250 GB IDE Hard-Drive for Files

    The first problem I noticed was that it runs extremely slow, I have two othe machines from the same era with similar specs that run much, much faster. During start-up, I entered F2 to make sure both processors are recognized and they are, but they are listed as 266/133/256.

    Second problem is that the computer only recognizes 2 GB Ram. According to the Dell manual, 3 GB is max.

    Third problem is that the 250 GB IDE Hard-Drive is not recognized. It came with a jumper in the "cable select" position which I left as is but it did not show so I removed the jumper (slave) but it did not help.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    33,074
    Blog Entries
    18

    Default

    I think that 2K went up to SP6 (unofficial) and at least SP4 (official).

    Do you have the data sheet or jumper information for your hard drive? Is it sharing the IDE bus with a CD-ROM or DVD drive? The IDE drive should be set to "master". Also, if there's a jumper limiting the visible storage to 32GB, you might enable that.
    Last edited by Chuck(G); November 26th, 2019 at 09:53 AM.

  3. #3

    Default

    Thanks for the response.

    I set the 250 GB IDE hard-drive to "master" but now I cannot boot to Windows. If I press F2, I see that the IDE drive is recognized as "Primary Drive 0". There are two IDE connectors on the mother board, the 250 GB is connected to "1" and the CD ROM is connected to "2"

    Under the "Hard Disk Drive Sequence" option, it lists two options:

    1) System Bios Boot Devices
    2) AIC-7899, A:00 Seagate ST336754LW (which is the SCSI hard-drive with the OS installed)

  4. #4
    Join Date
    Mar 2017
    Location
    New Jersey, USA
    Posts
    542

    Default

    You have the 512GB modules in the B channel slots, correct?

    You may need to use the SuprFreq utility to reset the clock multiplier:
    https://www.dell.com/support/home/us...riverid=r20706

    see also: https://forums.tomshardware.com/thre...rouble.300679/

    edit: also see this post regarding use of /E to reach 1GHz: https://www.dell.com/community/Deskt...em/td-p/241588

  5. #5

    Default

    yes, I installed the 512's in the rear per the instruction manual. Thanks for the link, I'll take a look at it

  6. #6
    Join Date
    Oct 2008
    Location
    Kamloops, BC, Canada
    Posts
    5,855
    Blog Entries
    44

    Default

    Intel's chipset drivers from that era needed to be installed on some machines or else they fell back on a generic mode that was much slower and feature limited.
    Have you also verified all your ram DIMMS are identified at POST?
    = Excellent space heater

  7. #7

    Default

    Yes, all 8 DIMMS are identified.

    I'll have some time today to work on it. Thanks for all of the replies so far.

  8. #8

    Default Two Steps Forward, One Step Backward

    So I used the utility to set the correct speed of the processors, they are now recognized as 933 MHz.

    I also got closer to figuring out why the computer was so slow. It seems the DVD writer has something to do with slowing the machine down because after removing it from the system, it now runs normally.

    The step backward is that now, the SCSI Hard-Drive which contains the OS is not recognized, hmmm

  9. #9

    Default

    I figured out why the SCSI hard-drive was not recognized. In the BIOS Set-Up, under "integrated devices" the SCSI controller was in the "off" position. Easy fix but it's actually the second time it was turned off since I re-installed Windows 2000.

  10. #10
    Join Date
    Apr 2015
    Location
    Austin, Texas
    Posts
    1,760

    Default

    Quote Originally Posted by acad_2k View Post
    So I used the utility to set the correct speed of the processors, they are now recognized as 933 MHz.
    You said in the OP that you have 1 GHz Xeons installed, you're 66 MHz short of that.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •