Image Map Image Map
Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: IBM ps2/30 hard drive replacement

  1. #21

    Default

    Quote Originally Posted by pinkdonut666 View Post
    I just picked one up that is doing some, uhhh interesting things... Somehow the system seems to think it has 562cylinders and 51 heads... very odd.



    I don't know if re-capping will help me here unfortunately. ( I know I know not taking my own advice but It be nice if this drive would work) This drive doesn't seem to have any mechanical problems, the motor spins up nice and quietly and the heads seak back and forth, no physical damage to the head stack or platters.

    The Model 30 throws a 1790 error on starup and advanced diagnostics throws a 1712 error.

    but for whatever reason something is borked. Speedstor & the IBM Advanced diagnostics think the drive has 562cyl (it has 615) and speed stor reports 51 heads... weird... and unfortunately speedstor locks up when I try and change the drive "type"

    very annoying I hoped this drive would work for an OS/2 installation (which doesn't seem to play nice with XT-IDE or HardCard solutions in this system)

  2. #22

    Default

    Later versions of OS/2 came with an IBMINT13.I13 driver, that should support drives through the BIOS. Is that missing in OS/2 1.x?

  3. #23

    Default

    Quote Originally Posted by mcs_5 View Post
    Later versions of OS/2 came with an IBMINT13.I13 driver, that should support drives through the BIOS. Is that missing in OS/2 1.x?
    My first guess was a hardware conflict of some type, that DOS will just ignore the built in controller but os/2 won't? I'm really not sure. I just know that os/2 doesn't see a fixed disk via Fdisk but Dos does when using an XT_IDE or Hard card.

  4. #24
    Join Date
    Feb 2017
    Location
    Guildford, U.K.
    Posts
    394
    Blog Entries
    1

    Default

    I'll try to test that WD 30MB DBA-ESDI drive I have. I was going to try it in a recent 8570-M61 purchase but that's playing up and although the 160MB drive spins up, POST is no longer starting.

  5. #25
    Join Date
    Feb 2017
    Location
    Guildford, U.K.
    Posts
    394
    Blog Entries
    1

    Default

    Quote Originally Posted by WBST View Post
    I'll try to test that WD 30MB DBA-ESDI drive I have. I was going to try it in a recent 8570-M61 purchase but that's playing up and although the 160MB drive spins up, POST is no longer starting.
    LLFs just fine:
    https://photos.app.goo.gl/fZF7RKq3YviBZj1y8

  6. #26

    Default

    Quote Originally Posted by WBST View Post

    Thanks WBST for the hard drive deal, it finally arrived today !

    Heh, quicker shipment took about three weeks, I wonder how long the slower would have taken =).
    I think most delay is caused by Finnish post office. Post office package sorters were at strike during december
    for weeks and I think they have not yet recovered from the big mess after that.

    I have a chance to try out the drive next weekend!

  7. #27

    Default

    Well... doh.

    At least, I learned that I know little about IBM hard drives .

    hd.jpg

  8. #28

    Default

    Quote Originally Posted by VintageVic View Post
    Well... doh.

    At least, I learned that I know little about IBM hard drives .

    hd.jpg
    Sure... they have different model #s so they're different drives.
    PM me if you're looking for 3" or 5" floppy disks. EMail For everything else, Take Another Step

  9. #29

    Default

    The WDL-330R is from a PS/2 Model 55SX. It is a Direct Bus Attachment (DBA) ESDI drive, used with the MCA bus machines.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •