Image Map Image Map
Page 1 of 4 1234 LastLast
Results 1 to 10 of 40

Thread: Toshiba T1900C

  1. #1

    Default Toshiba T1900C

    Went today to old school building in Varkaus, Finland.
    Building is going to be demolished next week and they were giving
    away all furnitures and basically anything, that people could just carry away.

    I did pick up some tables and chairs that I can use, but to my surprise,
    there were also some computer hardware. Got couple of fujitsu siemens desktops
    with flat screen monitors and keyboards, mice and cables included.

    But most interesting found was this Toshiba T1900C.
    It did not come with needed 18V power supply however. I need to figure out
    where I can get suitable psu for it. Most likely the battery has died long time ago,
    but I guess it could work with just the psu. Interested to find out if it will still work.
    Attached Images Attached Images
    • File Type: jpg a.jpg (165.3 KB, 19 views)
    • File Type: jpg b.jpg (97.1 KB, 15 views)

  2. #2



    I found 19V power supply (Toshiba requires 18V). With it, I do get green led (DC IN) on.
    Battery led is blinking orange. Very obviously the battery must be a goner.

    I try to boot the laptop with this psu connected, but battery led goes away and DC IN green
    led stays green, but starts to blink 1 long and 3 short blinks. And keeps repeating this while the
    screen remains empty.

    I realize, that the toshiba migth just refuse 19V psu, but it could be something else too.
    I could not find blink codes from the internet. There was the manual for t1900c, 183 pages;
    I did skim through it, but could not really find help from it either.

    Anyone got idea of the DC IN -blinking codes ?

    Seems, that failing caps are also a common problem with these, but in those case descriptions
    toshiba tryes to boot and something is shown on the screen. This one got black screen all the time.

    Laptop also remains completely silent. I guess, it is not allowing power to go to the hard drive.
    Maybe this could hint to mismatching psu. It just might be too picky on that.

  3. #3


    Have you tried cleaning the board?

    If the capacitors are leaking, their fluid is conductive, which may be causing issues.

  4. #4
    Join Date
    May 2006
    Melbourne, Australia


    Quote Originally Posted by VintageVic View Post
    I realize, that the toshiba migth just refuse 19V psu, ...
    If the 19V power supply is unregulated (see [here]), it may be putting out significantly more than 19V.

  5. #5
    Join Date
    Oct 2016
    Dutchess County, New York, USA


    Most laptops are not critical of input voltage as long as within a volt or two. The voltage has to be higher than the full charge voltage of the battery to be able to charge it. Otherwise, the voltage is regulated in the first few circuits found in the charger input. A few early laptops would not boot if there wasn't a battery installed, might have used the battery as a large capacitor?? Don't know if the Toshiba was one.

    I also don't know anything about that blink code, but there were only a few BIOS writers back in the early days, Award and Phoenix comes to mind and searching for their blink codes might reveal the correct data.

    The CMOS battery might be dead or needing a charge (if rechargable) and try leaving the adapter pulled into it for a few hours to see if it charges the CMOS battery. Also, a trick I've used on main batteries that won't start charging is to remove it and plug it back in a few times while the adapter is also pulled in. Each time you put a pulse of power to the battery and therefore give it a small charge. If you can get the battery's circuitry to power up it might allow the charge to begin normally. If the cells are shot they might only supply a few minutes of run time, but you can at least see if the battery is rebuildable.
    Crazy old guy with a basement full of Pentium 1 laptops and parts

  6. #6


    Thanks all for your input!

    I have not yet opened and checked, if there are leaked caps inside.
    Very likely there are, if the laptops are not picky of exact voltage.
    I will check with multimeter, what does the psu actually gives. But it seems, that I need to open
    it up and check the capacitors.

    I have tried to boot with the battery installed and without. But of course, the battery itself must be defective for its long age.
    I did have the psu connected over night, but that did not change the situation.

    I have not tried that trick to remove battery and reinsert it, while psu is connected. I will try that just in case.

  7. #7


    So, I decided to take the laptop apart.


    On the way to possible cause (electrolytic caps), I checked internal batteries.
    Amazingly that small coin lithium battery was showing 3,00 V. On the other hand,
    it might have been replaced some time during the laptops life. The green finger battery
    was completely dead.

    I removed the batteries and had a try - no chance to the symptoms. Still one long green led flash and three short ones.

    All caps look externaly fine. 1000uF cap has been a known issue, so I tried to pull it from pcb. No change to behaviour.
    There was neither any chance after pulling the bigger brown 2200 uF cap.

    I checked, that pcb gets +19,26V near the power connector. The big dark blue cap near the power connector gets above 18V too.
    Two light blue caps (near the removed smaller brown cap) get about 2V each (one slightly under 2V the other slightly over 2V).

    Voltage on the removed brown caps is a bit inconclusive. At times they get zero, but I have also read just above 1V from those
    connectors. Trying a push to power on -button gets these connectors have a short burst of low <1V voltage, but voltage drops
    almost immediately to zero after releasing the power button.

    I'm not sure what could I try next. I was under impression, that shorted electrolytic caps might be the issue, especially that
    1000uF cap, that has been known issue. But not really sure now, though 2V on the ligth blue caps could still suggest
    a short somewhere. But none of the caps show short if I try with ohm values, they show at least >300 ohms each. At least
    I'm assuming its not a short, since there is some level of resistance (enough or not... ) .

    Two small brown caps (right from two light blue) are showing no voltage. But I guess it might just be due to computer not starting

    Oh well... back to the drawing board.

  8. #8


    What about the capacitors on the motherboard?

    Are they ok too?

    Did you check the ESR of the capacitors? That'll drift out of spec if the capacitors start failing.
    Last edited by DankEngihn; January 9th, 2020 at 10:07 AM. Reason: Missed a word

  9. #9



    I cant see any electrolytic caps on the motherboard.
    I'm quite novice with electronics, is it possible to measure ESR with just multimeter ?

  10. #10


    Depends on the multimeter you have.

    They're not electrolytic capacitors, they're SMD tantalum capacitors, which when they fail, fail short.

    Have you tried powering up the board with nothing else connected? Just the two boards and a charger?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts