Image Map Image Map
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Fixing Commodore 1541 drives

  1. #11

    Default

    Thank you Larry, for the links. Pictorial guide was new to me. Useful in some cases
    to get reference, although as the page says, it is not 100% exact as many failures can
    cause similar symptoms.

    I think I spent 8 hours or so last weekend trying to fix one 1541 pcb. This one is trying to make
    me nuts. At first, it was 'endurance runner'. No boot, spindle spinning with red led on. Checked
    all the chips ok, that had ic sockets on them, in another drive.

    While inserting the chips back to the pcb, noticed, that UB4 rom had quite loose ic socket.
    There was some contact issue and I got the drive to boot, if I pressed the rom down heavily during booting.
    Ended up changing that ic socket and got it to boot reliably (or so I thought at the moment).

    Now I tried to load a disc, but C64 got stuck in 'Searching for...' part and the drive has no reaction.
    Very commonly this is UA1 (7414). So, I cut the legs of that chip, cleaned pcb, installed socket and put fresh 7414
    in there. But to my surprise, no change! This time it was something else.

    And another known cause is UC3 (7622 chip). I checked that and noticed, that a-ha, the old ic socket is also loose here!
    So, I stripped that socket and put a new one in place. After this, I took a step backwards. The drive would no longer boot.

    I've been chasing my tail from here to get it boot up again without success. Newly installed UC3 socket is a likely suspect,
    if I went wrong there. So I checked with multimeter, if I had shorted two traces in this socket, but I found no such error.
    I re-tried all the socketed chips on another drive and they were still ok. I went on socketing UB1 (7406) and UC5 (7404)
    and UD1 (7406) and checked that after remove, these chips were ok and not causing the issue. I also decided to replace
    electrolytic caps near the two bridges. Put new ones with correct values in place, but that did not help either.

    It is probably very small issue, but I'm having a creative break with this one now. I still keep wondering if something is
    wrong with UC3 socket or related traces, since after that replace I have not been able to boot the pcb. However, the drive
    should boot even without UC3 chip in the socket, which makes me confused. And it was a clean removal of the old socket,
    without any visible damage to the pcb, traces or pads.

    Perhaps another socketed chip does not have a good contact. UC2, UC1, UC4, UB3 are also socketed and sockets are not changed.
    I might need to start checking for these chips contact to their sockets. Tidious work, but that's what is sometimes is.

  2. #12

    Default

    I moved on to the failed drive on my previous set. Let's call it drive #5.

    Symptoms: Drive seems to boot otherwise fine, but spindle is not spinning. Red led comes
    on and goes off. Mechanisc spins with a working pcb (but is very noisy), so there is an issue
    with this pcb too.

    Fist thing I did was to change bridge CR1, assuming if the pcb is not getting 12V and I have had
    failed bridges before. But no change there.

    Most of the chips were directly soldered to the pcb, so it was required to desolder them away from the board.
    I next suspected UC1, the motor controller. But to my surprise it was ok after all. I believe UD2 (7417 or 7407)
    is logic controlling the drive and I desoldered that also, but it tested fine on other drives also.

    I then got the idea to check voltages going to the mechanics. P5 and P7 connectors should have +12V on a few
    pins - 2,5 Volts only! Ah-ha, no wonder drive mechanics is not working.

    But I already changed the CR1 bridge, what next ? I checked that 2,5 volts is also on each cap along the way
    to the P5 and P7 connector. If any of them were partly shorted, that might be issue. So, I cut one leg from
    caps C1, C2, C3, (C21 is originally not in place) and even the big one C17. And Coil L8 and diode CR2.
    No change, still too low voltage. Now, I figured that voltage regulator VR1 must be the issue, since nothing
    else is on the 12V line. However, even after changing VR1 from spares, the voltage remained the same 2,5 Volts !
    That was very surprising to me.

    I then examined with multimeter the traces from bridge CR1 to voltage regulator VR1. I was getting confused, because
    traces from CR1 would lead to VR2 ??? What was going on here ?

    It turns out that actually in this board, the 12V line comes via CR3 (and not CR1) to VR1 and goes forward from there on.
    So, I had still not changed the bridge CR3 at the 12V line. Finally, after replacing that bridge, I was getting 12 Volts
    to the mechanics. I soldered the second leg back to pcb on each component that I had removed from 12V line.
    Booted up, and indeed the drive mechanics came live !

    Yehey. What a trick, I must have wrong scematic to this pcb (251830), or there is a typo on scematics (?). Had I
    changed both bridges at once in the beginning, it would have saved me a lot of trouble. At least, a note to myself,
    always check voltages from connectors P5 and P7, if drive mechanics is not working during boot up !

    I can't call this working drive yet as the mechanics is giving awful grinding noise and I have not tested if
    it would read a disc or not. But, a step forward yesterday anyways!

    1.jpg 2.jpg

  3. #13

    Default

    the PCB in my previous post / drive was indeed good after bridge repair and I had rescured another
    drive back to life.

    Since then, I have received new treasures, the set of six 'new' failed drives. And one failed C64C pcb.
    Right after I had ordered the drives, I noticed having broken my own rule. I had mistakenly ordered
    a couple of drives with mitsumi mechanics. My bad, but I'm still happy about the package deal.
    I measured the read heads, and 50% of these two cases have bad / open RW head. The one with bad
    head is giving ?file not found -error (by sellers description, not by my test yet), so I assume it is booting
    fine and probably pcb itself has no issues. I will test it later though.

    The other drive with good RW head ended up being repaired yesterday. What amount of dust and dirt
    there was on the pcb. The drive has obviously been storaged in damp conditions. Immediately it
    was obvious by the UC2 ROM, that was very corroded. In fact, one leg did not survive the chip being
    pulled out from socket. I still wanted to save that rom chip and managed to solder a new leg to it (or so I believed).

    There was no point trying to save that corroded socket. I pulled it out in small peaces a few legs at the time
    and put a new socket in its place. Then I pushed the rom chip back, after cleaning some corrosion from the legs away.
    Did not notice at the time, but the soldered leg did not survive push down and it cracked away. There was no
    change in operation of course, since ROM was not fully back on pcb and I ended up socketing UC3 and UB1 until
    I noticed the problem with ROM chip again. Both UC3 and UB1 survided the pull, I tested them on other working
    drive to be fine.

    I had to give up on the rom chip and put another in place and the drive was booting again! RW head was also
    very very dirty, cleaned it with alcohol dippid cotton swab. Finally made test loading to be sure that everything
    works well. I have yet to acquire some locktite for the stepper motor shaft. But I consider 1 of 6 repaired,
    1 of 6 proved dud or spares, and the rest remain to be investigated and repaired.

    I have started to make some statistics a while back, it may be interesting read later. Based on chip dates,
    this drive was probably made around week 31+ /1986.

    1.jpg
    2.jpg
    3.jpg
    4.jpg
    5.jpg
    6.jpg
    7.jpg
    8.jpg
    9.jpg

  4. #14
    Join Date
    Feb 2009
    Location
    Southern California, USA
    Posts
    2,819

    Default

    Keep up the good work!

  5. #15

    Default

    Thanks Dave for your encouragement !

    Next in line is this brown case 1541 drive.
    The patient suffers from unbootability with red eye symptom and endlessly running spindle .

    First glance at the pcb... chips from around week 31/1984, but pcb seems to have been replaced
    based on damage on screw on the left. Screw has been removed, damaged and not successfully
    screwed fully back. I have had (quite many) of these drives, where I suspect that are combination
    of bad pcb and bad mechanics. Previous owners may have combined from two (or more) failed drives
    a good pcb + good mechanics and survived 1541 drive that way, which is good. And then there are
    the poor drives that end up with me. I believe this one is one of those poor drives.

    Since many of the big chips are on socket, I test them all on a good drive, replacing the chip there
    one by one and making sure that the good drive boots. All of these socketed chips proved working.

    Next, I want to check that the sockets have no contact issues. I spent at least an hour with multimeter
    checking data and address lines of UB4, UC2, and UC4 the cpu and all other pins also of these chips, because
    they could cause the symptoms. All contacts are fine with the drive.

    Now, my next suspect is UA1 (7414 logic chip). I remove it carefully without damaging the pcb and test on
    a working drive. Ah-ha! No boot there! I throw that chip away and install a new socket on UA1. Try with working
    7414 chip and the patient is now booting!

    A quick check on the mechanics and I notice that the head is very sticky. It must have had no chance of working
    being so much stuck. This further convince me, that this drive unit was a combination of bad pcb and 'bad'
    mechanics. Bad being just very dirty in this case. Proper cleaning applied and the drive reads directory fine
    and also manages to load a program without issue.

    Result !

    a.jpg
    b.jpg
    c.jpg
    d.jpg
    e.jpg

  6. #16

    Default

    A new week begun yesterday and I found myself tinkering with another faulty 1541 drive.

    The drive was sold to me as 'endurance runner'. Symptoms: spindle is spinning indefinitely,
    but during power up, red led comes on and goes out in expected time. This tells me, that
    it probably boots up fine. If load was attempted, C64 got stuck at 'searching for...' step.

    I tried swapping UC2 and UC3 (and actually booted the drive without UC3) chip with no change in behaviour.
    UD2 (7417) chip is between motor controller (UC1) and the drive motor itself, so I pulled it. It checked to be
    ok in another working drive. Next I suspected the motor controller (UC1) chip itself and pulled it from the pcb.
    Tried the motor controller chip in another drive and the symptoms followed - faulty chip was found.
    Installed IC sockets to pulled chips and the drive is now working with good spare motor controller chip.

    Made a test load of game. Samantha kept her hat on at all times, but I lost my pants twice =).
    She's a tough poker face!

    edit:
    The drive has also been modified as device #9, with a poor mans 'switch', just two cables that come
    out of the casing. I am having difficulty to decide if I want to drill a hole in a good looking case.
    Switch would be nice as I could use device as #9 and/or as #8 drive to help fix drives with assumed alignment issues
    (I could load alignment software with #9 drive and use the alignment program for device #8 drive being repaired).
    I'm still probably not going to drill any holes to preserve originality and just leave this drive as device #9. And either
    strip the two cables or insulate them inside the casing.

    1.jpg
    2.jpg
    3.jpg
    4.jpg
    Last edited by VintageVic; February 24th, 2020 at 09:53 PM.

  7. #17

    Default

    Okay, had a quick check the next faulty 1541 drive.
    First test revealed following symptoms / behaviour:
    o Boots up fine.
    o I was able to read directory
    o Attempt to load a game results in head struggle. It's moving back/forth for a while
    and at the end, it ends up pushing the head all the way to the end (see pic 2), and computer
    results "File not found error", with red led blinking.

    First drive I have had with this kind of result. I already wanted to check that it is not misalignment
    issue - mechanics seem to work fine with a good pcb. So, it is an issue with the short board.

    Any ideas ?

    There are not that many choises, typical are probably the 6522 chips or motor controller,
    followed by checking the 7414. I'd try to guess the most likely suspect first though, before pulling
    chips out.

    1.jpg
    2.jpg
    3.jpg

  8. #18

    Default

    Quote Originally Posted by VintageVic View Post
    o Boots up fine.
    o I was able to read directory
    o Attempt to load a game results in head struggle. It's moving back/forth for a while
    and at the end, it ends up pushing the head all the way to the end (see pic 2), and computer
    results "File not found error", with red led blinking.

    First drive I have had with this kind of result. I already wanted to check that it is not misalignment
    issue - mechanics seem to work fine with a good pcb. So, it is an issue with the short board.
    I ended up trying the 7406 and 7414 and 6522 (UC1), without change in the behaviour.
    I also noticed, that the drive seemed to corrupt discs !

    I then rechecked Ray Carlsens (great) advices on chips and it starts to look like UD1 to me now
    (quote from Ray's website):

    "UD1 251853-02 (GENERIC H36A2U57) HEAD AMPLIFIER LSI
    Read and/or write failure"

    Now, that is a long component to remove. I have working short board
    that I could pull the component out. But it is a risky move if I damage it (or both).
    So, I therefore decided to just use my working spare pcb and fixed the drive with it.

    Not a 100% happy about not confirming the cause, but it makes no sense risk it just
    now. Perhaps in the future I end up accidentally buying short board 1541 that has open
    head. I might come back to this unrepaired pcb and then try to confirm if UD1 was really
    the issue there. At least to me, it looks like that now.

    Well, in the end, I have now fixed 4 of the 6 failed drives. One is confirmed dud with open
    head and one more to fix - if I manage to do that.

    I might have look at the dead c64c motherboard next that I had with the failed drives.

  9. #19
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,290

    Default

    Who's Samantha?

    (Not much of a game player)

  10. #20

    Default

    Quote Originally Posted by MikeS View Post
    Who's Samantha?

    (Not much of a game player)
    Heh heh, I just ended up loading a game from a random disc and
    it was samantha fox strip poker . Many would recognice that from the last pic
    of the post you are referring.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •