Image Map Image Map
Results 1 to 5 of 5

Thread: IBM Model 50 Z Power Supply Question

  1. #1

    Default IBM Model 50 Z Power Supply Question

    Greetings all,

    I received an IBM PS2 Model 50 Z that will not power on. Can someone tell me if the power supply for these units will power on without a load present ? I removed the motherboard and the power supply will still not show a green power LED when on. I also purchased a "working" PS on eBay and I have the same issue. No power LED on the PS with or without the motherboard attached. So either these PS need a load present or I have 2 dead PS.

    Thanks !!

  2. #2

    Default

    Page 422 here says that it isn't required for the to be a load. It does talk about a power-good signal required to turn the light on.
    http://ohlandl.ipv7.net/books/ps2-hmm.pdf

  3. #3
    Join Date
    Feb 2017
    Location
    Guildford, U.K.
    Posts
    317

    Default

    Quote Originally Posted by jafir View Post
    Page 422 here says that it isn't required for the to be a load. It does talk about a power-good signal required to turn the light on.
    http://ohlandl.ipv7.net/books/ps2-hmm.pdf
    Please note for future reference, that site is an old mirror. The current, actively maintained site is:
    http://ps-2.kev009.com/ohlandl/books/ps2-hmm.pdf

  4. #4

    Default

    Thanks!

  5. #5

    Default

    Thanks, both of you guys !! It's much appreciated !! Looks like I have a bad Tantalum cap on the main board and both my PS are fine.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •