Image Map Image Map
Results 1 to 5 of 5

Thread: Dead Sun IPX PSU

  1. #1

    Default Dead Sun IPX PSU

    I have a Sun IPX which I've had in storage for the thick end of 5 years, that I'm trying to bring back to life, which is falling to power up.
    Connecting power and turning on the mains power gives nothing - no twitch of the fan motor, no high pitched squeals or ticking.
    Powering up with the hard drive power disconnected or the main board disconnected yields the same result.

    There are no signs of bulging capacitors or any signs of leakage along the lines of
    http://www.vcfed.org/forum/showthrea...Power-Supplies or http://www.vcfed.org/forum/showthrea...acitor-Carnage
    (no stains or corrosion)
    There are no signs of any parts having released any magic smoke, or having got too hot.

    For the record, the power supply seems to be identical to the IPC power supply mentioned in the above links.

    Other PSU identifying information:
    Sun part number 300-1055-07
    Sun (and Sony) part name "APS-02"
    Manufactured by Sony
    Part number: 1-634-165-13
    Rating: 5V 9A, 12V 1.5A, -12V 0.1A

    Before I try to reverse engineer a schematic over the weekend, does anyone have any suggestions or hints?

    Thanks in advance
    mdog69

    PS: The "dead" NVRAM issue has been handled - the original battery was dremmeled/hacked out and replaced by a coin cell some years ago, and, as of a couple of days ago, we are now on coin cell number 2.

  2. #2
    Join Date
    Mar 2009
    Location
    Bainbridge Is., WA
    Posts
    85

    Default

    The PSU on one of my IPCs fails as your did. In my experience, capacitors don't necessarily leak when they die.

    I tried to recap it and failed. Luckily I had a spare IPC/IPX that has become the donor for my running ones.

    alan

  3. #3
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,796

    Default

    I haven't personally seen any IPX supply cap leakage yet, but they're also all getting pretty old at this point, so I wouldn't be surprised if just the caps have lived out their lives and the ESR is too high for them to function anymore. Haven't personally seen it, but it'd be the first thing I'd try. If you're going to have the board out to repair it anyway, you might as well recap, I figure. There's a cap list on my site (linked in those previous threads) and as you've observed the IPX and IPC supplies are nearly identical, so the caps are likely the same -- do verify first though.

    If you're getting absolutely nothing from it, no "typical sick SMPS shutdown click/whine/whatever" noise, I'd start checking with the line side stuff. Fuse first of course Make sure you don't have a blown bridge rectifier. I don't know about this particular supply, but in others I've had the bootstrap cap dry up and fail to start the supply, resulting in no action whatsoever, even though there's plenty of rectified line voltage for the SMPS controller.

  4. #4

    Default

    Quote Originally Posted by glitch View Post
    I'd start checking with the line side stuff. Fuse first of course
    The check got as far as disconnecting the AC connection from the PCB and continuity testing between the IEC power input and the PCB connector.
    This revealed that the one half of the double pole power switch (neutral side) had taken early retirement.

    The switch has been converted to a single pole switch (both neutral wires feeding the switch are now on the same terminal), and the thing powers up fine.

    I suppose it serves me right for assuming the worst.

    Thanks for the pointer to the bootstrap capacitor - will bear that in mind the next time I have a real "PSU failing to start" fault.

    mdog69

  5. #5
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,796

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •