Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Model 2 drive questions

  1. #1

    Default Model 2 drive questions

    I made some progress on my model 2 today. I recapped the power supply and put everything back together today. Power up and got a Boot Error RS message on a pretty bad screen. See attached picture. I looked up the error and it seems to be thinking that it doesnít have a boot disk but it actually doesnít have a disk at all. I tried it with the door open and shut on the drive. Same. I am a complete noob so just poking around I think it must have a drive door sensor that is malfunctioning or there is some junk in it that makes it think there is a disk. Any advice here would be appreciated here. I plan to pull the drive and inspect/clean it. I have read every post I could find so I think I can safely clean this. Does it make sense to think that if I can clear this issue the next message I should see would be the insert disk? Also somewhat related....the screen looks pretty bad but when I tapped the drive door to open and close it it would get stable and clear for a second then go back to bad. This is repeatable so I suspect this might be resolved with the door sensor and a cleaning as well...

    Thanks for all the support

    Nathan
    Attached Images Attached Images

  2. #2

    Default

    Try disconnecting the 50 pin cable from the floppy drive and see what you get. A properly working machine will show the INSERT DISKETTE screen in this configuration. This way you can narrow down where the issue is. I would also try disconnecting the power plug to the drive to see if that has an effect on your screen issue.

  3. #3

    Default

    tried unhooking the driver connector and nothing changes. Unhooked the power as well and no change. Does that suggest a drive controller card issue? The drive spins but the light doesn’t come on regardless of anything I do. It never try’s to seek but I haven’t put any disks in so that might be why? I assumed it would seek when the door was shut. I ohmed out the door switch and it’s good. Checked voltages. I have my + and -12 volts but I only have 4.5 to 4.6 volts on the backplane at either end. Same on the keyboard pin and the disk drive. If this is below tolerance how is it boosted/adjusted?

    Thanks for the help,

  4. #4

    Default

    It appears we've taken the drive out of the equation, which is progress.

    Did you reinstall the cards in the correct order? CPU and FDC must be the first 2 cards in that order.

    Your 5v is low which needs to be addressed. It could be due to a component issue on one of the boards. Try taking measurements with the different individual boards removed. I don't suggest powering up without any boards to ensure proper load is on the 5V. The power supply can be bench tested as per the Model II Technical Reference Manual. Which power supply do you have? There are 3 different ones found in the Model II.

    If 5v is ok then it certainly could be an FDC issue, but could possibly be an issue on the CPU board as well. My next step would be to swap out the FDC and then CPU with a known good boards to narrow down the problem. This was the typical M2 troubleshooting procedure.

  5. #5

    Default

    I have the cards as CPU, FDC, Video, Memory. Unfortunately I donít have any other boards to play with but I do have a bench variable DC power supply I could inject 5 VDC in to see if that fixes anything. Iíll try that tonight. I can also check the FDC card for issues. Failing that I may be sunk. The loose cards I see on eBay are cost prohibitive for trouble shooting purposes.

    Thanks for the tips

  6. #6

    Default

    Plus you don't even know if those boards on eBay work properly.

    You can certainly troubleshoot the cards at the component level. It's just so much easier to narrow down to the problematic card first.

    Hopefully it's all due to your 5v issue.

  7. #7

    Default

    Nathan, where in DFW are you located?

  8. #8

    Default

    Hi there. I’m in midlothian. About 20 miles south of Dallas

  9. #9

    Default

    If you come to the next DFW Retro meetup then you could bring it with you. The last one in January I was able to help someone diagnose the problems with their Model II.

  10. #10

    Default

    I had heard about something like that. When and where are they?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •