Image Map Image Map
Results 1 to 5 of 5

Thread: IBM PC Server 500 Power Supply Troubleshooting...

  1. #1

    Default IBM PC Server 500 Power Supply Troubleshooting...

    So, I have two power supply units for this system and both appear to be dead. The first one worked when I bought the machine, but once I brought it home after a six hour journey and tried to start it up, I got absolutely nothing. No power light, no fan spin, nothing. Nothing popped and there was no smell of burnt silicone, so I'm not sure what happened to it. I wasn't really up to the task of prodding around inside it, so I decided to grab a "refurbished" one (terrible idea in hindsight) off of eBay for cheap. It at least gave me a power indicator and fan spin, but the system still didn't POST and it seemed to be providing inconsistent power (the fans would rev up and down every couple of seconds) and this one did faintly smell of released Magic-Smoke (TM).

    Anyways, one refund later and I now have a fully loaded PC Server 500 with two dead power supplies and no insight into what actually failed in either of them. I've opened both up and, aside from a lot of dust in the original unit, I don't see any traces of anything that burnt, popped or otherwise noticeably failed. I also don't see any obvious solutions like a blown fuse. I've never really done repair work on a power supply before and I'm hoping one of you might be able to give me some pointers on what I should do next to revive one of these, or if anyone knows of any "common failure point" in these units (aside from bad electrolytics). I can post photos of them if you think they'd help.

  2. #2

    Default

    So I've done some more testing and a little research to give you all more information since nice my original post was a bit sparse.

    They're both Astec AA19370 (IBM FRU 06H3596) 438 watt power supply units that I've tested with the load (six hard-disk drives) connected and disconnected.

    The first will immediately start making a "clicking" noise at one-second intervals, during which the florescent light in the room will flicker at the same time it "clicks". The fan in the supply also does not start and trying to run it with no load increases the "clicking" to about five times per second. Judging by it's symptoms, it's pretty obvious this your typical "SMPS stuck in hiccup mode", which means it's trying to start, sees incorrect voltage or a short, shuts itself off and then tries again. I plan on testing the voltages at the system board connector and seeing which one is the problem child.

    The second unit won't exhibit any strange behavior upon being plugged in unlike the first, however it won't start with load connected and with no load the fans (both the supply's and the chassis fans) will alternate between high and low speed. That mentioned, I think I've also narrowed down the problem with this supply, that being If you start these supplies with no load attatched, they'll start in a "No-Load Mode". Now, if it starts in this mode and the light on the supply lights up (which it does), you know you at least have correct voltages, however just because it starts and functions in this mode doesn't mean it will continue to do so when you connect a load to it. I've also learned that the fans, while they only have a positive and neutral lead, are in fact PWM controlled via a controller in the supply and that they should run on a lower speed when the supply is in no-load mode. So taking this into account, the fact that the fans alternate between high and low speed and that it refuses to start under load leads me to believe that whatever is responsible for detecting load and deciding what mode it starts in has failed in some manner. What that is or what component(s) might be responsible though, I have no clue.

    It should also be noted that...

    - Neither supply smelt of burning electronics at any point

    - Neither supply has any internal fuses or breaker that can be manually reset

    - Neither supply is particularly dirty (a fine layer of dust, but that's it)

  3. #3
    Join Date
    Sep 2016
    Location
    Shrewsbury, MA
    Posts
    1,250

    Default

    Clean the computer out thoroughly and check the capacitors on the motherboard to see if any are shorted. Also, I would diconnect any drives or anything not required for it to turn on

  4. #4
    Join Date
    Feb 2011
    Location
    NorthWest England (East Pondia)
    Posts
    2,386
    Blog Entries
    10

    Default

    There is info on the PSU pin outs here:-

    http://www.mcamafia.de/pdf/server_hmm_s30h2501_01.pdf

    if you have two trays of disks you should have the second PSU...

    http://ohlandl.ipv7.net/8641/8641_Power.html
    Dave
    G4UGM

    Looking for Analog Computers, Drum Plotters, and Graphics Terminals

  5. #5

    Default

    Czech if the SCSI drives are jumpered to auto spin up. If they are, disable / open the auto-spin.

    From my DIMM memories, IBM suggests the additional PSU was needed if a second and third bank of RAID drives... So your single bank probably is not the issue.

    I've seen similar hunting from the PSU fans on a no-load 95A. In that particular case, the fan "growled" as the PWM spread out the pulses in order to match the load. OP hooked up drives, and the fan resumed normal operation.

    http://ps-2.kev009.com/ohlandl/RAID/RAID_Cheetah.html

    "brought it home after a six hour journey and tried to start it up, I got absolutely nothing. No power light, no fan spin, nothing."

    Suggests loose cables -OR- perhaps one of the adapters was "cocked" and is not fully seated in the MCA slot.

    Pull all memory, pull all adapters, pull complex. Re-install complex [careful, card edge MUST be in slot!], re-install ONE pair of SIMMs in A1/B1. Boot.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •