Image Map Image Map
Page 1 of 4 1234 LastLast
Results 1 to 10 of 39

Thread: Commodore PET 2001 - Won't boot / random characters

  1. Default Commodore PET 2001 - Won't boot / random characters

    Hi,

    I have recently acquired a Commodore PET 2001 computer and have been having some trouble. At first, it came on but only showed random characters all over the screen. I carefully removed and re-seated all the chips I could find, starting with the memory. After doing this, I was able to get the READY prompt. I was super excited. However, one thing that needed fixed was the power switch was almost impossible to toggle. I guess with age it simply became corroded. I got a replacement rocker switch and replaced it. To do this, I had to completely remove the motherboard while I was replacing the switch. I carefully placed it on my desk so it would be safe. However, after replacing the switch and re-installing the motherboard, the junk random characters were back.

    First, I doubt it but just to rule it out, the rocker switch can't do this right? I mean I checked each of the voltage regulars and I get approx 5V on each of them with the unit powered on - so I assume power-supply wise it's good. I just want to rule it out because that was the only thing that was changed.

    Second, what could cause this? I have read a lot of posts about possible bad RAM/ROM etc., and I saw that the first 2 memory chips are what the OS uses, so if the first 2 are bad the system will not boot. So I carefully went through switching the memory out one-by-one to see if I could find a combo that worked. No success. I did notice that if I remove the video memory chips, I get a grid of squares on the screen - so obviously having the memory in place is doing "something".

    What's strange is, even if I take out all of the memory (leaving the video memory in place) I get the exact same result. The screen is full with random characters. If I turn it off and back on quickly, I can see some of the characters change - but I never get the READY prompt.

    I'm going to create a video later tonight demonstrating what the system is doing, as well as pointing out several things I'm curious about in the hopes that it will help in troubleshooting this.

    I was thrilled to get this computer and have become quite determined to bring it back to life once again. I am hoping one of you can lend your knowledge and experience to help me get it working.

    Thank you so much!
    -Phil

  2. #2
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,343

    Default

    Well, take comfort in the fact that the video section and the monitor are working; you're half way there

    No, replacing the power switch has nothing to do with it. One possibility is that removing and flexing the main board has disturbed one or more of the ROMs or CPU/IO chips; the sockets are notoriously unreliable. Try gently moving all the large socketed chips back and forth a bit in their socket to scrape through any oxidation, maybe even remove, clean and replace if you're comfortable with that.

    Also, for reference, what are the numbers on the RAM and ROM chips?

    Good luck; hopefully it's a simple fix.

  3. Default

    Thank you MikeS! I'm keeping my fingers crossed I will check when I get home from work and let you know. I'm 100% comfortable with doing whatever I have to do. When you say "replace" do you mean literally remove the socket and re-solder a new one in?

  4. #4
    Join Date
    Jun 2012
    Location
    UK - Worcester
    Posts
    3,800

    Default

    Welcome Phil.

    Yes, my guess also would also be one (or more) of the socketed components.

    The random characters on the screen at startup are just a symptom of the random way the contents of the video RAM takes when it powers up. To clear the screen of this random rubbish requires the CPU, ROMs and low RAM to be fully functional. Failure of any of these components will mean that the random rubbish will stay on the screen and never clear.

    Removing the video RAM is exactly the opposite of what you have said. There is no RAM to take a random value, the input to the character generator will be all logic Ď1í which will equate to a specific character.

    Donít forget there are other voltage regulators (other than +5V) - but I will need to check. I am used to an 8032...

    Do you have any test equipment at all (e.g. a multimeter, logic probe etc.).

    Dave

  5. #5
    Join Date
    May 2011
    Location
    Outer Mongolia
    Posts
    2,284

    Default

    A simple problem that might cause this behavior is an issue with the power-on reset circuitry. There's a simple circuit involving a 555 timer and a few capacitors that holds Reset down for about a second after the power comes on to give any glitches a chance to settle; I actually had that stick on a PET I was repairing and the result can be the same "garbage stuck on the screen" result. Replacing one of the capacitors in that section solved it.

    On the plus side, this is a really easy thing to check for if you have even minimal tools. (Multimeter/logic probe on pin 3 of the 6502.)
    My Retro-computing YouTube Channel (updates... eventually?): Paleozoic PCs

  6. Default

    Thank you daver2! I do have some test equipment (very limited). I have a multimeter though and obsessive persistence haha. If you can let me know what other voltage regulars are on there that would be great. I did notice that on the bottom left of the board, directly to the left of the 2 rows of memory, there are 3 components. 2 mounted one way and the last one mounted in reverse. I'm not sure if they're resistors or what, but I'm not sure what they SHOULD be reading as. They seem to bounce around when I test them, and the first and second one get pretty hot.

  7. Default

    Thank you so much! Can you point me in the right direction for this area to test? i will be adding photos of my board along with a video showing the symptoms later tonight. I have a multimeter, but no logic probe.

  8. #8

    Default

    Hi Phil, depending on the overall condition of your board you might only have an issue with bad contacts somewhere. Especially inside the sockes for the RAMs, ROMs, CPU (6502) and I/O Chips (6522, 6520). You need to give them a really good clean!
    If it does not help you may need to check continuity with your multimeter to find sockets with bad contacts. Dont rely just on the beep but look also for very low ohms reading. You may need to replace some of these sockets. As Mike already mentioned they are very unreliable

    As you got already the Ready prompt i would not expect something more serious. Fingers crossed!

  9. Default

    I have posted several images of my motherboard, along with 2 videos trying to demonstrate more of what's happening and what I've already tried. I'm quite new to this, but am a very quick learner and hope to get this figured out. All of your assistance is more appreciated than I can even explain!

    Images: https://imgur.com/a/mVRLNOh
    Video 1: https://youtu.be/QZdjspoeQ6M
    Video 2: https://youtu.be/ttyhZnmGEY8

  10. Default

    Do you have any steps I can follow to test this on my system as well? That way I can rule it out as a possibility.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •