Image Map Image Map
Results 1 to 7 of 7

Thread: Televideo 912c

  1. #1

    Default Televideo 912c

    I am the proud papa of a Televideo 912c. Unfortunately, it does not seem to be in working order. The symptom that I am seeing is that when I power it on it makes a sustained beep. I suspect that this means "something is wrong".

    I've downloaded the operator's manual and checked the dip switches and I believe that I have them all set if not correctly then at least to reasonable values.

    Is there anyone that is familiar with these machines that would be willing to give me some pointers about troubleshooting my issue?

  2. #2
    Join Date
    Aug 2009
    Location
    Oslo, Norway
    Posts
    1,343
    Blog Entries
    3

    Default

    The page on Terminals-wiki also list a maintenance training manual: http://terminals-wiki.org/wiki/index.php/TeleVideo_912
    Perhaps it contains useful stuff?
    Torfinn

  3. #3
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,608

    Default

    Welcome to these forums.

    Re-seated the connectors ?
    Re-seated the socketed chips ?
    Thorough visual inspection ?
    DC voltages out of power supply good ?

    I have a 912B, not the 912C. If the web page that tingo pointed to is accurate, the difference is only in the keyboard.

    Although certain not to be the only cause of a continuous beep, one cause I discovered was the failure of certain RAM chips - see [here]. But in that case, there is a secondary symptom of a screen full of strange characters.

    I have images of the two ROM's at [here].

  4. #4

    Default

    Thank you. I've got a copy of the Operator's Reference Manual, I'll reread through it.
    I've also seen references on the web to a Maintenance Manual, but I've not been able to find a copy yet.

  5. #5

    Default

    Great. Yes, That is my understanding as well, the only difference between the 912B and 912C is the keyboard.

    I will run through your checklist, this is my first hardware project like this (I've traditionally been a software guy.) I'm not getting the secondary symptom but it may still be an avenue worth pursuing.

    Thank you.

  6. #6
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,608

    Default

    Quote Originally Posted by ThomasNSF View Post
    I've also seen references on the web to a Maintenance Manual, but I've not been able to find a copy yet.
    The 'Terminal Maintenance Training Manual' at the web page pointed to by tingo is a collection of technical manuals.
    Section 5 covers the 912, comprising PDF pages 221 to 325.
    In it is also a troubleshooting guide, starting PDF page 401. At PDF page 411, the 912 symptom of 'no video, constant beep' is listed.

  7. #7

    Default

    I had a similar Televideo terminal and it worked for one day after I bought it but the next day it just beeped. I decided to recap all the capacitors even though they all looked fine-- and it solved the problem! It is a very tedious, easy-to-screw-up process so I would recap as a last resort.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •