Image Map Image Map
Results 1 to 3 of 3

Thread: New Osborne Exec wont read any images I throw at it.

  1. Default New Osborne Exec wont read any images I throw at it.

    Hey everyone. I picked up an Osborne Exec yesterday with original manuals and disks, Osborne magazine (I had no idea this was a thing!) but the disks were mostly damaged by age. I put them in my Osborne 1 and it wouldn't read. I tried to put the .tdo images from RetroArchive and convert them to something my Gotek can read but nothing will boot. Boot error every time. Any ideas?

  2. #2

    Default

    I finally got some verified boot media for my Osborne Exec and I still have the boot issues.

    I had already cleaned the floppy drives and lubed the rails. But I forgot to clean the floppy drive contacts, so I tried that. But no go.

    I swapped A: and B: to see if it was just a drive A: issue, but nothing.

    I did a visual inspection of the drives (loose connections, puffy capacitors, etc.). But nothing. Checked the drive cable for breaks of "kinks". Nope.

    Everything pointed to the floppy controller. So I looked at that today. Sure enough, the MB8877 floppy controller chip is **very** corroded. I'm going to try to clean it and see if it works, but I verified that the MB8877A (which is still available today) will work as a replacement and found a couple on eBay for $15. I'll see if that fixes problem.

  3. #3
    Join Date
    Mar 2013
    Location
    Chaffee, MO
    Posts
    1,609

    Default

    ivanthetolerable,
    If you will email me the *.TD0 you want converted for the GOTEK, I can take the .TD0, create, the
    *.IMD, and from that a .RAW (Sector Dump) Image, which will give the Directory Listing.
    Then I can convert the .RAW Image to a GOTEK Image that is bootable. I have the definitions
    for Osborne for creating the configuration file to dump along with the *.HFE image. It should
    boot on your Osborne.

    Larry

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •