Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Pet Rescue

  1. #11

    Default

    My 6540 adapter boards appear to have the same configuration as Mike. They have gone straight onto the board and worked without any mods.

    Andy

  2. #12
    Join Date
    Dec 2012
    Location
    Brandon, FL
    Posts
    121

    Default

    Wow, yeah, NOT what i got.. I ordered 10, and they are all of a different design..




  3. #13
    Join Date
    Dec 2012
    Location
    Brandon, FL
    Posts
    121

    Default

    So here is the two versions side by side.. mine have Copyright date of 2012 on them, maybe old stock?


  4. #14
    Join Date
    Dec 2012
    Location
    Brandon, FL
    Posts
    121

    Default

    Quote Originally Posted by MikeS View Post
    Boy, I don't know what you've got there but it sure doesn't match my DIP '138 version of the 6540>27xxx adapter; mine are the same as the SMT version except pins 3 and 1 are swapped and pin 9 is the select output instead of pin 12:

    2 > 5
    3 > 4
    4 > 1
    16 > 6
    17 > 3
    27 > 2
    yep, swapping pins 1/3 would result in Y6 being L instead of Y3 , so that is valid as well.

    im going to have to look at it and see what i can do to salvage these, since the pet doesn't use have the CS lines anyways accept the /CS4 , /CS3 and CS1 , i could also omit CS1 & /CS3 if i tie an address pin to BA11. and then stack a complete 32K and get full 32k block on one chip, so would only need 4 eeproms ( C000-CFFF ), ( D0000-DFFF ) , and ( F000-FFFF), i would still need to wire /CS3 and CS1 for E000-E7FFF , as e800-efff is mapped to IO space.

    or can just wait for romulator to show up.

    i will just toss these in the bin , not sure what good they are

    or can just build my own rom replacement pcb ( i have blanks for another project ) .

  5. #15
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,338

    Default

    Yup, that was my suggestion; forget the resistors & '138, add a couple of jumpers and use 3 x 32K EPROMs; just make sure you put them in the right socket. No issue with the E ROM, just use a 2716 which will ignore the upper half of $Exxx.

    Hope Jim sees this thread and comments.

  6. #16
    Join Date
    Dec 2012
    Location
    Brandon, FL
    Posts
    121

    Default

    Mike, Yep, I just finished up mocking the pinout, and wiring up these pcb(s), way easier to just ditch the 138 and resisters, here was the layout.



    This basically put the adapter at the high address.. ( using CS1 instead of /CS3 for bank select )

    Construction of the adapter(s).







    I re-used the one i already had with the LS138 as the E000-E7FF bank.

    After being installed and booted up:





    Success! now i can use my SD2PET.



    Since, i only really bring this out to events for people to play, really don't need the romulator now, ( which hasn't arrived ) , but will keep until the day my ram dies

  7. #17
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,338

    Default

    There ya go! Very nice!

    Still hope to hear from Jim about those odd adapters; might email him directly.

  8. #18
    Join Date
    Dec 2012
    Location
    Brandon, FL
    Posts
    121

    Default

    I emailed him, and i made a comment on his website, I have not heard anything, i even included the link to this post.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •