Image Map Image Map
Results 1 to 4 of 4

Thread: ISA USB board

  1. #1

    Default ISA USB board

    Based on a very old thread on this forum and some other threads I found online, I thought it might be fun to try to get an old XT going with a ISA USB board based on the CH375 IC. I found one on Taobao in China and managed to wrestle through the Google Translator to actually make the purchase. To my surprise it showed up a couple of days ago in my mailbox!

    So I'm trying it out with a multitude of different USB drives (all partitioned with a single partition < 512MB in size, formatted as FAT, not FAT32). I tried the V1.9 and the V2.0A drivers I was able to find online, but none of them seem to be willing to do anything useful beyond throwing errors. It's definitely seeing the board (if no USB is plugged in, it tells me no disk found). If I plug in a USB stick, I get one of three behaviors: a) Bootsector error, b) Data error, c) Freeze.
    I tried both the IRQ and the NOINT versions of the CH375DOS.SYS driver, but no luck either way. I also tried 3 different USB sticks (256MB, 1GB, 8GB -- all partitioned and formatted as described).

    Long shot -- does anyone have any idea how to make this work?


  2. #2

    Default

    Try it in a more modern PC, 486 - early pentium, Somebody had one of those working but i can't remember who it was, There are threads on this forum somewhere, I think the flash drive had to be formatted as a zip disk ??, I don't have the chinese card, I have the lo-tech experimental isa-usb card that never went into production sadly.

  3. #3
    Join Date
    Oct 2014
    Location
    near frankfurt/m, germany
    Posts
    1,054

    Default

    Which DOS-Version? Up to 3.x no support for partitions bigger than 32 MB.

  4. #4

    Default

    I was using DOS 6.22 on a NEC V20 machine. But Iíll give it a go on a 486 I have here as well. Would be too bad if I canít get it to work on the XT clone I had it destined for though ..

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •