Image Map Image Map
Results 1 to 3 of 3

Thread: Problem Dual Booting NT 3.1 and 3.51 (and maybe 4.0)

  1. #1

    Default Problem Dual Booting NT 3.1 and 3.51 (and maybe 4.0)

    Spent some quality time today playing with my "new" AT&T/NCR 3430. Tried installing NT Advanced Server 3.1 but ran into problems (bad disk image I acquired?) but got Workstation 3.1 working. After a bit of tinkering I installed NT WS 3.51 onto another partition. Got it running and updated, fixed a networking issue, then tried to boot back to NT 3.1. It starts out with NT Loader 3.51 (which I thought odd), goes to the blue screen showing the computer, NT 3.1, 64Mb RAM, and 2 CPU's (yeah, it's pretty cool!), and then it blue screens with a STOP 7b INACCESSIBLE_BOOT_DEVICE. 3.1 is on the C: partition, and 3.51 is on D:. The boot.ini lines are a little different, 3.1 starts with scsi rather than multi or something like that, along with something about SCSI at the end of the line, whereas 3.51 starts with multi I believe. Changed it to the 3.51 format and no change. Guessing the 3.51 install broke something somehow...

    Before I spend too much time beating my head against the wall, has anyone else ever tried to do this and/or have any thoughts? From a brief bit of googling, sounds like it ought to work...but there's also not much in the way of info out there about NT 3.1!

    If I can get it to work, I think it would be neat to have as many NT versions as possible installed on it...at least 3.1, 3.51, and 4.0, maybe even server versions of at least the latter two.

    Thanks,

    Wesley

  2. #2
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    3,514

    Default

    Just off hand, installing NT 3.51 would have updated the NT loader. That is normally the only shared piece between multiple NT installs. I have no idea if the NT 3.51 loader actually supports loading NT 3.1, but it may not.

    Try creating a boot floppy with the NT 3.1 NT loader, and see if that will start NT 3.1. You will need whatever line was originally in the boot.ini file and put that on the boot.ini on the floppy.

  3. Default

    I have setup multiple versions of NT on one partition, but not on separate ones. Not sure if that is the issue though, it might be that NT 3.5 NTLDR just can't boot NT 3.1.

    Try to dump the boot sector from C: and add that as a menu option in the BOOT.INI on D:

    Then you can get into the 3.1 NTLDR and try to boot 3.1 from there.

    When using one partition (like I do) you have to use a trick to make multiple versions of NTLDR available. Get a copy of the old one and name it something different like NTLDZ. Then also make a copy of the boot sector and open it in a hex editor to find the string 'NTLDR' and change it to 'NTLDZ'. Then add that boot sector as a menu option in BOOT.INI

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •