Image Map Image Map
Page 1 of 5 12345 LastLast
Results 1 to 10 of 41

Thread: Problem with Seagate ST-225 type 2 hard drive

  1. #1

    Default Problem with Seagate ST-225 type 2 hard drive

    Hi,

    I am trying to fix a Seagate ST-225 type 2 hard drive. It is a 20 MB drive. The controller is 62X0775 with 4 switches.

    Problem: the drive is reported by the BIOS, but programs can not use it. Programs report problem with MBR.

    The BIOS does not report 1701 error. It reports a 601 floppy errror, but the floppy works.

    Switches on the controller are correct. Cable is OK. I tried LLF:
    - debug - it returned immediately with some result, so it did not have any effect
    - IBM Advanced Diagnostics Disk - gives an error and it returns immediately

    What I noticed is that the stepper motor only turns on power on with a beep and when using the "Measurements Test" in the IBM Advanced Diagnostics Disk. Nothing else makes it move. Programs like fdisk.exe and part.exe do nothing.
    It seems like INT 13 is not handled ... Not sure where the problem is ... the HDD or the controller.

  2. #2

    Default

    can you perform the seek test in the IBM diags?

  3. #3

    Default

    There two things:
    0 - FIXED DISK TEST - (Tests the Fixed Disk Drive Adapter and the fixed disk drive (C or D) read and write operation)
    1 - MEASUREMENTS TEST - (RUN MEASUREMENTS TEST: Provides a test signal to measure voltage levels at selected test points)

    The FIXED DISK TEST gives an error "CHECK DRIVE AND ADAPTER".... Then the MEASUREMENTS TEST makes the stepper motor spin, but it does not output anything.

    The guy who sold me the computer told me that the disk worked at least one time he tested ...

  4. #4

    Default

    What error does the LLF from the advanced diag floppy give?

  5. #5

    Default

    It does not give an error.

    CHECK DRIVE C: AND ADAPTER
    ERROR -
    1 FIXED DISK DRIVE(S) & ADAPTER 1715 S

  6. #6

    Default

    I’m assuming this is a 5160, right? Have you checked the cabling and termination is correct?

    http://minuszerodegrees.net/ibm_xebe...bling_info.htm

    Also do you have the switches set for that drive type on the controller? According to here drive type 2 should be off on.

    http://minuszerodegrees.net/ibm_xebec/ibm_xebec.htm

  7. #7

    Default

    Yes.

    It is a straight cable with IBM "20MB Fixed Disk Drive Adapter" 62X0775. My jumpers are set for type 2 20MB drive. I do not see a terminator in this case ?

    Here are some photos of both controller and drive: https://drive.google.com/drive/folde...PHjTaauT2d97Xk

    My IBM BIOS ROM on the controller is 61X9279.
    Last edited by tonata; September 3rd, 2020 at 12:40 PM.

  8. #8

    Default

    Looks right to me. The terminate is that yellow resistor array on the bottom of the drive in your photo. With the untwisted cable you should have the drive select jumper set for the first option, which according to your photos looks correct too.

  9. #9
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,831

    Default

    Quote Originally Posted by tonata View Post
    Not sure where the problem is ... the HDD or the controller.
    So both controller and drive are under suspicion.

    Quote Originally Posted by tonata View Post
    The BIOS does not report 1701 error.
    Can you confirm that the controller's BIOS displays 1701 when no drive is attached.

    ( On my IBM 5160, after the POST completes its RAM test, it takes about 30 seconds before the IBM/Xebec controller displays 1701. )

  10. #10

    Default

    Yes. It reports 1701 after 20 seconds.

    It is a XEBEC variant 3 and HDD type 2.
    DOS sees the disk in general through the BIOS but all calls to the disk seem to fail.
    I also tried another cable. The disk has not been damaged or rusty ... it spins, beeps, the stepper motor is not stucked ...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •