Image Map Image Map
Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 40

Thread: USB internal from GCT-8IT not work

  1. #11


    430TX boards generally had working USB, but the headers might still not been standardized. I would verify the pinout of the USB header again, and also verify that you or the previous owner of the board didn't accidentally blow out a pico fuse on the USB channels. With an Award BIOS, you should see an IRQ assigned to the USB UHCI controller on the hardware summery screen (if its enabled properly) just before the machine boots into an OS.

    The BIOS should have an option to turn on/off the onboard USB controller. There is also a BIOS for this board floating around that may be newer, but the image is compressed and doesn't show any date when looking at the file.
    Last edited by njroadfan; September 20th, 2020 at 02:37 PM.

  2. #12


    The connector is good, I tested the voltage so that it is not inverted and I tested by inverting the D + and D- and it still does not work.

    I don't know where the USB fuse is. In device manager under win98 the assigned irq is 11 and before the start I have Service USB Controler IRQ 11 only

    There is no option in bios to enable or disable the built-in USB controller. My BIOS is dated 08/19/97.

    I tested another BIOS which dated from 98, it is a BIOS EVALUATION ROM, NOT FOR SALE, there are still no options in the BIOS to enable or disable the built-in USB controller, and it doesn't work still not under win98.

    If you have a newer official BIOS that would be of great interest to me. My motherboard is the GCT-8IT and not the GCT-8ITB

  3. #13


    Any idea ?
    no one has this card with a newer bios?

  4. #14


    I had thought of a usb fuse but when I plug in an optical mouse it lights up,
    the light is red, there is indeed + 5v, so it cannot be a fuse at the usb level.

  5. #15


    Did you try a Linux disc as Chuck suggested ?, If not try NSSI for DOS and see what that shows.

  6. #16


    i tried ubuntu 5.10 live, everything is recognized, intel usb chipset is recognized, but when i plug in for example a usb stick, it is not recognized,
    nothing happens. I launched the NSSI program, it is identical, everything is recognized at the hardware level ,
    intel 430TX, intel 82371AB / EB / MB PCI to USB Universal Controller etc ...

  7. #17


    How old is the USB stick you tried and what size is it ?, UHCI controllers are pretty Dumb ass controllers, The smarts for those need to be in the driver's, I don't know how smart the drivers are in Linux for UHCI. If you have a really old USB Stick 2 Gb or less try that.

  8. #18


    i have tested usb stick cruzer, mouse usb, smart card reader ...
    but if I needed drivers, they should detect what I plugged in and suggest I look for drivers. Nothing is detected.

  9. #19
    Join Date
    May 2009
    Blog Entries


    You will need a device that has an UHCI transceiver. Many newer (USB 2 or 3) devices don't have the ability to fall back to USB 1 and some that do use the other USB 1 implementation OHCI. Also, many devices need more power than the early USB ports were provided.

    Early USB mice, USB floppy drives, and card readers that are limited to 2 GB or lower capacity SD cards have the most chance of being seen with the USB 1 ports. If the USB device was made before 2000, it has to be using USB 1,x and will have either UHCI or OHCI so it is still possible to find a working USB 1 device that won't work with working USB 1 ports. Some have both UHCI and OHCI support but there is no way I know of to guarantee getting a device with complete USB support. This all makes finding out if a given port works more of a challenge than it should be.

  10. #20


    Quote Originally Posted by andromeda92 View Post
    i have tested usb stick cruzer, mouse usb, smart card reader ...
    All of which UHCI has poor to no support for newer hardware

    Nothing is detected.
    I don't have a Ubuntu 5.10 live CD, Being such an old version does it automatically Mount flash drives when plugged in ??, Or have they got to be mounted manually, Linux is not Windows.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts