Image Map Image Map
Page 1 of 9 12345 ... LastLast
Results 1 to 10 of 89

Thread: Faulty 8032-SK with no V-Sync - Gary

  1. #1

    Default Faulty 8032-SK with no V-Sync - Gary

    Acquired a 8032-SK that spend many years in a barn in a coastal city. This has caused a fair amount of corrosion on the IC pins that are socketed, to the point that many of the pins literally fall off. This is on top of the hornets nest inside the machine!

    First order of the day was to remove the built-in bomb but, after doing that, no joy in booting it up. Did a few things:

    1. I replaced the CPU and Character ROM that both lost pins (the pins literally fell off!) but the machine does not start.

    2. Installing one of Dave's (from Tynemouth) RAM/ROM replacement cards, and mapping everything out, gives the startup beeps but no display.

    3. Looking at the video output signals, on the header connecting the monitor, I get H-sync but no V-Sync nor Video.

    4. The RAM/ROM replacement card has a copy of (other) Dave's PETTESTER in it and if I select that, I get H-Sync and Video output but still no V-Sync.

    5. I see the 7486 XOR that drives the video connector is socketed, so it looks like someone's worked on it before. Checking the input to the V-Sync XOR gate, shows no activity. So it seems the CRTC is not generating a V-Sync signal.

    Any idea where to look next? Seems either the CRTC is not being set up or it's faulty?

    Gary - Copy.jpg
    Not a bad looking 8032-SK, taking into account it was in a barn for decades.
    Hornets nest.jpg
    Think the drivers that must operate the chips, all left.....
    Universal board with a Tynemouth board installed, allowing it to boot - but no display.
    V-Sync Signal.jpg
    Getting H-Sync (blue) and Video (yellow). This is with PETTESTER. Normal bootup gives H-Sync but nothing else.

  2. #2
    Join Date
    Jun 2012
    UK - Worcester


    The (other) Dave here...

    Good detective work so far.

    Yes, a socketed UC2 probably indicates that someone has been working on it as you have already guessed.

    I assume you have already done this, but check the VSYNC output pin (40) from the CRTC itself UB13. If you have an open circuit PCB track (or a faulty connection) this may flush that out.

    Power off and check for an accidental short circuit from UB13 pin 40 (VSYNC) to 0V or +5V. Or even a short circuit to anywhere else locally. If someone has worked on UC2 it could be there is a solder splash short circuit somewhere.

    You could also try removing UC2 (as it is in a socket) and see what effect that has. I can see two (2) gates of IC2 used on schematic 10 of the UNIV2 - but not where the other two (2) gates are used.

    It may also be worth scoping the other output pins of the CRTC (UB13) - TAn and RAn and see what you are getting.

    Two possibilities then:

    1. A dead CRTC.
    2. The initialisation data is not getting to the CRTC correctly (corroded Dn pin on the CRTC). Again, check for continuity from the data pins of the CPU to the data pins of the CRTC.


  3. #3


    Thanks Dave,

    I need to figure out how to get to the CRTC with the Tynemouth RAM/ROM board plugged in as it obscures the CRTC.

    As a quick check, I did pull the XOR from the socket but did not see any signals on the inputs of the XOR gate pins on the socket. Your idea to measure for shorts makes sense, will definitely do that.

    What is interesting is that, if I boot with the normal ROMs enabled, I get H-Sync but no Video (in addition to not getting V-Sync). When I boot with the PETTESTER embedded in the TyneMouth ROM, I do get Video (but still no V-Sync). This seems to imply your PETTESTER somehow get the CRTC to generate video where the Edit ROM does not.

    I also want to try your latest PETTESTER (V04, I think?) and see if I can configure the Tynemouth board to allow the PETTESTER to run from the Edit ROM socket and then check if it manages to configure the CRTC.

  4. #4


    A further update on this;

    I switched to the Tynemouth PET Diagnostics board that plugs into the CPU sockets and exercise the 8032 board.

    Checked for shorts, continuity, etc. Also reflowed the CRTC pins.

    Still don't get V-Sync on pin-40 of the CRTC and also get no output on the RA0-RA4 outputs. These drive the lower 3 bits of the Character ROM address bus. The TA0-9 outputs do show data (at least on TA0-6) though.

    Inputs to the CRTC does look right, it's getting Clock, Reset, CS, Data, etc.

    Trying hard here not to have to take the CRTC out but it does seem to indicate a fault with the CRTC itself?

  5. #5


    Another update.

    I traced the circuit quite a bit and it does look like the CRTC should be set up but it is not successful. Some of the outputs of the CRTC seems dead, including the output pins that drive the Character ROM address lines. So I decided to replace it with a 6845 I pulled of an CGA card.

    First question; Is the 6845 OK to be used on the 8032? From what I can read there are differences between it and the MOS 6545. But are these significant?

    With the 6845 installed, I get the following:

    1. With the Tynemouth PET diagnostics board, I now get text output. It passes most of the RAM and fails all the ROMs. But I'm getting video output!
    2. With the Tynemouth RAM/ROM replacement card (and everything mapped out), I get the startup tone but no text display. Both H and V-sync are present but no Video output.
    3. If I switch the RAM/ROM board to the inbuilt PETTESTER, I do get Video output.

    Any idea what could be causing this? My understanding is that the diagnostics programs still use the video generation circuitry around the Character ROM, VRAM, etc.?

    The new 6845 installed with the Tynemouth PET diagnostics

    Output text from the PET Diagnostics board

    PETTESTER on the Tynemouth RAM/ROM replacement board

  6. #6


    Yet another update (this is the 3rd update over the last few days but still awaiting the moderators to approve )

    I found a socketed 6545 in another 8032 and tried that in Gary (the 8032 under repair).

    Getting exactly the same symptoms, Video output with the diagnostics setups but no video output with just the system ROMs (via the Tynemouth RAM/ROM replacement board).

  7. #7
    Join Date
    Jun 2012
    UK - Worcester


    I see a whole load of approved posts now !

    Keep posting, you’ll hit the ‘magic’ level before too long...

    Your video circuitry is now working OK, as is your RAM.

    The next thing to look at is why your ROM is faulty.

    It looks like either every ROM is faulty (major bit rot) or the address decoder for the ROMs is faulty.

    Looks like the CRTC was dead then.

    Getting there...

  8. #8
    Join Date
    Jun 2012
    UK - Worcester


    I would check the inputs and outputs from UE12 (4 to 16 decoder).

    It will be easier to use a NOP generator for this test.

    It is also possible that one of the buffered address lines is faulty. Again, a NOP generator will prove or disprove this. However, for this to be true, it will depend on how clever the RAM test is at detecting an adress fault.

    I can give you more information on how to perform this test if you wish. You need to identify the circuit for a 6502 NOP generator, or acquire a spare 6502, bend the eight data pins out and strap the to +5V or 0V (using low-valued resistors). A 6502 NOP is $EA = 1110 1010. 0 pins are connected to 0V and 1 pins are connected to +5V. 100 Ohm resistors should be good to use.


  9. #9


    Yup, I think the problem might well be with the decoder. The Tynemouth PET diagnostic does a CRC 16 times per ROM and reports the CRC as 'inconsistent', i.e. it changes all the time. If I plug a new ROM into the Editor socket, it also reports as inconsistent.

    Never played with a NOP Generator though I get a feel on how it will work. Going to Google a bit and see what I can do.

  10. #10


    A bit of a side-story with more errors on this board

    In addition to the inconsistent CRCs, I noticed the Tynemouth board also reported Reset stuck high and IRQ stuck low. It's also reporting RAM issues with the VRAM (and one can occasionally see random characters on the screen) but I'll fix that a bit later. Probably one of the 2114 chips.

    The stuck Reset line, I traced to a faulty 555, and is now working properly. Quite cool that the PET diag board measures the reset timing.

    The stuck IRQ is probably a bigger issue. From reading the circuit it seems the IRQ is driven by the VIA and two PIAs. So one of these chips is probably pulling this line low. Will go and sniff around them to see if I can see something but suspect I might have to socket them.

    1. The IEEE PIA (UB16) is already on a socket and makes no difference if I pull it. IRO stays stuck low.
    2. Getting the startup chirp so at least some of the VIA (UB15) must be working.
    3. The Keyboard PIA (UB12) is the last one driving IRQ. Is there a way one can short a key and see if it generates an Interrupt?

    Reset stuck high and IRQ stuck low.
    IRQ Stuck.jpg

    Reset fixed, now to look at that IRQ.
    IRQ Stuck-2.jpg


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts