Image Map Image Map
Results 1 to 5 of 5

Thread: Linux support for C-H trackballs.

  1. #1
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    35,320
    Blog Entries
    18

    Default Linux support for C-H trackballs.

    Here's a strange one.

    I have two C-H Trackball Pro devices; one PS/2 interface and the other serial.

    If I use either and boot Windows 95-Win7, the trackballs are recognized and function as they should. I'm using a PS/2 interface keyboard, FWIW.

    If I boot any version of Linux from about 10.04 on (I haven't tried earlier ones), Linux is blind to both devices. If I plug the PS/2 one into a USB converter, everything is fine and Linux has no issues.

    Can anyone shed any light on this connundrum?

  2. #2

    Default

    For serial mice you'd need to do something like "inputattach --microsoft /dev/ttyS0" where /dev/ttyS0 is your serial port (whichever it goes under). As for the PS/2 port, that's an odd one, it should just work.
    IBM PS/2 Model 25, NEC V30 8MHz, 640KB RAM, ATI VGA Wonder XL, 2GB SSD, Ethernet, DR DOS 6/GeOS, Xircom PE3 Ethernet

  3. #3
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    35,320
    Blog Entries
    18

    Default

    Apparently you can also edit the xorg.conf file, but in Debian Squeeze, I can't find it--it's definitely not in /etc/X11.

    I guess I'll have to run Xorg --configure to get it. Strange that it wasn't part of the installation.

    (This is an old K6-2 500 system, so I'm somewhat limited on OS choices).

  4. #4
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    35,320
    Blog Entries
    18

    Default

    I tried the xorg.conf modification and it did nothing. Online documentation seems to imply that this method is deprecated. Okay...

    I'm running Debian Squeeze on this system. "inputattach" is not a package installed by default; so it's "sudo apt-get install inputattach" first. Edited the rc.local to include "inputattach --daemon --microsoft /dev/ttyS0", reboot and all is well.

  5. #5

    Default

    Quote Originally Posted by Chuck(G) View Post
    I tried the xorg.conf modification and it did nothing. Online documentation seems to imply that this method is deprecated. Okay...

    I'm running Debian Squeeze on this system. "inputattach" is not a package installed by default; so it's "sudo apt-get install inputattach" first. Edited the rc.local to include "inputattach --daemon --microsoft /dev/ttyS0", reboot and all is well.
    I'm glad inputattach worked. Yea, the xorg.conf setting is well deprecated. I wasn't sure which distro you were using but I'm glad the guess worked.
    IBM PS/2 Model 25, NEC V30 8MHz, 640KB RAM, ATI VGA Wonder XL, 2GB SSD, Ethernet, DR DOS 6/GeOS, Xircom PE3 Ethernet

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •