Image Map Image Map
Results 1 to 7 of 7

Thread: ADTPro serial configuration crashes with Java error

  1. #1

    Default ADTPro serial configuration crashes with Java error

    Hi All,

    I am experiencing a problem with ADTPro and wanted to see if anyone else has seen this and knows a solution.

    So I have an apple IIe with a Super Serial Card and wanted to use ADTPro in serial mode. My laptop is running Java runtime version 8.0 with ADTPro version 2.0.3. I have tired it using the regular serial port on the docking station and using a USB to serial adapter.

    Without anything connected to the serial ports if I start ADTPro and click on serial it asks me for the serial port to use and the speed. As soon as I click OK ADTPro crashes and Java generates an error log that Java has experienced a fatal exception error. This occurs in exactly the same manner if I have the serial cable connected between the laptop and the IIe.

    Anyone seen this and/or have a suggestion? I didn't want to upload the java error log etc and turn this post into a novel until I found out if this is a common place error with an easy fix.



  2. #2
    Join Date
    Jun 2012
    UK - Worcester


    Hi Gordon,

    We don’t necessarily need the entire Java error log, just the lowest-level couple of errors may be sufficient to identify what the problem is.


  3. #3


    First, what version of Java 8.0 are you running? It got over 100 updates, so please tell us the exact version number.

    Did you try anything at all so far, like resetting Java to its default values or anything?

    Also, what OS and what brand of USB adapter and drivers?

  4. #4


    Hi Guys,

    It is the full version of Java I was using is Version 8 Build 271 (Build 1.8.0_271-b09). I uninstalled Java and downgraded it to version 8 Update 202 (Build 1.8.0_202-b0 and everything works perfectly now. Looks like the problem is with Java.

    If there is a sticky thread relating to ADTPro it might be a good idea to notate this in there somewhere.

    Thanks for the Help


  5. #5



    I replied to this, but for some reason the moderator never approved/posted it. Anyway I solved the problem it turns out it was the version of Java I was using, by going back an few iterations to build 202 I think ADTPro worked perfectly.

    Thanks for the help.


  6. #6


    Same error and same soluction, the problem is the news java versions not working with AdtPro

  7. #7
    Join Date
    Aug 2008
    Burlington, VT


    Should consider dropping David Schmidt a note and let him know about the issue.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts