Image Map Image Map
Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Dead Toshiba T4500C

  1. #11

    Default

    Thanks for your input T-Squared!

    The bookmark icon vanished. I noticed that ribbon cable for floppy drive was loose. some pins maybe contacted wrong places there. I corrected
    it and no more bookmark icon. I have to find out a way to attach that ribbon cable well. Originally it is pressed down and hold in place by tiny
    plastic clip. I knew when I tried to open it, that this will break very easily. tried very carefully pry it open knowing that and it broke anyway.
    Perhaps, if the plastic was new it was possible to open without breaking, but the old plastic is extremely brittle and for me not possible to open without breaking it.

    About the cable pads... in my previous post I attached 6.jpg. In that upper corner there is definitely some sort of corrosion going on.
    It looks like maybe someone did try to fix that earlier. Is this part the 'pad' you are referring to ?

  2. #12

    Default

    Yay !

    This makes me happy
    9.jpg

    I did give some heat with my soldering iron to the upper left corner contacts. At first nothing, but then
    I heated one pin more and then I seem to have result there!

    I left the big battery charging over night and indicator shows 100% now.
    10.jpg

    who knows, maybe it hold the laptop on for 50 seconds or so? But no matter, I was curious if it has any change
    by trying to charge it.

    But the next issue to tackle, why it wont boot ? Not from a hard drive, nor from boot floppy. It does not seem
    to make big effort, just gives error about missing basic.

  3. #13
    Join Date
    May 2011
    Location
    San Antonio, TX
    Posts
    377

    Default

    Yes, the short brown cables with the multiple silver pads. That does not look like corrosion to me. I think it is flux. (Used to make solder clean and shiny.) Flux is ok, and helps with connections, but you have to clean it off after use. (The other person who used it did not.)

    I can offer some advice to fix that cable. But DO THIS AT YOUR OWN RISK. (Don't get angry at me if it doesn't work.) If you can't do this, try to ask someone who does know how to do it.

    It might be hard, but if you can, put your screen on a surface where it will not be scratched, heat up your soldering iron if you have one... (And make sure the tip is clean, no black burned stuff on it, and use more flux if you can!)

    1. Take a small wooden stick (About 1.5 mm in thickness. Maybe a tongue depressor will work), and, with the edge of the stick, press down a bit on the cable close to the solder pads, between the rectangle in the cable and the solder pads on the green board. (NOT ON THE SIDE WITH THE SCREEN GLASS)
    2. If you touch each of the solder pads on that cable with the iron for one second or two, just enough to melt and turn shiny, you might be able to solder those cable wires back into place, but don't move the soldering iron side-to-side! (You might misalign the wires if you do.) Just press down lightly with the iron. Also, don't be scared about the soldering iron touching the brown cable. That is very heat-resistant.

    helpfinal.jpg


    OH! YOU DID IT!

    Yes, that was not corrosion. If the corrosion melted into a brown liquid, then that's flux. That's for making solder clean and shiny.

  4. #14

    Default

    Ah, you had discussed this at another topic already =).

    The bios of this laptop is very lacking. No boot order, nothing about the floppy.
    Hard drive options are: 510Mb drive or no drive at all. I cannot even specify cylinders, heads or sectors. it's just hard drive of that
    type or none at all.

    It spins the hard drive and spins the floppy on the floppy drive. But I can't hear head seeking the floppy at any point. I might need
    to try to open the floppy drive and see if the head is very stuck.

  5. #15

    Default

    I opened the floppy drive and confirmed that floppy stepper motor is not moving.
    I can freely spin the stepper axel so it is not stuck. Drive does spin the disc.

    I think this unit only requires +5V (based on the manual). So again, I don't think it is another power supply ussue.
    Hmm. I wonder what to try next.

    Edit:

    Well, I got the head moving during start up by pressing the cable firmly at its connector.
    I cleaned the heads and gave a drop of oil to the stepper axel and the rail.

    During boot, it will spin the disc and sometimes (not always) tries to move the head.
    Sometimes head may go from one extreme end to the other.

    And finally, we are always back to "please use toshiba basic".

    I've got a bunch of floppy drives, but of course none of them fits to this laptop. Of course,
    the issue might be elsewhere than the floppy drive itself.
    Last edited by VintageVic; November 26th, 2020 at 07:41 AM.

  6. #16

    Default

    I tried the floppy. tried and tried, but no luck with it even after cleaning. No difference
    with using DD floppies either. just no luck with it.

    Then it occured to me that what if I put the hard drive to a desktop computer and see if
    it would work there. Since I can think of only two ways to get this thing booting (floppy or hard drive)
    it's only fair to entertain both options. But is it even IDE drive ? Quick googling revealed to me that it is.

    You'll need adapter to connect the drive to an IDE cable though. I thought I might just have one such thing
    and how fortunate, I was able to find it! Then to test with the desktop PC.

    First things first, the BIOS. It did recognize the drive automatically immediately. However, the PC would not boot from it.
    So I booted the desktop from a floppy. Went to C: drive and checked what DIR says. Empty! formatted, but completely
    empty. No wonder the Toshiba would not boot from it.

    Just in case, I removed any partitions, made new one and formatted the C: drive with dos 6.21 boot disk. Then
    I copied the autoexec.bat and config.sys there and the rest under c:\dos.

    Desktop would boot from the hard drive now. Aaaand.... SO WOULD THE TOSHIBA =D.

    BUENO.jpg

    Muy bueno, muy bueno indeed .

    I tried to read floppy after that, but still no luck with it. Heh, maybe it is broken after all.
    A bit harder to transfer media to the Toshiba, but now I'm confident that it will be a working laptop soon!

  7. #17

    Default

    Okay, one last visit to this thread.

    The floppy drive seems to be defective but other than that, Toshiba is fine now!
    I have put some media to it's hard drive and assembled the laptop. Tried out that
    external mouse and keyboard work too. Did not try the trackball mouse, but I will.

    I'm very happy about bringing back the dead laptop, eventhough I'm missing floppy.
    Made a 'how to fix P30 error' video to youtube, starting from the point when I got the Toshiba:

    https://youtu.be/OlGaYucskGQ

    Very first tutorial video of mine, I have lessons to learn from speaking english to how to hold
    the camera and about lighting... but if it helps someone with similar problem, I'm glad.
    If it gets views, maybe I will try to make similar (but improved) how to -videos about fixing
    or building other vintage stuff as well, since I'm often tinkering with something.

  8. #18

    Default

    Quote Originally Posted by VintageVic View Post
    No longer P30 error, but the little display shows "ON" symbol. And some strange 'faucet' symbol, what ever that means ?
    I think also, the floppy symbol comes on and goes away, probably it is trying to see if anything is at the floppy drive.
    The faucet symbol is the power consumption level, as configured in the BIOS (full speed, balanced, low speed, user-defined). It can be changed by a keyboard combination at runtime.

    Quote Originally Posted by VintageVic View Post
    Of course, the bios battery is dead and the unit has forgotten what hard drive it is attached into. That is why it will not boot.
    If I remember correctly, these devices do not actually have a BIOS battery.

    Quote Originally Posted by VintageVic View Post
    I see the cursor is there, but not what is above it. Most likely and error like 'non system disk or disk error, insert boot disk'.
    More likely, the message is about a missing ROM BIOS. That message appears when booting fails (e.g. when the hard drive does not have a partition marked as bootable - very confusing).

    Quote Originally Posted by VintageVic View Post
    The bookmark icon vanished.
    The bookmark icon denotes that the system will actually not power off when the power button is pressed, but it will go into suspend mode instead. This can also be toggled using a keyboard combination.

    Quote Originally Posted by VintageVic View Post
    The bios of this laptop is very lacking. No boot order, nothing about the floppy.
    Unfortunately, the boot order is fixed at "floppy, then hard disk". The BIOS appears to auto-detect the hard disk to some extent, but definitely does not like anything above 500 MB.

    Quote Originally Posted by VintageVic View Post
    Just in case, I removed any partitions, made new one and formatted the C: drive with dos 6.21 boot disk. Then
    I copied the autoexec.bat and config.sys there and the rest under c:\dos.
    For the future, you might want to track down Toshiba DOS for these machines. It is needed to use the HardRAM feature and provides support for the power management if I remember correctly.

    Quote Originally Posted by VintageVic View Post
    Okay, one last visit to this thread.
    Hopefully, you will still read this message. I haven't checked this thread in a while...

    Also, *thank you very very much for the PSU photo!*

  9. #19
    Join Date
    Oct 2016
    Location
    Dutchess County, New York, USA
    Posts
    302

    Default

    If pressing on the ribbon cable causes the floppy to work then the broken connector is your problem. The latching bar is necessary to press the ribbon against the connector contacts. Either repair the broken bar or replace the connector completely. MEK, methyl ethyl ketone, will "weld" many plastics and also completely dissolve it if too much is used. Nasty chemical, but useful for repairing some types of plastics. Do not repair in place of you will dissolve the ribbon and the main part of the connector!!!!!
    Crazy old guy with a basement full of Pentium 1 laptops and parts

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •