I was having a problem with cartridges not working and they were real sticky trying to push them in or pull them out so I opened up an original nintendo entertainment system to find it had a bit of what looks like dirt/mud that somehow got into it. I cleaned the contacts on the 72-pin connector, took it all apart, washed it out, rinsed the board carefully, and blasted it with compressed air and got it back together. This improved the sticky issue with the cartridge, but it didn't always work when inserting cartridges so I thought perhaps I needed to also lift the pins on the connector which I skipped because they did seem high enough to me already. Took it apart, lifted the pins, and then noticed I hadn't put the underside of the RF area metal case back on it the first time, at this point it is not plugged into anything and I go to put the small 2" x 2" plate back on and somehow it comes into contact with a solder joint and I see a small arc/short occur. There is a 2200uF cap on it which rectifies an 8 VAC loaded signal coming in from the wall adapter so I have to presume that it is one of its leads that shorted to ground. I finish putting it together and now here is no composite video output. I tried different cartridges and still no video. Sometimes the red light blinks which i think is some sort of protection thing, and sometimes not. I disable the protection chip by cutting pin 4, still no video. I take it all apart and look at the video pin going to the RF module, it has very little voltage on it when powered on (somewhere between 0-.3 V), but no signal of any type on the scope. I pulled the transistor connected to the video line on the RF module thinking maybe it was zapped and loading down the video signal, but it tests okay when pulled so I put it back. Voltages seem mostly good, the voltage regulator outputs 5V when powered on and the IC's are getting it. Sometimes I see a sawtooth type pattern on it, but I don't think that is related to it not working, but maybe that the heat sink is getting too warm not being connected to any of the metal shields. I looked at pin 21 coming out of the non CPU IC because I saw a schematic where it showed this was video out, same thing, no signal.

I don't know if it is supposed to put out a video signal even with no cartridge inserted, so that is one problem, perhaps my 72 pin connector is really the problem and it just can't read a cartridge, but I wonder if the short I saw did something, maybe even allowed a negative voltage spike to ground which damaged an IC or something.

I saw a test point oscilloscope thing for the NES on a site, but it doesn't mentione where the test points are and I don't see anything labeled on the PCB either.

Any thoughts on what to look at next?