Image Map Image Map
Results 1 to 7 of 7

Thread: SDC-RLV12 and SCSI2SD

  1. #1
    Join Date
    Apr 2017
    Location
    Switzerland
    Posts
    321

    Default SDC-RLV12 and SCSI2SD

    I have a Plessey Q-Bus disk controller that emulates a RLV12. When I compare it with the manual for the Sigma SDC-RLV12 it seems they are identical. The jumpers are placed and numbered at the exactly same position. These controllers emulate a RLV12 (or RLV11 depending on the jumper settings) and connect via SASI to a Formatter, mostly a Xebec S1410. The current firmware for the SCSI2SD claims to be able to support SASI and there is also an option to activate the SASI quirks for a XEBEC. I have read out the disk configuration ROM, a 32byte bipolar highspeed PROM AM27S19, and found that the second configuration option will emulate 4 x RL02 drives. So I configured a chunk large enough on the SCSI2SD to be large enough to hold the capacity required for 4 RL02 drives.

    When I connect the SCSI2SD and power-up the PDP-11 in ODT I can see that all 4 drives are "online" and when I entre a read command it reads successfully from the disk. However the blocks I read are not the ones I expect. It is as if they are shuffled.

    Has someone already tried this setup using a controller that emulates a RLV12 and connects to a XEBEC formatter but using SCSI2SD SCSI/SASI disk emulator instead of the formatter?
    For more information about my projects see https://www.5volts.ch

  2. #2
    Join Date
    Sep 2006
    Location
    Silicon Valley
    Posts
    2,441

    Default

    if you have a logic analyzer i'd take a look at what read commands it is sending. they may interleave the volumes on the physical media
    it's entirely possible they didn't implement all of the xebec command set correctly
    i was going to look at adapting the scsi2sd to support streaming tape, so i'm really curious if anyone has experience debugging code on
    this.

  3. #3
    Join Date
    Apr 2017
    Location
    Switzerland
    Posts
    321

    Default

    I think I have to set the sector size in the SCSI2SD to 256bytes. Will try this the next free time slot.
    For more information about my projects see https://www.5volts.ch

  4. #4

    Default

    Quote Originally Posted by Al Kossow View Post
    i was going to look at adapting the scsi2sd to support streaming tape, so i'm really curious if anyone has experience debugging code on
    this.
    There is the ArdSCSIno project as well. I tested it and it worked well so I decided to fork it and make my own PCB. I added a a power connector and mounting holes. But you need to solder 0.5 mm pitch LQFP which is a bit of a pain. I have been considering adding tape support but haven't yet gotten around doing it. Just studied the spec of various SCSI streaming tape drives.

    The software is simple and easy to understand so adding command should be trivial. It uses SDfat so files in some scheme or perhaps SIMH .tap files can be used easily. Since speed isn't perhaps of greatest importance the early non-optimized versions are a good starting point for adaptation. Debugging can be done over USB port as it can be used to simulate a serial port.

  5. #5
    Join Date
    Aug 2009
    Location
    Oslo, Norway
    Posts
    1,396
    Blog Entries
    3

    Default

    ArdSCSino looks neat. I knew that those blue pills could be used for almost anything.
    Torfinn

  6. #6
    Join Date
    Apr 2017
    Location
    Switzerland
    Posts
    321

    Default

    I got the following answer from Michael McMaster (the author of SCSI2SD): 256 sector sizes will use the first half of each 512-byte SD card sector. So in other words I not only have to set the sector size to 256bytes but I also need to come up with a tool that copies the 256byte sectors of a RL02 disk image to individual 512byte blocks and then copy this to the SD-Card.
    For more information about my projects see https://www.5volts.ch

  7. #7
    Join Date
    Apr 2017
    Location
    Switzerland
    Posts
    321

    Default

    With the hint from Michael I got one step further, I can boot from the Plessey controller.

    Code:
    @rs/000000 340
    @17774400/000201 
    17774402/000000 
    17774404/000000 
    17774406/000000 177400
    17774410/000000 
    @17774400/000201 14
    @0gˇ
    RT-11XM  V05.07  
    
    .TYPE V5USER.TXT
    
                                       RT-11 V5.7
    
        Installation  of  RT-11  Version  5.7 is complete and you are now running
        RT-11 from your system volume.  
    
        Your  system volume is your working volume if you have used the Automatic
        Installation (AI) procedure.  If you  have  installed  RT-11  using  that
        procedure,  Mentec  recommends  you verify the  correct operation of your
        system's software using the VERIFY verification procedure.  You can  only
        perform  VERIFY  on  the  valid target (output) media you used for the AI
        procedure.  Run VERIFY before you run CONFIG.  To run VERIFY,  enter  the
        command:  
                                       IND VERIFY
    
        Mentec  recommends  you  read the file V5NOTE.TXT,  which you can TYPE or
        PRINT.  Also, read the Introduction to RT-11, rewritten for  V5.7,  which
        contains much of the information you need to use RT-11 Version 5.7.
    
    
    .R MSCPCK
    
    .show device
    
    Device    Status                   CSR     Vector(s)
    ------    ------                   ---     ---------
      DM      Not installed           177440   210
      DU      Not installed           172150   154
      DW      Not installed           000000  
      DX      Not installed           177170   264
      DY      Not installed           177170   264
      DZ      Not installed           000000  
      LD      Installed               000000   000
      LP      Not installed           177514   200
      LS      Installed               176500   470 474 300 304
      MM      Not installed           172440   224
      MS      Not installed           172522   224 300
      MT      Not installed           172520   224
      MU      Not installed           174500   260
      NC      Not installed           000000  
      NL      Installed               000000   000
      NQ      Not installed           174440   120
      NU      Not installed           174510   120
      PI     -Not installed           000000   000
      RK      Not installed           177400   220
      SL      Installed               000000   000
      SP      Installed               000000   110
      UB     -Not installed           170200   000
      VM      Installed               177572   000
      XC      Not installed           173300   210 214
      XL      Installed               176500   300 304
      DL      Resident                174400   160
    
    
    
    .show config
    
    RT-11XM  V05.07  
    Booted from DL0:RT11XM
    22 bit addressing is on
    
    USR     is set NOSWAP
    EXIT    is set SWAP
    KMON    is set NOIND
    RUN     is set NOVBGEXE
    MODE    is set NOSJ
    TT      is set NOQUIET
    ERROR   is set ERROR
    SL      is set OFF
    EDIT    is set KEX
    FORTRAN is set FORTRA
    KMON nesting depth is 3
    
    CLI is set DCL, CCL, UCL, NO UCF
    
    PDP 11/73A Processor
    1024KB of memory
    Floating Point Microcode
    Extended Instruction Set (EIS)
    Memory Management Unit
    Parity Memory
    Cache Memory
    60 Hertz System Clock                  
    
    Device I/O time-out support
    System job support
    FPU support
    
    
    .
    I have written a small program that converts the diskimage into the format expected by SCSI2SD i.e. expands the 256bytes sectors of a RL02 image onto 512bytes blocks of the SD-Card

    Code:
    Peters-Mini:disksrsx peter$ sudo ./cvtsector -i xebec-4-rl02.dsk -o /dev/disk4s2
    Password:
    inputfile: xebec-4-rl02.dsk
    outputfile: /dev/disk4s2
    argv[0]: ./cvtsector
    argv[1]: -i
    argv[2]: xebec-4-rl02.dsk
    argv[3]: -o
    argv[4]: /dev/disk4s2
    Peters-Mini:disksrsx peter$ diskutil eject /dev/disk4
    Disk /dev/disk4 ejected
    Peters-Mini:disksrsx peter$
    I always use real partitions on the SD-Cards for the individual SCSI disks, so I can directly access the junks on the SD-Card. SCSI2SD in fact has no clue about the partitions, you just need to configure the start blocks for each of the 4 IDs that it emulates. Booting RSX-11Mplus is works as well, the TOY program used in my STARTUP.CMD expects TOY hardware so it will not proceed I need to correct that in a later step

    Code:
    .boot dl1:/for
    
    
    
    RSX-11M-PLUS V4.6  BL87   512.KW  System:"HACK11"
    >RED DL1:=SY:
    >RED DL1:=LB:
    >RED DL1:=SP:
    >MOU DL1:"HACK11"
    >@DL1:[1,2]STARTUP
    >;                      PLEASE NOTE
    >;
    >;      If you have not yet read the system release notes, please do so
    >;      now before attempting to perform a SYSGEN or to utilize the new
    >;      features of this system.
    >;
    >;
    SET -- Inquire cannot determine terminal type 
    >;
    >; Please ignore any random characters that may have printed on your
    >; terminal just now.  They came from a SET /INQUIRE=TI: command.
    >; Evidently your terminal does not recognize escape sequences.
    >; This will not affect the running of this command file.
    >;
    TOY -- Device not available
    
    AT.T0  -- String substitution error
            .ASKS $TIME Please enter time and date 'TEMPS'
    .ASKS $TIME Please enter time and date 
    >run $shutup
    
    RSX-11M-PLUS Shut down program
    
    Enter minutes to wait before shutdown: 
    Reason for shutdown (<CR> for none):
    OK to shutdown? [Y/N]: y
    All further logins are disabled
    
    30-MAR-1982 00:00 System is now shutting down -- HACK11
    
    @LB:[1,2]SHUTUP
    >VCP DISCONNECT /ALL
    >@ <EOF>
    >
     DMO DL1:/DEV/LOCK=V
    DMO -- System disk being dismounted
    DMO -- SYSTEM  dismounted from DL1:    *** Final dismount initiated ***
    00:00:42  *** DL1:  -- Dismount complete
    >
    SHUTUP operation complete
    
    126130
    @
    Last edited by cbscpe; January 29th, 2021 at 03:23 AM. Reason: It works!
    For more information about my projects see https://www.5volts.ch

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •