Announcement

Collapse

Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

DEC vt420 problem where I can't type

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    DEC vt420 problem where I can't type

    I've got a vt420 hooked up to the Altair 8800C I've been building and most of the time it works great. Running it at 19200 baud.

    The problem is that sometimes it gets into a stuck cycle where it won't type anything and I have to go into setup and choose "CLEAR COMM" so make it able to type again. It seems to be related to certain characters sent to it because it happens at the same time. If I try to boot CP/M 3.0 for example, it will beep and then nothing until I do clear comm. Or if I load a floppy exercise tool, sometimes it displays garbage characters and the same thing. It is not in hold mode because there is a light on the screen to show that. I've tried Ctrl-S/Q to make sure it isn't receiving a character like that ,but that also doesn't recover it. Just clear comm. I tried looking through the manual, but couldn't find what it is.

    #2
    It seems to have something with the dual sessions feature, but it doesn't make sense. I should be using the S1=Comm1 option, but it causes the freeze up. Only if I use the "Sessions on Comml" option does it not lock up. You would think the former wouldn't because it doesn't accept any dual session control codes and the latter would.

    Comment


      #3
      I've captured it - this happens when it receives a bell. Does a bell ever mean freeze up until clear comm?

      Comment


        #4
        Dumb question, but have you tried a factory reset on the VT420 and then set up the comms session from scratch (noting down what you have done).

        If the VT receives an XOFF (and it is set for XON/XOFF handshaking) then typing on the VT keyboard to unclear it may not help).

        I would set all handshaking (hardware and software) to OFF and set FAST SCROLL (rather than SMOOTH SCROLL) to start with.

        Just thinking out aloud...

        Dave

        Comment


          #5
          Thanks Dave; I did try resetting to the factory configuration and it did not help. I connected my logic analzyer to it and it seems the LA effects whether it will happen or not, or at least as often. I think the LA has 200K pullups in it, so I wonder if that making a difference. I am using the jump scroll. Maybe it is a signal issue, when I was monitoring just the rx line I got it to do it and saw the bell character happen at the time it hung, but when I am monitoring both the rx/tx, it doesn't want to do it. That makes me wonder if when it happened if something happened on the tx line that caused it to send back the bell and that is the real issue. It seems to happen when I boot the CP/M 3.0 for the Altair 8800 between the final startup line and the A> prompt. I may try my scope on those two lines at it has a larger impedance and may not effect it to see what that shows. Something is odd there!

          Comment

          Working...
          X