Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

If computers could tell stories...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    If computers could tell stories...

    I bought this one maybe 8 years ago, because it had a Phase5 '060 board, and for the price, I couldn't pass that up.

    I bought it out from under another buyer, with a promise that I'd put it into use, and not just put it on a shelf.

    Well, all the intentions in the world...

    Apparently it had a CD-ROM, judging by the abandoned IDE cable.

    Why use an A2091 (or whatever that is) when the accelerator has a SCSI bus?

    I did pull the battery, but there's an awful lot of green in there.

    Get a load of that '060...

    Last edited by KC9UDX; February 20, 2016, 06:37 PM.
    Be polite and I may let you live.

    https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

    #2
    Ugh. The carnage.

    KIMG0532[1].jpg
    KIMG0531[1].jpg
    Be polite and I may let you live.

    https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

    Comment


      #3
      How devastating! Another A2000, which I pulled the battery out of over ten years ago, when it was still working, seems to have the same damage. It's even deader, though. It doesn't generate a raster. The first one does.

      I'm starting to feel like a moron. I'd be up to my ears in dead A2000s right now except I'm missing about 7 of them. How the heck do you lose an A2000?
      Last edited by KC9UDX; February 20, 2016, 07:32 PM.
      Be polite and I may let you live.

      https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

      Comment


        #4
        I had an A500 Plus with battery damage, much worse than what your pictures show. I tried to resurrect it but it was basically rotted out by the green stuff. It ended up in the skip - I should have parted it out..

        So.. you have a picture of Travis (from Terry Nation's Sci Fi TV series "Blake's 7") for your avatar, are you a Brit?

        Comment


          #5
          Originally posted by JonB View Post
          I had an A500 Plus with battery damage, much worse than what your pictures show. I tried to resurrect it but it was basically rotted out by the green stuff. It ended up in the skip - I should have parted it out..

          So.. you have a picture of Travis (from Terry Nation's Sci Fi TV series "Blake's 7") for your avatar, are you a Brit?
          To the best of my knowledge, my ancestors were, but I'm not. I'm Space Commander Travis since this site went Federation.

          What's bugging me is I am missing at last one entire complete A2000, and a box with five motherboards. I should have enough stuff to make one work.

          At the very least, both these boards need new 68k sockets. I have/had some, somewhere. I bought a dozen of them a couple decades ago. They are necessary to install Derringer accelerators; the sockets are used to raise the board up. I had/have two of those accelerators.

          I've had batteries do far more damage, but in both of these cases, the 68k and socket did take a lot of damage. The socket in the pictured one is useless, and the other one is questionable at best, after lots of cleaning. What gets me about that one is that it worked for at least a year after I pulled the battery.
          Be polite and I may let you live.

          https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

          Comment


            #6
            I've got the uP socket on board #2 working, as far as I can tell. The uP is not running.

            /RST works normally, but /HLT is stuck low. As far as I know, /HLT goes only to a pullup resistor, and to the Zorro bus. There are no cards in the system, so I don't know what's pulling it down.

            If I isolate /HLT (bend the pin up), and give it a logic high, eventually the uP pulls it down, which tells me there's a bus error. So, maybe my socket isn't working.

            No matter what I do, the address bus is high impedance at the uP.
            Be polite and I may let you live.

            https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

            Comment


              #7
              I found a socket, and replaced the one in the 2nd machine, the one with less damage. I now think that was a mistake.

              I took the MegAChip out and installed a Fat Agnes, swapped Gary and Denise, and now the machine does something.

              I get 13 or 14 caps lock blinks upon power up (can't count fast enough!) and get a green/yellow/blue diagnostic screen. Unfortunately the convergence on my monitor is not right, so I can only guess that it's green; bad CHIP RAM.
              Be polite and I may let you live.

              https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

              Comment


                #8
                I have learned over time that not only batteries but also electrolytic capacitors can surreptitiously leak Goo of Death, and even pulling them is no guarantee of safety if either type of Destruct-O-Gunk seeped out beforehand and the spill went unnoticed. That stuff needs washing off, or it apparently continues to do damage for an indefinite period of time afterwards. How best to do the washing depends on what exactly leaked, where it leaked into and what the stuff it touched is made of. I have read that Classic Mac circuit boards, for example, can with careful preparation and the proper methods be cleaned extremely thoroughly in a simple home dishwasher, though the stuff Commodore produced is a great deal less sturdily-made, so I’d only dare to try that trick on a few throwaway test boards before trusting anything difficult-to-replace to it.
                the world’s only gsteemso
                agitator-in-chief for the Seattle Retro-Computing Society

                Comment


                  #9
                  I've done that before with no trouble, with boards (and chassis') of all makes and models. The only caveat is making sure everything is actually dry. IF transformers can be the worst.

                  When I removed the battery, I scrubbed the board with isopropyl alcohol, I always do. But I probably should have used something acidic, apparently.

                  I've gotten nowhere with this one. I've never gotten anywhere with an Amiga in this state. I'm just not familiar enough with the signals and timing of a 68000.
                  Last edited by KC9UDX; February 25, 2016, 10:17 PM.
                  Be polite and I may let you live.

                  https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                  Comment


                    #10
                    I wonder what the chances are that the corrosion has worked its way inside the 68000 package and caused damage there?

                    I just powered on the A2000, and waited for /RESET to go high. I then probed /HALT expecting it to be low because there was no video activity. But, it's high. So, it should be running. But the address lines are all high impedance!

                    Shouldn't it be controlling the address bus whenever it isn't HALTed?? I guess I'm going to have to learn the whole 68000 just to fix this problem.

                    I should have spare 68000s, but haven't a clue where they are, other than stealing one out of the A2000 that we use every day. I really do not want to take that thing apart, at all.

                    I put the other 68000 in, and sometimes /HALT never goes high, and sometimes it does, then I'm back to the Green diagnostic screen.
                    Last edited by KC9UDX; February 26, 2016, 06:02 PM.
                    Be polite and I may let you live.

                    https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                    Comment


                      #11
                      If I may, I had the same experience on one of my A2000 (3 units). Two had battery leak issue which I cleaned first with IPA. It worked then but after a few months of storage, one did not power up to Workbench. So this time I cleaned again the area (apparently inside /under the 68000 could be also a suspect for acid flow) with lemon juice ( from bottled concentrate). Apparently it is good naturalizer to the battery acid. Then after, I used IPA again...well it worked after that....

                      Comment


                        #12
                        I removed the corroded and partially gone socket, and cleaned the board throuroughly with IPA (not beer!) but I probably should have used lemon juice or something like it, too.

                        It's got a new socket now, and I've verified continuity without shorts. But who knows what else could be open.

                        I very well may have two bad 68000s. One for sure doesn't seem to be working correctly, and the other one may have issues, too.

                        I did swap power supplies, just because I had one that had low voltage that I adjusted tonight. But there was nothing wrong with the other supply I was using.
                        Be polite and I may let you live.

                        https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                        Comment


                          #13
                          I found the source of the intermittent problems. My replacement socket had a bum pin for A17. Whenever I was testing it, it would push together and work. But I found that if I didn't put any downward pressure on it, it was open. So I fixed that.

                          Now /HALT does what it's supposed to, and the 68000 is running.

                          But now, it's not reading the ROM, at all. /ROMEN never goes low. I never checked this before, I had assumed it was working since I was getting the green(?) diagnostic screen.

                          I have checked and double-checked continuity on every trace around the 68000 and anywhere near the battery.

                          I would think that Gary determines /ROMEN by the address lines. Whatever the 68000 is doing, the address lines are all pulsing, so I would sure think Gary would set /ROMEN at least once in a while. I've tried two Garys. In fact, I've swapped those so many times that I've broken a pin off one.

                          I think my next step is to find the address of the ROM and manually send that address to Gary and see if /ROMEN goes low.

                          Before I discovered the socket problem, I had checked continuity from all lines going between the ROM and the 68000. I also checked all lines going between Gary and 68000. I suppose I'll check those again.
                          Be polite and I may let you live.

                          https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                          Comment


                            #14
                            Last night, I powered the A2000 on and got ready to do some testing. But, it started to boot. That is, the screen went Black, Dark Grey, Light Grey, White, like a 2.04 machine normally does when it's booting properly. But, it locked up. Upon rebooting, it did some other weird things, and locked up. Another reboot, and it did nothing. Checking /ROMEN, it was pulsing pretty regularly at first, but kept pulsing less and less often, and eventually quit. So, something is warming up and dying. I've tried three 68000s, three Fat Agnuses, and two Garys, with no change. So something else is happening.


                            KIMG0547[1].jpg

                            I don't know that I ever put a scope on a digital circuit with a clock this fast, so I really don't know what I'm looking at. But, is this really what the 7MHz CLK signal should look like?? It looks like this at pin 4 of the Fat Agnus, and identical at pin 15 of the 68000.

                            It looks downright disgusting to me. For what it's worth, it looks the same with the 68000 out of socket.
                            Be polite and I may let you live.

                            https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                            Comment


                              #15
                              I think I answered my own question: The other dead A2000's 7MHz clock looks exactly the same: Ugly. I doubt I'd have two with the exact same fault.
                              Be polite and I may let you live.

                              https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                              Comment

                              Working...
                              X