Announcement

Collapse

Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Still have two issues with Kaypro 4/83

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Still have two issues with Kaypro 4/83

    It has a video issue where the horizontal placement of pixels gets shaky. If it is cold and I turn it on, this will usually happen within 5 minutes and last a few minutes. Eventually as it warms up more, it goes away. And thoughts on what I should try?

    Also, I've got one drive A: that works well, and another drive B: that doesn't. B: will sometimes work, but sometimes not, but now it seems mostly in the not working category. I made up a test tool that would write every sector with a pattern along with the track and sector number. Then it can read that back and indicate if any sector isn't read or the sector's contents do not match what they should. A: works well with this, but B: will fail within a few tracks. It usually can't read the sectors on a disk that A: can read. The drive also makes a squeaking kind of noise as it rotates as well, I finally disconnected it from the ribbon cable and power and drive A: is mostly quiet. And thoughts on what I should try? I remember pulling it and making sure its drive rails were clean and unplugging/replugging its cables and so on. It has been a flaky drive since I got it.

    #2
    Horizontal instability was/is caused by my Kaypro 4/83 by a bad horizontal position potentiometer on the monitor board.
    You can easily find this out by tapping the board with an insulated piece of material or by turning the horizontal position potentiometer a bit. Use an insulated screwdriver for this!

    I usually turn the potentiometer a few times back and forth and the try to find a stable spot again. Since Kaypro used several monitor chassis you have to try and find which one is the culprit. The service manual has some pictures of the different versions and positions of the adjustments.

    As for the floppy drive: squeaking noises often mean something is running dry, the spindle motor itself, the center bearing of the floppy or the hold-down mechanism. Try to pinpoint the source of the sound and use a small amount of lubrication there.

    Comment


      #3
      Is your B: Drive a Tandon TM-100-?? If so I have a few things you can try.

      Larry

      Comment


        #4
        Thanks guys. I'll try to find the horizontal pot.

        Yes, I says it is a Tandon TM-100-2A.

        Comment


          #5
          Found the horizontal position adjustment and adjusted it. It didn't seem unstable at all during adjustment, but maybe moving it will make a difference.

          The bad drive was mostly working this morning. It booted CP/M and I read my full test disk on it without errors. So it can't work. Then something odd happened. The drive motor was not running and the system was on. I adjusted the drive from horizontal to vertical and all of a sudden the drive motor started running, but no LED. Now it seems to be stuck in this state. Power cycle results in the same, drive running but no LED. I put the original drive back in place as drive A: and it works perfectly, so it is something with the drive.

          Comment


            #6
            Some success on the drive! I noticed its voltage on the 5V rail was way low, <1V! I pulled the board and noticed some significant resistance (25+ ohms, varying) on the 5V connector and what should be a direct solid trace. Resoldered the connector which improved the resistance, but I still think it wasn't quite right. Then I noticed some old tantalum caps that the other drive logic board does not have. I replaced the tants with some fresh ones and it is working much better. It read 7 full disks with 0 errors. Then on the 8th test it developed a two read errors on track 1. 9th was exactly the same. 10th had some delay on that track, but no errors.

            Comment


              #7
              This drive hates me! It is still acting flaky as can be, one minute it works, then next it doesn't. I connected a scope up to the test point 1 output and it seems to vary. One minute it is around the same as the other drive and it works, and the next it will be very weak.

              I then decided to swap the logic board between my good drive and the bad drive. That did not fix the issue, so it would seem that it has some sort of physical issue. I did check the RPM and that is fine. I did do the radial adjustment again. Also, it is so flaky, it wasn't working so I had the unit off for awhile, come back and turn it on and it boots CP/M.

              Comment


                #8
                Alan, on the Tandon TM-100 that has the problem. Thrre are three things you need to check.

                1. The Hub where the taunt band attaches to the stepper motor, make sure that the Hub
                screw is tight to the stepper motor shaft.

                2. Clean the drive rails with a cotton swab dipped in Alcohol. Then carefully and slowly move it full range
                so the head carriage assembly moves full travel. Lubricate the guide rods with about 3 drops on each rail
                with some Motorcycle Lubricant called Dri-Slide. It is a lubricant for Motorcycle cables and it does not attract dirt.
                It can be purchased from any Motorcycle shop.

                3. Open the door and look for either a full length Brass rod that the door hinges on. If there is no full length
                Brass Rod there will be two short White Nylon Pins. If you see the two pins replace them with the full length
                Brass Rod. (I have some of the Rods available if you just need a couple.) The two short White Nylon Pins cause
                the door Hinge part to break, and your might already be broken. I have a few of those parts available too.

                4. Look at the RPM Board and see if the 2 47 uF 16 Volt Caps have leaked and the acid had ate the PCB traces.
                I have some Copper Hollow Rivets that I bought to repair those PCB Holes and then Jumper the defective traces
                with small wire wrap wire. Both my Kaypro II Drives suffered from this problem, and I repaired them

                Larry

                Attached Files
                Last edited by ldkraemer; May 7, 2021, 04:21 PM.

                Comment


                  #9
                  I tried to attach the Tandon TM-100 Door Photo but somehow it's tagged as SPAM. GREAT SYSTEM WE HAVE HERE ERIC......ABSOLUTELY
                  GREAT FOR HELPING FOLKS WITH THEIR HARDWARE.

                  Larry

                  Comment


                    #10
                    Thanks Larry:

                    #1 - it is tight, I've removed it to put some oil on the bearing to make it quieter and retightened it. (it didn't make it quieter though...)
                    #2 - already done, but I think I used some sort of grease a year ago. I can move the head up and down the rails pretty nicely. I did tighten the allen wrench accessible from the topside ever so slightly. The phillips screw was already tight.
                    #3 - will check.
                    #4 - will check.

                    In the meantime I've had some progress. I found one more tantalum cap that I think may be been part of the issue. I replaced it and am having a bit better luck now.

                    After doing this I tried to recalibrate the radial setting and I think it is working pretty good (so far). I can never be certain because it always seems like sooner or later it flips on me, but I'm hoping that final tant replacement might mean something positive. The service manual says to turn the adjustment screw all the way counterclockwise, and when I do this I can see it moves to a different track! If I center it on that track it will not boot. If I turn it all the way clockwise it leaves that track, but meets apparently the correct one as it runs out of travel clockwise, so I'm not sure it is ideal, but it is working.

                    Here is my question - if it uses a track 0 sensor, can that be adjusted so that the radial alignment has more room? There is also a screw that looks like it adjusts the end of travel.

                    Also, even after adjustment and a tightening down of the 3 radial adjustment bolts, if I did a seek on track 0, read a sector, it worked. But then if I tried track 79 it didn't. Then it does this odd thing where it steps maybe all the way back to track 0 or half way and then it gets it right! Is there a retry in the bios that does this perhaps?

                    Comment


                      #11
                      Also, does it really need a 150 ohm terminator? That seems awfully strong. I've got a 470 ohm I could use.

                      Comment


                        #12
                        You only need the Terminator in the Floppy Drive that is on the End of the Cable. Original is 150 OHM, but you could use 470 OHM.
                        You can change the step rate on the TRS-80 Model 4, but I'm not sure about the Kaypro. If I knew I have forgotten. Seems to me the
                        Microcornucopia ROM I have has adjustable step rates. At least I seem to remember it does.

                        Larry

                        Comment


                          #13
                          I'm doing the format/verify desk now. If I format a disk in each drive and then do a other-verify in the copy utility, it verifies with no errors. If I then swap the disks between drives and attempt to do an other-verify again, it fails. I am thinking that the adjustment of B: is probably off, but this takes me back to the question above about running out of adjustment.

                          Comment


                            #14
                            It sounds like track 0 is a combination of the track zero sensor switch AND the stepper being at phase 0. I can see why I can't just do the radial adjustment to the other track and have it "zero" to that. I suppose the only way to do that would be Allen bolt on the stepper and let it move one step without moving the carriage somehow. I'll have to think on that. I really do want to figure out how to get it in the radial adjustment zone and then set properly so it can read/write disks that the drive sees perfectly. My drive A: seems to do well with the disks I make from my PC/AT's 360K drive, but I sure wish I had an alignment disk as that would be a lot easier!

                            Comment


                              #15
                              Here is what I am thinking if this makes sense:

                              when I turn the adj ccw, it pushes towards the center (higher tracks)
                              I want it to be a little further outwards so that I can do adj ccw and it will be on track 0 then.
                              the only way to do that is to start on track 0, loosen the stepper bolt, step it to track 1, then tighten the bolt again.
                              then it will think it is on track 1, but really it is still positioned where it was
                              then it can be moved to 0 which is more outwards
                              then I'll have move adjustment from the radial adjustment

                              Comment

                              Working...
                              X