Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Kaypro 4-83 graphic overlay

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • gertk
    replied
    Originally posted by Eudimorphodon View Post
    Just took a look at the Kaypro's video schematic, and I have to admit I'm stuck scratching my head why they used a six bit edge-triggered latch plus an 8:1 multiplexer instead of a shift register for dot generation, but I guess there's no reason why that wouldn't work?
    No idea why they used this elaborate concept, also using a 4 bit counter starting at 9 to get 7 dots effective, then only using 5 bits from the rom, scanning 10 lines per character vertically and use only 8... A10 and the enable pin(s) of the rom are also used for blanking. The character counter is running from 0-127 and 0-79 are visible (maybe that way it was easier to generate the horizontal timing)

    I think I'm a little thick this morning to work it out, so I have some questions about what you've learned from driving the shift register!

    First: You're driving the Load pin (and clocking the GAL) with a once-per-character pulse from the Kaypro's motherboard? My dumb question, since it's a thing I actually haven't tried yet with the video dingus I'm building: the characters in this machine are 7 bits wide. When a character is less than 8 bits does triggering a load automatically make the next bit clocked out bit0 again, or are you having to trigger a clear on the shift register? It doesn't *look* like you are with the GAL code.
    Yes, parallel loading the shift register is shifting bit D7 (input H) out first so that way it stays in sync with the 7 bit width scheme. I'm keeping the shift register reset during the blanking (vertical and horizontal) otherwise the data keeps on going for all 128 bytes and I get retrace problems. The serial input can either be tied to ground or Vcc since the shift register never gets to the bit from input A (aka D0)

    Second: I'm curious, do you really need to work the clear input on the shift register? (And if you do I'd genuinely like to know why, in case it's a thing I need to worry about.) On the thing I'm building at first I thought I needed to use either the CE/Inhibit input or the clear input on the shift register to keep it from outputting recirculated data when I was outside the active video area, but then I realized if pin 1 was tied low like you have it'd just clock out an endless string of zeros when it wasn't within 8 cycles of the last load command. But maybe there's something about the overlay or cooperating with the Kaypro's native circuitry that makes you need it?

    To keep the screen from getting overlayed with random data during startup (making the Kaypro's own video unreadable), I keep the video output disabled until 'switched on' by the /VON input.
    The graphics ram can then be cleared (or written) first and then switched on. At the moment I am using the /VON in the graphic video inverter stage of the GAL.
    The /W output of the Kaypro video multiplexer U41 is fed into the NAND gate U15, used as inverter, by lifting pin 5 I have an extra input for my graphic video but it needs to be inverted too

    In case you're curious at all I'm using a GAL on my project too; I'll probably be using at least one other because the thing I haven't tackled yet is the memory arbitration, which may well run into whatever issues you're having. (I'm likewise intending to use a fast 32k SRAM; I have a couple 35ns Cypress parts on hand that I hope are fast enough to do the needful, but right now the prototype is just generating fixed content from a 70ns flash chip) The GAL that's in there now is clocked at the pixel clock (12mhz) and four of the outputs are set up in registered mode as a 4-bit counter that I can hold in halt/reset or allow to free-run. Address generation is done by an AVR 8-bit CPU running synchronously at the pixel clock, and the shift register load signal is generated by the GAL based on that counter, which I start free-running at the start of each active line area. (That frees up instructions otherwise needed to toggle the shift register so I can do more per character while still giving a predictable cadence so I can prevent doing the address loads that would unsettle the memory output when the load is going on.)
    When using 8 pixel wide characters there is no need to reset the shift register as every 8 pixels you need to clock in new data anyway, by tying the serial input low you can leave the dotclock running during blank, just stop the parallel load from happening and it will work fine.

    Arbitration is the hardest part. You need either a synchronous system of video and CPU (as can be done with the 6502 for example: first half of the CPU clock is video access, second half is VIDEO access) but with a Z80 you either have to add waitstates or use some other clever technique.

    I have thought of the following:
    The CPU writes data and address to some latches and then the video circuit handles the writing (synchronously with the character clock)
    With a fast SRAM chip this should be doable.

    You have a 12 MHz dotclock and it gets divided by 8 for your character clock so your time per character access is 1.5 usec. By using the 'other edge' of that character clock you could write the data from the latches into the SRAM without disturbing the reads (which would happen on the leading edge of the clock). If the CPU has an access time of less than 1.5 usec there would be no contention. If the CPU is faster you could add fixed time as waitstate for the video memory range (or uses some NOP's before accessing the video ram again)
    You do need a flipflop set by the writing of the latches by the CPU which indicates that writing is needed, and is reset by the actual write by the video circuit.
    Otherwise the video ram will be filled with the same data over and over...

    Leave a comment:


  • Hugo Holden
    replied
    What a marvelous vintage computer project. I really like those fractal graphics, well done !

    Leave a comment:


  • Eudimorphodon
    replied
    Just took a look at the Kaypro's video schematic, and I have to admit I'm stuck scratching my head why they used a six bit edge-triggered latch plus an 8:1 multiplexer instead of a shift register for dot generation, but I guess there's no reason why that wouldn't work?

    For blanking the output I can also use the shift register reset output freeing up one output on the GAL.
    I think I'm a little thick this morning to work it out, so I have some questions about what you've learned from driving the shift register!

    First: You're driving the Load pin (and clocking the GAL) with a once-per-character pulse from the Kaypro's motherboard? My dumb question, since it's a thing I actually haven't tried yet with the video dingus I'm building: the characters in this machine are 7 bits wide. When a character is less than 8 bits does triggering a load automatically make the next bit clocked out bit0 again, or are you having to trigger a clear on the shift register? It doesn't *look* like you are with the GAL code.

    Second: I'm curious, do you really need to work the clear input on the shift register? (And if you do I'd genuinely like to know why, in case it's a thing I need to worry about.) On the thing I'm building at first I thought I needed to use either the CE/Inhibit input or the clear input on the shift register to keep it from outputting recirculated data when I was outside the active video area, but then I realized if pin 1 was tied low like you have it'd just clock out an endless string of zeros when it wasn't within 8 cycles of the last load command. But maybe there's something about the overlay or cooperating with the Kaypro's native circuitry that makes you need it?

    In case you're curious at all I'm using a GAL on my project too; I'll probably be using at least one other because the thing I haven't tackled yet is the memory arbitration, which may well run into whatever issues you're having. (I'm likewise intending to use a fast 32k SRAM; I have a couple 35ns Cypress parts on hand that I hope are fast enough to do the needful, but right now the prototype is just generating fixed content from a 70ns flash chip) The GAL that's in there now is clocked at the pixel clock (12mhz) and four of the outputs are set up in registered mode as a 4-bit counter that I can hold in halt/reset or allow to free-run. Address generation is done by an AVR 8-bit CPU running synchronously at the pixel clock, and the shift register load signal is generated by the GAL based on that counter, which I start free-running at the start of each active line area. (That frees up instructions otherwise needed to toggle the shift register so I can do more per character while still giving a predictable cadence so I can prevent doing the address loads that would unsettle the memory output when the load is going on.)

    Leave a comment:


  • gertk
    replied
    I posted the circuit diagrams of the CPU, IO and Video circuit of the Kaypro above.

    Also tried to (RC) delay the output enables of the latches and buffer but it makes no difference.
    Maybe I need to toggle the /CS or /OE of the SRAM but then I need to have an output on the GAL...
    The video output inversion can be skipped as there is a spare NAND port on U5 available.
    For blanking the output I can also use the shift register reset output freeing up one output on the GAL.

    Leave a comment:


  • gertk
    replied
    Most of the glitches/artifacts occur on the leftmost column and the pattern is often the same: 1010101 (and it gets stored into RAM)

    There is also some (barely visible) hash during the writes but that was expected, the Kaypro video circuit has the same 'problem'

    The timing is quite critical I guess as the write signal, /RAMWR, and the outputs of the latches and buffer are only active during the low portion of the /ENA signal (PBRDY).
    Might be violating the timing rules of the SRAM a bit here

    I did use a very fast SRAM chip (I have a whole bunch of the old 32 kByte PC cache rams of 15 and 20 ns in the 'skinny' DIP28 format)

    Below I attached the schematics for the IO/Video and CPU circuits of the Kaypro 2 & 4-83.

    kaypro4_83_cpu.pdf
    kaypro4_83_io.pdf
    kaypro4_83_video.pdf

    P.S. It seems I have left out the logic equation for the /LOE and /CNTRES signals in the image, but they are as follows:

    Code:
    ' COUNTER RESET '
    CNTRES = VS;
    CNTRES.OE = OE;
    
    'LATCH and BUFFER OUTPUT ENABLE, active only when reading or writing data '
    LOE = ENA * !LDLO * !LDHI
    LOE.OE = OE;

    Leave a comment:


  • Eudimorphodon
    replied
    Originally posted by gertk View Post
    That is correct, the Kaypro uses a similar scheme: 128 bytes per line with 80 bytes visible, by using a clever way of wiring the address lines they still manage to keep it in 2 kBytes.
    I'm really curious how they did that, I'll have to see if I can dig up the schematic.

    I've been working on my own video project, a from-scratch video card intended to emulate early S100 video cards like the Polymorphic VTI or Solid State Music VB1B (or a TRS-80's built-in video) in addition do doing full bitmap graphics, and a working constraint I initially adopted was having the memory for each video line having to be a power-of-two in width because it simplifies a number of things significantly. (Which is why 64x16 was a popular video format for a couple years.) I didn't know when I started that apparently that same constraint secretly applied to some early 80 column cards as well. The Kaypro's apparently another example.

    None of the outputs of the GAL are synchronized (yet) and could explain the glitches I sometimes see.
    In the new circuit I have made provision to synchronize with either /DCTC or TC but have not tried this yet.
    I assume the glitches are the normal "hash" you see on video systems that don't arbitrate the CPU with wait states when the video memory is being accessed by the video out circuitry? (IE, like a TRS-80 Model I or an original IBM CGA card.) I'm not sure how you'd solve that without generating wait states or using dual-ported memory.

    Leave a comment:


  • gertk
    replied
    Originally posted by Eudimorphodon View Post
    Nice!

    Looking at the schematic I see you have A0-A6 connected to the "X" latch and A7-A14 connected to the "Y" latch; I assume that means that the way you have the framebuffer laid out it's essentially 1024 bit-wide (128 byte) line that you're only using part of...
    That is correct, the Kaypro uses a similar scheme: 128 bytes per line with 80 bytes visible, by using a clever way of wiring the address lines they still manage to keep it in 2 kBytes.
    My counters are chugging along with this scheme resulting in 128 bytes per line and by combining the HS and VS signals it blanks out the rest (by resetting the shift register)

    I guess the question I'd have: Since the Kaypro natively has 7 pixel wide characters, are you using 80 bytes across and not using one of the bits in each character, or are you using 70 full bytes? ... Looking at the schematic I'm going to guess it's the first, because you're using a signal called "DCTC" as both the load signal for 74LS166 and to clock the address counters. (Which I'm guessing is pulled from the Kaypro's shift register load signal?)
    Yes I use 7 bits per character also, resulting in the 560 pixels horizontal resolution.

    /DCTC is the character clock (inverted) taken from pin 1 of U6, it also latches the parallel input of the 74F166 shift register
    TC is the non inverted signal coming out pin 15 of the pixel counter U1 (both signals are also available on U4)
    I needed both edges for the 74HC590A counters (one to count and one to latch the output register)

    The 13.9 MHz signal taken from pin 8 of U2

    The HS signal is coming from pin 8 of U32 (aka A10 of the character rom), VS is taken from solder pad E4

    Data lines KP_D0 to KP_D7 are connected to solderpads E14 to E7 (U52 PIO)

    /ENA is connected to E18 (U52 PBRDY line, it pulses for every data byte written to port B of the PIO)
    Solderpad E16 (U52 /PBSTB) is connected to ground (this gives the shortest pulse on E18, about 500 ns on my 5 MHz clocked Z80)

    LDLO connects to E29 (PB0 of U72) when high selects the X latch
    LDHI connects to E28 (PB1 of U73) when high selects the Y latch
    KPWR connects to E31 (PB2 of U73) when writing this signal is high, reading is low
    /VON connects to E34 (PB7 of U73) when low the graphic overlay is enabled, it is pulled high with a 10k resistor so when the Kaypro is reset the overlay is off.

    Port B of U73 is used in mode 3, that leaves the other pins open for either in- or ouptut.

    /GFX_OUT from the GAL is fed into (the lifted) pin 5 of U15

    In my prototype I used a 20V8 GAL and the equates are here (turned out a GAL 16V8 can handle all the signals also)
    photo_2020-10-16_11-10-24.jpg

    None of the outputs of the GAL are synchronized (yet) and could explain the glitches I sometimes see.
    In the new circuit I have made provision to synchronize with either /DCTC or TC but have not tried this yet.

    BTW reading from the graphic memory needs an extra dummy 'IN' instruction because of the odd PBRDY/PBSTB handshake the PIO does when the port is in input mode.

    Leave a comment:


  • Eudimorphodon
    replied
    Nice!

    Looking at the schematic I see you have A0-A6 connected to the "X" latch and A7-A14 connected to the "Y" latch; I assume that means that the way you have the framebuffer laid out it's essentially 1024 bit-wide (128 byte) line that you're only using part of... I guess the question I'd have: Since the Kaypro natively has 7 pixel wide characters, are you using 80 bytes across and not using one of the bits in each character, or are you using 70 full bytes? ... Looking at the schematic I'm going to guess it's the first, because you're using a signal called "DCTC" as both the load signal for 74LS166 and to clock the address counters. (Which I'm guessing is pulled from the Kaypro's shift register load signal?)

    Leave a comment:


  • gertk
    started a topic Kaypro 4-83 graphic overlay

    Kaypro 4-83 graphic overlay

    Hello,

    Since the Kaypro 4-83 does not have any graphic capabilities I decided to develop a small simple graphic extension board.
    The board creates a graphical 560x240 pixel overlay on top of the text display. The board has its own memory.

    Synchronization with the original video output is done by connecting some wires to a few points and lifting one pin in the video circuit of the mainboard.
    To keep interfacing simple I decided not to try and get it memory mapped but instead control the overlay board through the two unused B ports of the two Z80 PIO adapters.
    The mainboard has labeled solderpads for all the unused pins.
    By first adding some pinheaders those solder pads next to the PIO's connecting is fairly easy.

    Writing to the graphic memory is done in three steps:
    1. set X offset
    2. set Y offset
    3. write data


    All done by IN and OUT instructions to the PIO chips.

    It is also possible to read back the data from the graphic memory.

    The rather odd resolution of 560 pixels horizontal comes from the fact that the Kaypro displays 5x8 character bitmaps in a 7x10 matrix.

    So far I have made a prototype and tested with BBC basic and some small assembler routines (for speed) and the results are already quite nice.
    There are still some small glitches when writing to the graphic memory resulting in some artifacts which I hope might be solvable by synchronizing some of the outputs of the GAL 16V8 (which acts as 'logic glue' on the board).

    When the Kaypro is reset the output of the graphics overlay is disabled and the Kaypro works as usual.
    By setting a single bit to zero the graphics overlay is activated.

    The whole circuit consists of 6 TTL chips, a fast 32 kByte SRAM chip and a GAL16V8 chip.

    The (crude) schematic is attached as PDF, I will add a list of which connections go to where if anybody is interested.

    kpgfx.pdf

    some example images
    2020-10-14 14.03.02_small.jpg

    2020-10-13 12.26.06_small.jpg

    photo_2020-10-15_20-58-17.jpg

    the prototype
    photo_2020-10-08_22-09-49.jpg

    Gert
Working...
X