Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Installing core backplane into PDP 11/40

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • billdeg
    replied
    that's good to know as my EIS cards both seem to be bad.

    Ray has my RL11 boards and stuff, he checked them out they're ok so once they're back here I can try to boot with the MOS / 64K board installed and no EIS (unless I find the problem and fix it)
    Last edited by billdeg; July 21, 2016, 06:18 AM.

    Leave a comment:


  • wa2flq
    replied
    Originally posted by billdeg View Post
    This weekend while at HOPE I will set up simh and experiment. I don't believe in my actual 11/40 I have an EIS card installed. I have not used simh for pdp 11 RT11 yet, I only used for other things.

    I have never actually used rt11, although it seems similar to Pdp8 OS8. When you say that you can load a job monitor, do you mean "boot" see an OS prompt so I can then run commands? I need to learn more, I assume we were talking "get to the dot prompt".

    Because in SIMH for the 11/40 EIS is standard, you CANNOT disable it, (i.e. SET CPU NOEIS), I seriously wonder if this is going to hamper using RT11 even with 64K
    For the purpose of discussion here
    monitor=operating system
    handler=device driver

    So loading a monitor is equivalent to booting the OS.

    RT11 was meant to be a small "real time" OS mean for users that needed close access to the hardware. The Single Job - SJ or its successor SB made minimal expectations of the underlying hardware. If you had more memory or memory management features, you could select the included FB or XM monitors. If you were up to customizing things, adding error logging, timeout support or more terminals; this was possible because the bare OS sources were included. You could then compile these features into your own version of the monitor and handlers.

    RT11 should not depend on EIS to boot. In SIMH it boots fine off of an emulated 11/20.

    Code:
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo].sh con[/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]RT-11SB  V05.07  [/FONT]
    [FONT=Menlo]Booted from DU0:RT11SB[/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]USR     is set SWAP[/FONT]
    [FONT=Menlo]EXIT    is set SWAP[/FONT]
    [FONT=Menlo]KMON    is set NOIND[/FONT]
    [FONT=Menlo]MODE    is set NOSJ[/FONT]
    [FONT=Menlo]TT      is set NOQUIET[/FONT]
    [FONT=Menlo]ERROR   is set ERROR[/FONT]
    [FONT=Menlo]SL      is set OFF[/FONT]
    [FONT=Menlo]EDIT    is set KED[/FONT]
    [FONT=Menlo]FORTRAN is set FORTRA[/FONT]
    [FONT=Menlo]KMON nesting depth is 3[/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]CLI is set DCL, CCL, UCL, NO UCF[/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]PDP 11/15,20 Processor[/FONT]
    [FONT=Menlo]32KB of memory[/FONT]
    [FONT=Menlo]60 Hertz System Clock                  [/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]FPU support[/FONT]

    Leave a comment:


  • billdeg
    replied
    This weekend while at HOPE I will set up simh and experiment. I don't believe in my actual 11/40 I have an EIS card installed. I have not used simh for pdp 11 RT11 yet, I only used for other things.

    I have never actually used rt11, although it seems similar to Pdp8 OS8. When you say that you can load a job monitor, do you mean "boot" see an OS prompt so I can then run commands? I need to learn more, I assume we were talking "get to the dot prompt".

    Because in SIMH for the 11/40 EIS is standard, you CANNOT disable it, (i.e. SET CPU NOEIS), I seriously wonder if this is going to hamper using RT11 even with 64K
    Last edited by billdeg; July 21, 2016, 04:55 AM.

    Leave a comment:


  • wa2flq
    replied
    Originally posted by billdeg View Post
    I have a 64K MOS RAM board installed in slot 3 of my DD11-CF backplane. Slot 3 is a MUD slot without the NPG jumper removed. The manual says it will work in any MUD slot. It seems to work OK. I ran a memory diagnostic and loaded BASIC.

    On the same backplane slot 2 is a MUD slot with the NPG jumper removed. I have had the RL11 controller installed there. The RL11 manual says the M7762 should be installed in a MUD slot with the NPG removed.

    I believe I have concluded correctly where to put the MOS and RL11 controllers and that they can be together. Any dissenting opinions?

    If replacing the 16K core with the 64K MOS RAM will load RT11, I would conclude that one needs more than 16K installed in the system for version 5 all else being the same.

    Bill
    You should be able to boot any single job monitor - RT11SJ or RT11SB in only 16KW (32KB). You may not be able build your own customized monitor or execute large complies/links without additional memory, but the basic utilities should work.

    The memory and controller configuration appears acceptable.

    Code:
    [FONT=Menlo].sh con[/FONT][FONT=Menlo]
    [/FONT]
    [FONT=Menlo]RT-11SB  V05.07  [/FONT]
    [FONT=Menlo]Booted from DU0:RT11SB[/FONT]
    [FONT=Menlo]
    [/FONT]
    [FONT=Menlo]PDP 11/73A Processor[/FONT]
    [FONT=Menlo]32KB of memory[/FONT]
    [FONT=Menlo]Floating Point Microcode[/FONT]
    [FONT=Menlo]Extended Instruction Set (EIS)[/FONT]
    [FONT=Menlo]Memory Management Unit[/FONT]
    [FONT=Menlo]Cache Memory[/FONT]
    [FONT=Menlo]60 Hertz System Clock                  [/FONT][FONT=Menlo]
    [/FONT]
    [FONT=Menlo].sh mem[/FONT]
    
    [FONT=Menlo]Address   Module    Words[/FONT]
    [FONT=Menlo]-------   ------    -----[/FONT]
    [FONT=Menlo]160000    IOPAGE     4096.[/FONT]
    [FONT=Menlo]100000    MEMTOP    12288.[/FONT]
    [FONT=Menlo]074060    DU         1000.[/FONT]
    [FONT=Menlo]054372    RMON       3995.[/FONT]
    [FONT=Menlo]001000    ..BG..    11133.[/FONT]

    Leave a comment:


  • billdeg
    replied
    I have a 64K MOS RAM board installed in slot 3 of my DD11-CF backplane. Slot 3 is a MUD slot without the NPG jumper removed. The manual says it will work in any MUD slot. It seems to work OK. I ran a memory diagnostic and loaded BASIC.

    On the same backplane slot 2 is a MUD slot with the NPG jumper removed. I have had the RL11 controller installed there. The RL11 manual says the M7762 should be installed in a MUD slot with the NPG removed.

    I believe I have concluded correctly where to put the MOS and RL11 controllers and that they can be together. Any dissenting opinions?

    If replacing the 16K core with the 64K MOS RAM will load RT11, I would conclude that one needs more than 16K installed in the system for version 5 all else being the same.

    Bill

    Leave a comment:


  • billdeg
    replied
    Found this:

    "A minimal but complete system supporting a single real-time user could run on a single floppy disk and in 8K 16-bit words (16KB) of RAM, including user programs. This was facilitated by support for swapping and overlaying. To realize operation on such small memory system, the keyboard command user interface would be swapped out during the execution of a user's program and then swapped into memory upon program termination. The system supported a real-time clock, printing terminal, VT11 vector graphic unit, 16 channel 100 kHz A/D converter with 2 channel D/A, 9600 baud serial port, 16 bit bidirectional boards, etc."

    Leave a comment:


  • AK6DN
    replied
    Originally posted by billdeg View Post
    I spoke with QBUS by phone today, we were wondering what the minimum RAM requirement is for RT-11 v5. I may need add to the 16K I have installed.

    Confirming one way or another about the RAM requirement might shed some light. At least in addition to any additional CPU tests.
    From the RT11 v5.1 system release notes:

    Capture.JPG

    the RT11SJ monitor will run in 16KW, minimum. The documentation for v5.6 does not specify a minimum memory requirement (other than 28KW) that I can find, and for v5.6 the SJ monitor is renamed/redone as the SB monitor. So unclear at this point if v5.6 SB monitor can run in 16KW.

    Earlier v4/v3/v2 RT11 systems could run the single job monitor in as little as 8KW I believe but v5 bumped the minimum to 16KW.

    Probably the easiest test would be to configure a PDP-11 to the appropriate memory size in SIMH and trying to boot your test RT11 image.
    Last edited by AK6DN; July 20, 2016, 04:40 PM.

    Leave a comment:


  • Marty
    replied
    Hi All;

    Good for You, Bill, If You have a MOS Ram Card of more Memory than Your 16K of Core, Throw it in there just for a Test, If that solves the problem, then You know that it is not enough RAM in the System.. And that will hopefully tell You How much Ram is needed, Core or otherwise..
    If the problem still persists, then You know that You still need to look elsewhere..

    THANK YOU Marty

    Leave a comment:


  • billdeg
    replied
    I spoke with QBUS by phone today, we were wondering what the minimum RAM requirement is for RT-11 v5. I may need add to the 16K I have installed.

    Confirming one way or another about the RAM requirement might shed some light. At least in addition to any additional CPU tests.

    Leave a comment:


  • Marty
    replied
    Hi All;

    Bill, Good News !! Congratulations !!

    What I would suggest and give a try at, is go thru the Rest of the Tests and Do the same Kind of thing, Change the 'Bell' to a 'Star' And see if any of them Fail or if they all Pass, That way You Know for sure, especially if You run all of the Tests..

    THANK YOU Marty

    Leave a comment:


  • billdeg
    replied
    The change worked. It prints an asterisk every few minutes. I am at pass 10 so far. You're right, I was not waiting long enough, and I heard nothing of a bell so I had no idea whether the program was functioning correctly. At this point I am waiting to hear back from Ray who has my RL11 stuff, so I can resume testing the only thing that does not work - actually booting a disk.

    Leave a comment:


  • billdeg
    replied
    I will give it a try. The program ran for at least 30 mins before I stopped it but I will try your patches to see what effect it has, thanks

    Leave a comment:


  • Marty
    replied
    Hi Bill;

    I just found Your posting of running CKBB, and I have a couple of comments..
    First, You didn't let it Run nearly Long enough..
    Second, You need to patch address '3604 from an '000007 to a '000052, so it will Print a STAR when it makes a single Pass..
    It is easiest to do this from PDPGUI after You have Loaded the program into PDPGUI, but before You Load it into Your 11/40, after You have Patched it using PDPGUi then, Load the 11/40 and it will be ready to Run..
    Then Run it on the /40 and WAIT for the Stars to appear on the Screen.. (Assuming everything is OK ).. Give it 3 to 5 minutes per pass, Depending on the Amount of Memory You have in Your machine, and the speed of Your machine.. Maybe longer, since Your Machine is slower than mine..
    Also, Note that the First Star Doesn't count, only the Second Star and following.. And that both Fritzm, and I have listed where to find the 'Bell' and where to change it to '000052, and the Bell might be either an '000007 or an '000207..

    THANK YOU Marty
    Last edited by Marty; July 19, 2016, 03:55 PM.

    Leave a comment:


  • billdeg
    replied
    I took a different DL11 (M7800) and got that running too. This thread has a lot of useful info about the DL11 M7800:

    http://vintagecomputer.net/browse_thread.cfm?id=641

    Leave a comment:


  • billdeg
    replied
    after giving up on the M7856 I had been using (it receives but does not send back to the terminal), and an M7800 I hoped might work (bombs when attempting to do much of anything), I found another M7856, jumpered that one and now I am back in business. I have now 16K core, serial comms and a M9312 ROM/Terminator with RL01/2 and CONSOLE ROMs. Basically I am back where I was before with MOS RAM. The project was to expand the backplane and replace MOS with core RAM. NEXT - get RT11 running.

    As far as the original M7856 serial card goes, it appears to have been repaired more than once, some of the traces are bare, simply replacing the 1488/89 is not enough. I can compare the working card with the bad one, that should help diagnose/fix.

    Leave a comment:

Working...
X