Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Apple IIGS Floppy Drive Weirdness

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Apple IIGS Floppy Drive Weirdness

    Hi Folks! Hope you can help with a very weird problem...

    I picked up a used Apple IIGS. When I tried booting the thing, the drive would click a few times, and then I'd get the "Check startup device!" screen. Not good, but the weird thing is that after that, the disk is unreadable. I try reading it on another machine and I get "I/O Error". I reformat the disk on another machine, copy ProDOS onto it, and try booting it again on the IIGS. Same thing, after booting it's unreadable. I tried booting other disks that boot fine on other machines. Same thing, it doesn't boot and the disk becomes unreadable.

    The IIGS is ROM Version 01 with no cards. The drive is an Apple 5.25 Drive (A9M0107). I'm using a Commodore 1702 composite monitor, an Apple Keyboard II (M0487), and an Apple Mouse (A9M0331). In the control panel, everything is set to the defaults.

    I have another, working, IIGS and have tried swapping the power supplies, no difference. I tried swapping drives, no difference. I even tried swapping the keyboard and mouse, no difference. I checked the voltages, they are fine. I checked the battery voltage, it's fine. I did a self-test, no problem. I even tried the power supply and drive from the problem IIGS on my other other IIGS, they work fine. The disk boots and is fine afterwards.

    At this point, I'm baffled. Obviously the booting problem is an issue with the motherboard but I have no idea what it is. And why is it making the boot disk unreadable? Any help on this would be greatly appreciated!

    - Rick

    #2
    It sounds sort of like the write request line that outputs to the floppy drive is stuck. Does write protecting the disks make any difference? It would be interesting to see if somehow disconnecting just the write request line would make any difference, but there may be other damage to the floppy port.

    Comment


      #3
      I tried write protecting the disk and it made no difference - the disk still became unreadable.

      Funny thing, I always assumed it was the floppy drive that dealt with the write protection, rather than it being a signal sent back the the computer. I rewrote the disk on another machine with ADTPro and it complete ignored the write protection. I guess some programs just don't care.

      I'll check the write request and write data lines on the motherboard - maybe something shorted. Thanks for the tip!

      - Rick

      Comment


        #4
        Originally posted by Rick Thornquist View Post
        I tried write protecting the disk and it made no difference - the disk still became unreadable.

        Funny thing, I always assumed it was the floppy drive that dealt with the write protection, rather than it being a signal sent back the the computer. I rewrote the disk on another machine with ADTPro and it complete ignored the write protection. I guess some programs just don't care.

        I'll check the write request and write data lines on the motherboard - maybe something shorted. Thanks for the tip!

        - Rick
        If a floppy drive writes to a write protected disk then the FDD's protection circuitry is either faulty or intentionally crippled.

        Comment


          #5
          When you swapped drives, did you swap cables? The write protect line goes thru the cable direct to the IWM chip on the motherboard. If you swapped cables too then sure seems like IWM chip is bad.
          Does the media of the disk look scratched? Maybe the bad drive scratched them up first?

          Larry G

          Comment


            #6
            SomeGuy - I checked the floppy drive connector on the motherboard and didn't see any obvious problems. And seeing as the 3 1/2" drive worked (see below)...
            george - I tried using ADTPro, on my Apple IIc, to format and write to a 5 1/4" disk with a write protect tab on it. The program formatted it and wrote to it without complaint. Maybe someone else should try this to confirm?
            retrogear - The cables for these drives, the Apple 5.25 Drive (A9M0107), are not detachable. So yes, the cables were swapped. The media is fine - it was brand new out of a box and I tried different disks.

            Here's a interesting new wrinkle. I tried attaching a 3 1/2" drive, the Apple 3.5 Drive (A9M0106), and booting GS/OS 6.0 off of a 3 1/2" disk. It booted fine! I then daisy chained a 5 1/4" drive off of it. With nothing in the 5 1/4" drive I booted it up. The 5 1/4" drive was accessed, the drive clicks and the light goes on. It boots fine off of the 3 1/2" disk. But there's no 5 1/4" drive on the desktop! Huh?

            Even better, I put a bootable disk in the 5 1/4" drive and booted it up again. The 5 1/4" drive was accessed, the drive clicks and the light goes on, as before. It boots off of the 3 1/2" disk, as before. And there's still no 5 1/4" drive on the desktop. And guess what, when I take out the 5 1/4" disk and try it on another machine, it's unreadable! D'oh!

            Maybe this machine just has a vendetta against 5 1/4" drives?

            - Rick

            Comment


              #7
              Originally posted by george View Post
              If a floppy drive writes to a write protected disk then the FDD's protection circuitry is either faulty or intentionally crippled.
              Are you sure? I thought write protection was handled in software or firmware. I seem to remember being able to write to write-protected disks. But maybe that wasn't on the Apple.
              Be polite and I may let you live.

              https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

              Comment


                #8
                Sounds like a bad analog card in your 5 1/4" drive. It could fault and keep current running through the r/w head to do some erasing.
                About the cable, I was looking at the back of my //gs drives and thought the cable was screwed on but I see it's just to chain to the next drive.

                Larry G

                Comment


                  #9
                  Ok, so it's just this one 5.25" drive that is exhibiting this behavior. Yea, the electronics in it have to be borked. if it is in good cosmetic condition, it is probably worth hunting down replacement parts.

                  Comment


                    #10
                    retrogear and SomeGuy -

                    It's not just the one 5 1/4" drive. I've attached another 5 1/4" drive to the IIGS and it does exactly the same thing - reads the disk, doesn't boot, and then the disk is unreadable. Both drives work perfectly on both a IIc and another IIGS. I think this has to be a motherboard thing.

                    - Rick

                    Comment


                      #11
                      > I think this has to be a motherboard thing.
                      Well, then we're back to the IWM chip which controls both kinds of drives. Probably not much can be done w/o a new motherboard.
                      I did read something interesting that whenever a motor on port is accessed on the 5.25 drive that the cpu speed is slowed from 2.8MHz to 1 MHz.
                      Makes me wonder what it would do to a disk if it failed to reduce speed. Like a 5.25 drive on steroids

                      PS - I suppose you could change in the control panel slot 6 to your card and add a Disk II controller but then you would need the ribbon cable type of drives.

                      Larry G
                      Last edited by retrogear; January 2, 2016, 10:30 PM.

                      Comment


                        #12
                        Not if you get a card from a Platinum //e.
                        Be polite and I may let you live.

                        https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                        Comment


                          #13
                          Originally posted by KC9UDX View Post
                          Not if you get a card from a Platinum //e.
                          Will those work with 3.5" IIc/IIGS/Laser 128 drives? (I can't quite remember)

                          Comment


                            #14
                            I'm thinking I could get an Apple 5.25 Controller and stick it in slot 6. Then I could run the 3 1/2" drives from the internal floppy port and the 5 1/4" drives from the card. Does that sound possible?

                            Edit: Oops, I see Larry already suggested this. The Apple 5.25 Controller actually uses a 19 pin D connector instead of the ribbon connector so it should work with my 5 1/4" drive.

                            The Apple 5.25 Controller cards seems to be pretty plentiful and cheap (except for the shipping to Canada - Arg!). It might be worth a try.

                            -Rick

                            Comment


                              #15
                              Originally posted by SomeGuy View Post
                              Will those work with 3.5" IIc/IIGS/Laser 128 drives? (I can't quite remember)
                              Yes.

                              It seems to me there is one drive that won't work with it but it is a rare, unobtainable one. My memory could be way off on that one though.
                              Be polite and I may let you live.

                              https://www.youtube.com/playlist?lis...5NBVfKX5471R9U

                              Comment

                              Working...
                              X