Announcement

Collapse

Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Gateway 2000 4SX-25 error codes on start-up

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • GiGaBiTe
    replied
    Did you make sure the IDE cables were in the correct orientation? A lot of older systems don't have keyed IDE connectors and let you flip them any which way around, even allowing you to go off the connector and miss a couple of pins.

    Leave a comment:


  • dafivehole
    replied
    There is no option in setup for no hard drive or booting from just the floppy. I tried two different hard drives that are known good and neither worked... tried two different known good cables, still nothing... I'm sending the computer back. Thank you to everyone that responded.

    Leave a comment:


  • kc8eyt
    replied
    You may have a bad hard drive. Have you tried setting CMOS to no hard drive and not hooking one up? Try booting from just a floppy drive. If that works then look at the IDE connector on the motherboard, inspect the cable or try a few different ones, and make sure the hard drive is set for single/master.

    Leave a comment:


  • dafivehole
    replied
    I give up... I think something is fried on this MB. I'm using known good drives, etc. I verified all jumpers were set correctly, the battery is new, the memory is correct, I reset the BIOS settings to get this far and I get this message:

    1.png

    Leave a comment:


  • kc8eyt
    replied
    I found nothing about beep codes. I used archive.org's feature of viewing web pages from long ago (the wayback machine). That's how I found them. I believe I found these on Gateway's website from either 1996 or 1997. I tried to download a manual but all of the links I cam across were no good.

    I'm not sure how the beeps are ordered (do they mean the upcoming code has an issue, the current code displayed, or the previous code displayed?) If it's for the 190 code then your CMOS battery needs replaced, if for 135 then again perhaps CMOS battery, if 130 then maybe it's indicating it couldn't find a diskette drive attached.

    Leave a comment:


  • dafivehole
    replied
    This is awesome info... I looked on archive.org but only found the Gateway CD's which I DL'd years ago. Great info about the codes... I guess human nature is to think that they are error codes and not function verifications. I will definitely check the cache settings this evening... I know that some of the jumper settings were incorrect and needed to be changed but I didn't check the cache

    Did it have any info on the beeps? Once it shows 135, it beeps twice. Then once it shows 130, it beeps once.

    Thank you!
    Last edited by dafivehole; May 18, 2021, 11:56 AM.

    Leave a comment:


  • kc8eyt
    replied
    It looks like your computer didn't make it to the "10" post code for enable cache. Does your system have cache installed? If so, verify they are seated (press on each one, chip creep may have occurred). Also, verify the cache jumpers are correct:
    CACHE JUMPER CONFIGURATION
    Size J11 pins 1 & 2 J11 pins 3 & 4 J11 pins 5 & 6 J11 pins 7 & 8
    64KB Open Open Open Open
    128KB Closed Open Closed Open
    256KB Closed Closed Open Closed

    Leave a comment:


  • kc8eyt
    replied
    Doing some digging through Gateway's website via archive.org I found this:

    Beep Codes
    Below is the beep code sequence for the Intel I4 Integrated 486 systemboard. During the boot sequence you will receive a series of numbers. They don't indicate a problem, but rather verify certain functions during boot.
    440 Size memory above 64 KB
    370 Keyboard controller initialization
    330 Initialize auxiliary controller
    290 Test memory above 64 KB
    210 Read Keyboard ID
    190 Real time clock test
    135 (The number gets brighter. This is normal) Access to Setup Program
    130 Initialize diskette subsystem
    10 Enable cache
    000 Boot

    Leave a comment:


  • dafivehole
    replied
    I installed the correct memory, confirmed all jumper settings, confirmed CMOS battery is good, etc. and no changes whatsoever

    Leave a comment:


  • GiGaBiTe
    replied
    Originally posted by kc8eyt View Post

    I can't read the stickers on the left side of the chips. What's printed there?

    Yes, the eight chips are a pretty sure indicator that these are non-parity (x32) versus parity (x36) sticks of RAM. The link you provided for the motherboard clearly shows each memory configuration using parity x36 combinations of chips. There *might* be a setting in CMOS to enable non parity use.
    Definitely not parity modules. You can see where it has the option to be a parity module with the four pads at the top of the module for memory chips, and can probably be converted into a parity module if those chips were installed.

    Leave a comment:


  • dafivehole
    replied
    They say: Tested speed: 70ns 96

    Thank you,
    Roger

    Leave a comment:


  • kc8eyt
    replied
    Originally posted by dafivehole View Post
    Well that's one problem... here's what was in there:

    memory.png
    I can't read the stickers on the left side of the chips. What's printed there?

    Yes, the eight chips are a pretty sure indicator that these are non-parity (x32) versus parity (x36) sticks of RAM. The link you provided for the motherboard clearly shows each memory configuration using parity x36 combinations of chips. There *might* be a setting in CMOS to enable non parity use.

    Leave a comment:


  • GiGaBiTe
    replied
    Originally posted by Agent Orange View Post

    The ninth chip is used to store parity.
    This only partially applies to 30 pin SIMMs. There are 5 and 3 chip parity modules as well. The better thing to look for is an odd number of memory chips on 30 pin SIMMs to determine if it's a parity module.

    72 pin SIMMs are entirely different. Parity modules usually have 2-4 chips on the back of the module to make up the 36 bit width of a 72 pin parity module. Larger capacity SIMMs can have more memory chips used for parity.

    Leave a comment:


  • dafivehole
    replied
    Well that's one problem... here's what was in there:

    memory.png

    Leave a comment:


  • kc8eyt
    replied
    Originally posted by dafivehole View Post

    So each stick should have 9 chips on it?
    Correct.

    Leave a comment:

Working...
X