Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.

Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.

Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.

Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.

"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.

Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.

Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.

New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.

Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

IBM PS/2 Model 70 Reference Disk/Boot Behavior Questions

  • Filter
  • Time
  • Show
Clear All
new posts

    IBM PS/2 Model 70 Reference Disk/Boot Behavior Questions


    I've been working on getting an IBM Model 70-E61 up and running, but am (surprise!) having some issues getting the Reference Disk booted up.

    The drive originally in the machine was a ragged Mitsubishi 15F7503 1.44MB 3.5" drive with the top head sheared off. On boot, I'd get the expected 161/163 error.

    I found another Mitsubishi 15F7503 and cleaned the heads, cleaned up the worm gear, and recapped it.

    I replaced the battery and get the expected 161/163 error on boot.

    A downside here is I understand the only way I have access to writing the Reference Diskette floppy using the rf7080a.img source at the moment is less than ideal:
    • Windows 10 with external USB floppy and WinImage
    • dd in Terminal on MacOS 10.11 with USB floppy
    • DOS 5 on Virtual Box on MacOS 10.11 with USBASPI.SYS configured to use the external USB floppy drive. With this setup I tried RAWRITE. If I use REFSTAMP.COM afterwards, it reports that the signature is already stamped. This is the same if i write the disk with WinImage, dd or RAWWRITE. If I try running REFSTAMP on a freshly formatted disk, it will stamp the signature and report "Disk Stamped OK" (so it says).
    • That said, I can create a disk using rf7080a.img and have matching checksums with the source image file when I create an image of the resulting disk back into a file. I can see and access the contents on the disk as expected (even on a Quadra 700).
    When I try to boot the Model 70, it will access/initialize the drive, give the 161/163 error, beep twice, drive will seek 4 times, then throw the red “not OK” + IBM manual. If I hit F1, the floppy will seek four more times, then go to BASIC.

    I figured I’d give the TexElec PS/2 to standard floppy adapter a shot with a Sony standard 3.5" PC floppy drive. I was pretty surprised when it gave the exact same result: it will access/initialize the drive, beep twice, seek 4 times, then throw the red “not OK” + IBM manual. If I hit F1, it will seek four more times, then go to BASIC.

    For the heck of it, I cleaned up the original drive, sans top head, recapped it and had the same exact result.

    If I make a DOS bootable diskette, I get the same result as well, which I'd expect since the system CMOS isn't configured.

    At this stage, assuming my Reference Disk is good (which perhaps isn't a sure thing with USB floppy drive, etc?), where would I go next? Is this "seek 4 times" behavior what you see on an unconfigured Model 70 and you try to boot with a non-Reference Disk? I’d imagine it’s possible some floppy disk controller chip might be bad?

    Thank you!
    Last edited by ataritoobin; June 19, 2021, 08:08 AM.

    I surfed around a bit... did you make sure the floppy controller leads on the system board are clean? Not sure if you have a Type I or Type II look for U89, NEC D72065L look for U18 NEC D72065L

    If it is a Type I, the FDC is close to the PSU fan intake, and the FDC leads may have some grunge on them. This issue is better known on 8580s, but any system can get it.

    The Type II FDC is towards the front of the case, but the vents in the front allow air to travel over it.

    A Q-Tip and alcohol [rubbing or denatured] will do the trick.

    161/163, configuration, yep. No 6xx error codes? That's what I'd expect with a bad floppy drive. If the refdisk was bad, I'd expect an error message, asking you to insert a refdisk and hit F1...
    Last edited by ardent-blue; June 19, 2021, 08:21 AM.


      Re-read the 8570 RETAIN tips...I remembered the 8570 uses a drive riser to connect the FDD [and HD!]

      Pull the drive riser, buff the gold contacts that plug into the system board socket. Use a folded dollar bill [or bank note] to clean the drive riser contacts. Do NOT use an eraser [gummy residue] or abrasives [wear gold plating AND leave abrasive residue!]. Use compressed air [low pressure], computer duster, or a vacuum [IBM preferred, but the others do just fine] to blow out the drive riser socket on the system board. Insert / remove the drive riser into/from the system board socket three to four times [should buff up socket contacts].

      Reassemble, insure drive riser is firmly and squarely seated in system board socket. Also czech cleanliness of FDC leads. Clean as needed.

      Another issue to look into is contaminated heads. Not as likely... Use a brand of floppy that is good [IBM recommended... IBM branded floppies...] and let the system search a few times. Since you probably can't do a "DIR", you might have to boot three or four times with the "scratch" diskette.

      Brings up a thought - how clean is the floppy drive used for creating the refdisk? Scratch diskette to clean that one as well [if you neeed to]....
      Last edited by ardent-blue; June 19, 2021, 09:35 AM.


        Thank you for the tips! I appreciate it!

        Yep, strangely I never saw any 6XX error codes.

        Mine is the type Type I motherboard with the NEC D72065L @ U89. I cleaned up the chip and area with alcohol as you suggested and inspected for any cracked solder joints or the like.

        I blew out the edge connectors with air and cleaned all edge connectors with the bill method.

        I also cleaned the heads on the USB drive and tried again with the same results.

        For fun, I pulled up MacTools on the Quadra and confirmed I could see the "3y" in the disk header required for the Reference Disk to boot. I tried changing and writing a different value back, then put the 3y back in and wrote it to disk just in case the alignment or something else might be off with the USB drive, but had the same result on the PS/2

        I'll give it a final go with a Gotek at some point this week, but have the sneaking suspicion it's a problem with some circuitry on the motherboard
        Last edited by ataritoobin; June 20, 2021, 06:35 PM.


          With the Gotek, I got the same "seek 4 times" (via LED flash), then it throws the red “not OK” + IBM manual. If I hit F1, it will seek four more times, then go to BASIC

          EDIT: Strangely with the Gotek this evening, it would take longer and longer to "try" beyond the usual 4 seeks and eventually I got a "Non system disk or disk error" message which I hadn't seen before. I kept retrying and eventually it actually finally loaded the configuration program, but was super unreliable and fail any time it tried to read from the Gotek (e.g. "try backup copy" error).

          Eventually it locked up, the Gotek seek light was stuck on, and on reboot the system totally won't POST whatsoever, even with all drives/riser removed, etc. If drives are plugged in, seek light is always on. Power supply voltages check out ok.
          Attached Files
          Last edited by ataritoobin; June 23, 2021, 02:20 PM.


            I tried checking the ROMs, and they compared OK to the images found online, and the behavior is the same with the ROMs and the CPU removed. I guess I'm in the market for a replacement motherboard until I have time to take a closer look at this. That leaves the case and the power supply (knock on wood) as the only really useable parts from the original machine


              I might be able to come up with something - I'll send a DM later.
              Disclaimer: The username IBMMuseum and domain are not affiliated with IBM in any manner


                Originally posted by IBMMuseum View Post
                I might be able to come up with something - I'll send a DM later.
                Awesome, thank you! If you don't receive a reply let me know here, the messaging system gremlins probably ate them.


                  I'm having the exact same issues with a model 50.
                  Could you get it working?


                    I wound up buying another Model 70 (Type 2) and it too had the exact same problem attempting to read disks. I replaced the D72065L chip and was able to get it working. Not fun though since it's in an awkward place on the Type II motherboard

                    However, I never resolved the issue with the original Type I motherboard that no longer shows any signs of life.