Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Anyone put a Am5x86-133Mhz on a Soyo SY-25N?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raven
    replied
    One of the advantages to that setup is that upgrade chips with VRMs - and probably some stand-alone VRMs have this too - can have jumpers on-board to select that pin setting, among other settings; such is the case with my Am5x86-133 upgrade chip by Evergreen.

    The pin setting had slipped my mind - I thought you meant a proper multiplier jumper or some such, which became common on Pentium boards (particularly late ones, inc. SS7). I remember before I was aware of that, I had a machine that I couldn't get my 133Mhz chips to run any higher than 100Mhz in - a PS/Valuepoint - and that's almost certainly why.
    Last edited by Raven; October 24, 2011, 06:33 PM.

    Leave a comment:


  • orion24
    replied
    Originally posted by Raven View Post
    Also, though this has been said in various ways in the thread, I'm not sure if it was gone over like this:

    A 486 board with multiplier selections is *not* the norm - in fact, I've never seen one. 486 chips with multipliers are all internally multiplied AFAIK, and some of the more advanced motherboards that understand multipliers/etc. send things automatically (as you put it) from the BIOS/CMOS, which the chip can then interpret. However, most boards don't even have that, nor the jumpers, they just rely on the chip's internal workings, because that was the norm for the vast majority of the earlier 486 boards, and these were upgrade chips (yay run-on sentence!).
    Well the mainboard does have a setting for the CPU multiplier. It is not a direct multiplier selection (couldn't actually be, as multipliers were selected by the CPU eitherway). This is a certain pin on the 486 socket and the mainboard can either:

    1) Ground it
    2) Leave it with no connection (or connected to 3.3V)

    Early 486 CPUs that were designed to work with either 1x or 2x multiplier have no effect from this, but when CPUs with 3x multiplier arrived, they were operated in either 2x (ground) or 3x (no connection or +3.3V) speed according to input they receive from this mainboard pin. When the Am5x86 arrived, it still used that same pin but worked at 4x (ground) or 3x (no connection or +3.3V).

    Anything other than a very early 486 board, has a way to switch between these 2 options, and in a way, set the multiplier for some CPUs. If this is done via a jumper, then it is good, as you know what you are doing. If it is done via automatic BIOS detection mode thought, then more likely an Am5x86 will be set at 3x multiplier.

    Leave a comment:


  • Raven
    replied
    You can run a 3.3v chip on a 5v board just fine in most/all cases. I grant that this probably isn't good for the chip, but it does function. Maybe my Am5x86 was especially hardy, but before I realized that there was a voltage disparity I'd put it in a 5v Socket 0/1 system, and had been running it for months that way. I figured "what the hell" and kept it in there until I could get an appropriate upgrade chip (and eventually a POD83, sometimes I swap between the upgrade Am5x86 and that.. I love advanced 486s.. speaking of which, I gotta get myself a Cyrix 5x86 100 and 133mhz to add to my experience with the various late 486 chips. :3).

    Also, though this has been said in various ways in the thread, I'm not sure if it was gone over like this:

    A 486 board with multiplier selections is *not* the norm - in fact, I've never seen one. 486 chips with multipliers are all internally multiplied AFAIK, and some of the more advanced motherboards that understand multipliers/etc. send things automatically (as you put it) from the BIOS/CMOS, which the chip can then interpret. However, most boards don't even have that, nor the jumpers, they just rely on the chip's internal workings, because that was the norm for the vast majority of the earlier 486 boards, and these were upgrade chips (yay run-on sentence!).

    As such, ignore the multipliers. Use chkcpu (http://web.inter.nl.net/hcc/J.Steunebrink/chkcpu.htm) or a similar tool to check the speed and specs for the chip, once installed, and you'll know whether the multiplier is working right, as you know what the FSB is I'm sure (and usually that either runs at a fixed speed or *does* have a jumper - most often 25/33 selectable, with better boards having 25/33/40/50/60 or 66 or combinations thereof, and the earliest 486 boards running at 16).

    Excuse my rambling, but I love 486 machines, hah. I hope some of the information I spouted here was useful, and if you'd like clarification don't hesitate to ask :3
    Last edited by Raven; October 21, 2011, 02:29 PM.

    Leave a comment:


  • orion24
    replied
    Originally posted by njroadfan View Post
    Well scratch that, the "N" version of the board is 5v only, the jumpers and voltage regulator for 3.3V are missing.
    I have a similar board as yours ( SOYO 486 VESA 4.2: http://stason.org/TULARC/pc/motherbo...A-VER-4-2.html ). Mine has the voltage fixed at 3.3V. The area where the voltage selecting jumpers were supposed to be, does not have jumpers, but it is soldered with soldering iron in the same way as it would be if there were jumpers set for 3.3V operations (I might post some pictures). It can easily be desoldered and resoldered the other way around if you know about soldering

    Originally posted by njroadfan View Post
    This board: http://stason.org/TULARC/pc/motherbo...Y-25M-N-P.html

    I have the original manual here, this board predates the 5x86 so no 4x multiplier, but does support 3.3v 100Mhz DX4 CPUs. The AMD chips seem more readily available then the DX4s. Right now the machine has a DX2-66 in it. From what I have read, apparently the board can be set to 2x multiplier and the AMD will automatically clock up to 4x for 133Mhz operation.
    It is true that setting the multiplier to 2 sets an Am5x86 to x4, but with my board, there is no jumper for multiplier selection. Unfortunately this must be done under BIOS automatically. I tried all possible combinations and it's a no-go. And I managed to get 2x and 3x multiplier settings with the exact same jumpers settings and different CPUs.
    But this didn't stop me from forcing an Am5x86 to 4x. I bent the CPU-pin that is responsible for the multiplier and grounded it myself (manual 2x multiplier force) and it worked.
    Last edited by orion24; October 19, 2011, 08:13 PM.

    Leave a comment:


  • RWallmow
    replied
    http://www.amazon.com/gp/product/B004IJ681O 486 socket 3 voltage converter, I used one of these to get a Cyrix 5x86 working in my 5volt-only Compaq CDTV 520, worked great, drop in and go, I had what I thought were some problems at first, but it turns out SYSCHK just doesn't read Cyrix CPU clock speed right.

    Leave a comment:


  • twolazy
    replied
    Just ran into this searching for what pins to bridge and which to monitor for vcc, and came onto this gem!


    See http://web.inter.nl.net/hcc/J.Steunebrink/amd5x86.htm for the whole page this came from, it has the pinout chart needed


    ... if you have a multimeter, you can use the following procedure to check this out.

    Unplug and then open the system.
    Lift the ZIF socket handle and take the CPU out. Store it in an anti-static bag or box or place it with it pins on a piece of conductive foam.
    The VOLDET pin is pin S-4. It is tied to ground (Vss) internally in the CPU. Simulate this by inserting a wire from pin S-4 to Vss pin R-4.
    Now insert two wires for the multimeter. The ground wire goes in Vss pin S-10 and the live wire in Vcc pin R-10.
    Close the ZIF socket handle to connect the wires.
    Switch the system on and check for 3.45V + 0.15V DC on the multimeter. If you see 5V, then your motherboard is not autodetecting.
    Restore everything as it was.

    Caution: Anytime before you touch any component inside your system, place one hand on the chassis, such as the power supply case, to prevent electrostatic discharge dam


    Leave a comment:


  • twolazy
    replied
    http://www.hardwaresecrets.com/article/373

    scroll to socket 3 > click pinout

    Only trick I know of to perhaps help is, I recall someone telling me when checking voltages are correct on a 486 motherboard, always use a 5v cpu to test. 5v on a 3.3v could fry it, but 3.3v on a 5v cpu would do no damage other then not boot.

    Hope someone can help more, as I will most likely use the same method to check 3.3v on my Dell 466v. It seems my machine was also sold as a dx/4 100, and supposedly has socket 3. But dell makes no references to 3.3v settings in any their manuals. Only 1 jumper labeled pent overdrive/dx4. I assume this is for 3.3v but I would love to know for sure. So if you can figure out which pins to check to 3.3v, it would definably help me out also! I just scored a 5x86 133 on fleabay for $6.61 shipped. =)
    Last edited by twolazy; September 24, 2011, 10:15 PM.

    Leave a comment:


  • njroadfan
    replied
    Locally uploaded.SY-25P.jpg

    Leave a comment:


  • Chuck(G)
    replied
    Apparently, imagestore doesn't allow linking from other websites. I get a "Your domain isn't allowed to access this image" type of message.

    Maybe a different link would help.

    Leave a comment:


  • njroadfan
    replied
    Managed to find a picture of the "P" version of the board that has the 3.3V VRM. Looks like the only parts missing is the VRM and the jumper block. I might try this mod assuming I can source the parts cheaply locally (most places online have minimum order requirements). Which pin in the socket does one test for CPU voltage? Obviously I don't want to fry a CPU, although I have read people running AMD 5x86 chips at 5v without blowing them up!

    http://imagestore.ugbox.net/image/IM...83c56bb39e.jpg

    Leave a comment:


  • Chuck(G)
    replied
    You should be able to get this to work iwth a simple 3.3V LDO, such as the LT1085CT-3. (there are similar SMT versions available, such as the LM2675M-3. The datasheet says that the operating voltage tolderance is +/- 0.3V and less than an amp. Make sure that the voltage regulators have an adequate heat sink; include a decoupling cap on the output and you should be fine.

    Leave a comment:


  • twolazy
    replied
    Well first step then would be to identify the existing voltage regulator. It may be possible to tweak the output voltage to 3.3-3.6v with a variable resistor. Can you please post the details found on the VRM, or post a clear enough picture they are readable? I may be able to help more with this information, provided you feel comfortable using a soldering iron.

    Leave a comment:


  • njroadfan
    replied
    Originally posted by twolazy View Post
    Does the motherboard have an open section for the missing voltage regulator? Could just be missing that and a linking fuse/resistor. If it was my board, I next figure out what it was missing, and duplicate it. Sounds like it be a fun easy project!
    Sure does. The silver pads are there for the voltage regulator although I have no clue what part to source. As for the jumper block, its missing and there are two small metal pieces serving as a permanent connection in the 5v position, easy to de-solder and put the proper jumper block in. I don't see any other missing components, but I haven't pulled the board out of the case to check.

    Otherwise.... anyone got a spare Pentium P24 or DX4 100Mhz 5v overdrive chip?... or one of those 3.3v socket adapters?

    Leave a comment:


  • twolazy
    replied
    Does the motherboard have an open section for the missing voltage regulator? Could just be missing that and a linking fuse/resistor. If it was my board, I next figure out what it was missing, and duplicate it. Sounds like it be a fun easy project!

    Leave a comment:


  • njroadfan
    replied
    Well scratch that, the "N" version of the board is 5v only, the jumpers and voltage regulator for 3.3V are missing.

    Leave a comment:

Working...
X