Announcement

Collapse

Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

IBM 5155 hard drive not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    IBM 5155 hard drive not working

    I received an IBM 5155 this week from its first owner.
    He bought it in 1985, used it for a couple of years and then stored it neatly in its carrying bag.
    The floppy drive needed a couple of drops of lubricant and then sprung back to live.
    Using a floppy, it boots succesfully into DOS 3.2

    The machine has a hard drive on board. It's a Rodime RO252 (ST-506/412 interface, see pictures).
    It looks to be in very good shape, but it's currently not working.

    The symptoms / things tried are:
    • When booting, the IBM returns a 1701 error code.
    • I tried to run FDISK after booting from floppy, but that just returns "no fixed drive present".
    • The power LED on the HDD is on (always on, not blinking or anything, so it's not giving an error code) and the drive select LED is always off.
    • Verified that the drive select LED works.
    • The drive is not spinning at all.
    • The head is not moving at all.
    • Stepper for the head moves freely when powered off (also applied some lubricant from the back).
    • Spindle motor also moves freely when powered off. Can't really lubricate it unfortunately, not without taking the drive further apart.
    • The spindle motor (which I think is also a stepper) also gets power when the drive is on.
    • I tested both motors by applying a bit of voltage to two of the lines and it does move. I did this with the logic board removed.
    • Voltages entering the drive logic board are verified (12v and 5v).
    • Continuity on both controller and data cable is good.
    • Did a visual check on the logic board and everything looks in great shape.
    • Also did a visual check on the hard drive controller board (Xebec, ass 104866) which also looks good.
    • Took out the ROM chips from the hard drive controller to see if I could dump them, which worked fine.
    • I didn't really dive into configuration (like jumper settings, cable type) because this machine worked when it was stored by its only owner who has never opened it.
    My next step would be to hook up my logic analyser to the controller cable to see if the drive is receiving the correct commands and what it sends back, but that will be quite time consuming so I wanted to check for more ideas here first.
    Also, I think the drive should start spinning when it's powered up? Because then I'd have to look at that first before probing the controller lines. Or is that just supposed to happen when drive select is active?
    Attached Files

    #2
    So it isn't spinning up at all? The drive should immediately try to spin up the moment power is applied, even if it isn't connected to the controller.

    A common cause is "stiction", where the head sticks to the platter and won't let it spin. Since there is something exposed that lets you move the head, try actuating that just before applying power. Also try it with the head moved all the way in one direction or the other.

    You did say that the motors move, though. Does there seem to be anything else pushing against the outer part of the spindle that might be preventing it from moving enough?

    From what you describe, it almost sounds like something on the drive's logic board isn't outputting power properly or initiating startup.

    Comment


      #3
      Tried to put the head in different positions before powering up and also tried to give the spindle a push, but it didn’t have any effect.

      I’d love to figure out if the logic board is not initializing properly, but don’t really know where to start as I have no working drive to compare it to..

      Comment


        #4
        There might be a rubber gasket that the head resides on that got sticky. Remove that and put in 3-4 pieces of heat shrink tubing on the metal bracket and use a lighter to shrink the tubing and reinstall it once it cools down.

        My Compaq Portable 1's HardCard 20 did that as well and using that method fixed the drive and it sprung to life and still runs.
        Current retro systems:
        386/486DLC, AMS NotePro Plus DSTN
        Packard Bell Pack-Mate 28 Plus
        Toshiba Satellite Pro 410CDT, 2x IBM ThinkPad 380D (both TFT)
        iMac G3/600 Graphite, iMac G4/800 Lampshade
        YouTube channel: https://www.youtube.com/c/RetroPCUser

        Comment


          #5
          I was trying to postpone opening up the drive, but don’t really have other ideas.
          So will open it up tonight and see what’s going on inside there.

          Comment


            #6
            Opened it up and nothing seemed out of the ordinary.
            Lubed the spindle motor from the inside and it didn’t make any difference.

            I’m considering a few options:
            • Try to find a known working hard drive as replacement. See if that works.
            • Forget about the HDD and find another floppy disk drive. Even a working HDD replacement is bound to break down at some point.
            • Find a modern storage device alternative to put in place of the HDD. Haven’t searched yet, but I guess there are options for using SD or something like that.
            I’m leaning towards the latter. Although it being far from original hardware, it would make it a lot easier to really use and enjoy the system.

            Comment


              #7
              The drive does not Initialyse at Boot? That is spins motor and seek Track 0, so step motor does some steps?

              If Not Maybe the X-Tal is not working. That small Yellow square.
              You have to take an oscilloscope to check if the CPU gets a Clock signal.

              Have 2x already with old drive that there is no Clock signal, so there for CPU is not running.
              Try find the marks on that yellow block.
              Than Clock must be on Pin 2 and 3 of the NEC 8049 Big IC.

              X-Tal must be at right Freq. The cpu counts the timing of the index to calculate the spin speed and regulates the spin motor that way.

              Than If your drive spins, Then try to find with Oscilloscope if the index is working.
              As well as the Track 0 Index. Spin Index old drive often with Hall-sensor, Track 0 With light diode.
              Signals to be found somewhere at the data pins of the 8049, Just step them with a probe.
              Last edited by MauriceH; May 16, 2021, 04:39 AM.

              Comment


                #8
                Looking again, This it the X-TAL, To get the D8049 mcu running.
                Rhodime-X-Tal.jpg

                Comment


                  #9
                  Thanks Maurice!
                  You are right, the crystal failed.
                  Replaced it with an 8 MHz crystal to test and the drive spins up!

                  Now I have to order the correct frequency crystal and wait to see if that results in a working drive

                  Comment


                    #10
                    Top! great news so far. You can put in a "normal" X-tal. It does not need to be spec this ceramic version.

                    Comment


                      #11
                      Originally posted by MauriceH View Post
                      Top! great news so far. You can put in a "normal" X-tal. It does not need to be spec this ceramic version.
                      Ordered a couply of (normal) X-tal which arrive tomorrow. Fingers crossed.

                      I did notice that the bottom drive head does stick a little bit when it's on the outer edge and the disk starts/stops spinning (so at slow speed).
                      It happened with the top one too and that was easily fixed by holding down a cloth with alcohol on the disk while it spinned.
                      Will try a similar approach for the bottom disk, but it's very hard to reach since it's at the bottom with just a few milimeters clearance.

                      Comment


                        #12
                        It works with the new crystal.
                        It does have other issues though.
                        I was able to read data on the disk and run programs from it.
                        But there are read errors every now and then and chkdsk sometimes says FAT 1 can’t be read.

                        I tried formatting the drive but that fails every time with an error saying something is wrong with track 0.

                        Not sure if there are things I can try to revive the drive further?

                        Comment


                          #13
                          I had a similar Rodime drive, and it became very intermittent before finally doing its impression of a chainsaw.

                          I'd say you did a good job just getting it to spin up and getting any data off of it you might want.

                          Opening it up probably wasn't good for it, but even if you hadn't I'd still expect that it would eat itself up.

                          When you say you tried to format it, did you do a low-level format? Try using SpeedStor http://minuszerodegrees.net/software/speedstor.htm to do a low level and media verify. I would not expect much, but that would at least show you errors that are cropping up now.

                          Comment


                            #14
                            You’re definitely correct about opening it up. It didn’t do the drive much good and in hindsight I shouldn’t have done it.

                            I didn’t try any special tooling yet, just the DOS (3.2) format utility. Will have a look at that link you shared.

                            Comment

                            Working...
                            X