Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

ATI VGA WONDER 16 Looking for software or solution

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ATI VGA WONDER 16 Looking for software or solution

    I have looked quite a few days now with no result so am reaching out here. Forgive me if this is covered somewhere... and PLEASE direct me to where. Purchased this card hoping to have simple autoswitching but it seems to be emulating mda on a vga monitor. without the software I'm not sure how to switch modes. I tried the xl driver that seems to be commonly available but am given an error that no ati card is in use. I am using a sony vga from 1996 if perhaps there is a compatibility issue there. 5170. any guidance would be greatly appreciated. Hope it's something simple that Im just missing. thanks.

    #2
    Download ativtool.zip from here: http://www.vogonsdrivers.com/getfile...92&menustate=0
    and run VINSTALL.EXE

    If this doesn't work, please publish picture of your card. I have about 10 different models of ATI VGA Wonder from 1988 to 1992, all work fine with this program.

    Comment


      #3
      I will try this tonight, but I believe it is the same driver I've tried. thanks! will post image of card if no luck.

      Comment


        #4
        No luck. image of card attached. error message is:

        "This installation doesn't support the video card(s) in your system. Please use ATI or ATI-compatible hardware."

        message is displayed in what appears to be mda emulation using the card.
        You do not have permission to view this gallery.
        This gallery has 1 photos.

        Comment


          #5
          I have one just like it and it works fine. May be eeprom chip is bad? I would try to swap it if I can.

          Also, if you go to checkit or similar, do you see it detecting VGA bios? Does it print VGA bios id information on boot?

          Comment


            #6
            It does print ati bios on boot vers v3m-1.0. just upgraded to dos 6.22 and interestingly during setup it seemed to identify hercules. with 6.22, no change and still same error. am using phoenix bios if this may matter set to vga. will run checkit in a moment. can reflash the ati bios if you think this may help, ill look for the file, or if you know where best to find it would be appreciated. thanks for the help..... hope to get it working!

            Comment


              #7
              the 5170 motherboard switch display switch is toward the front of the computer which should be correct. i can try different and original 5170 bios if you think may make a difference but i don't think it would.

              Comment


                #8
                checkit says mda video adapter with 4k video ram ...hmm

                Comment


                  #9
                  is the eeprom chip different than the bios? what do I need to do to swap? do i program it with anything? also have not had luck locating the v3m-1.0 bios. did find a v3m-1.0/70 ...

                  Comment


                    #10
                    Just for a sanity check: is the color/mono switch on the 5170's motherboard set for mono or color? The ATI Wonder manual says:

                    When installing the VGAWONDER in the IBM PC/AT it is necessary to set the video display switch (Color/Mono switch) on the AT motherboard to Color and run the IBM Advanced Diagnostics Program which will automatically configure the System for an EGA (Enhanced Graphics Adapter) Card, which is the category for the VGA WONDER.
                    My Retro-computing YouTube Channel (updates... eventually?): Paleozoic PCs Also: Blogspot

                    Comment


                      #11
                      It's set for color but I'm using a different bios. I will try the original bios and use the advanced diagnostics program.

                      Comment


                        #12
                        Originally posted by psbsp View Post
                        is the eeprom chip different than the bios? what do I need to do to swap? do i program it with anything? also have not had luck locating the v3m-1.0 bios. did find a v3m-1.0/70 ...
                        eeprom is different, it's just a rewritable memory for a few dozen bytes. It's not the 27c256 type ROM chips. Don't change bios, it won't do any good.

                        Did you try it on other boards? May be something a bit more recent, like 386 or 486?

                        Does 5170 board have 6MHz or 8MHz CPU? At 6MHz a lot of ISA cards seem to glitch, at least for me.

                        Comment


                          #13
                          Did you run the VSETUP tool from the ATI diskette ? VSETUP is used to set the default video mode or default monitor type.

                          Comment


                            #14
                            Checkit says cpu is 8.01 mhz. I don't think I have another eeprom chip but I will look. would it do any good to erase it and reinsert? Unfortunately don't have a 386/486 to test... could test it in an XT? I think i read it would work in 8 bit but maybe I'm misremembering.

                            Mikey99, I have been trying vinstall. Ill look around for vsetup, or if you can point me in the right direction.. great. thanks

                            Comment


                              #15
                              The manual for your card is located here :
                              http://www.minuszerodegrees.net/manu...ly%201988).pdf

                              I'm attaching a zip file of the ATI VGA Wonder first diskette files that contains VSETUP.



                              Attached Files

                              Comment

                              Working...
                              X