Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

HeadStart LX-40, anyone know of it?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HeadStart LX-40, anyone know of it?

    Hi everyone,

    I'm new here so be gentle My name is Dennis and I'm from Holland, I have a few old computers: IBM 5150, IBM 5155, IBM 5160, IBM 5170, a PS/2 Model 80 (or 60, dunno for sure, that tower model with a 80286 in it and OS/2 1.1 Ext Ed) and also a TRS-80 Model 1 (with level 2 basic).

    Next to that I also kept my first computer, a HeadStart LX-40. It's the first PC we got at home way back in 1988 (for me, that's way back). It looks a bit like a HeadStart Turbo-888XT, but has one 1.44M 3.5" floppy drive and one 360K 5.25" floppy drive, it also has a MiniScribe 40MB harddisk (I think one of those 8540XT thingies), an 8088 CPU that does 10MHz as well as 4.77MHz and 640KB memory. It comes with a HeadStart M-888-C screen (4 color CGA). And it had a software bundle that I don't use (FrameWork etc), I currently have MS-DOS 5.0 on it, PC-Tools 7.1 and some games and Word Perfect 5.1.

    Anyhoo, onto the problem: The computer still works OK, except in that it sees the 1.44M floppy drive as a 360K floppy drive. Weird thing is, if I put in a 1.44M floppy and do a "DIR A:" I get a directory listing. But when I want to format a disk, the system wants to format 360K in like 9 tracks and blabla clusters. Of course, my B: drive works OK (since that really is a 360K drive).

    Strange thing is, other than that I have no problems with the system. No boot failures, no error messages, no "CMOS battery low", no bad clusters on the harddisk (recently reinstalled it with MS-DOS 5.0 etc). There is a jumperblock on the mainbord (and the mainboard is really small, just a handfull of chips and 8 slots and the CPU) but that's only for setting options like CoPro present etc. Nothing for the floppy drives AFAIK. Plus nobody ever touched those jumpers (but I should look em up in the manual).

    So uhm, anyone know what's going on? I did change the CMOS battery out of since it was the original anyway and about 22yrs old. But to no avail, last time I used it (was still when I lived at my parents, about 1995 I guess, before I fot my 486 DX2-66), it was still working OK and then retired to the basement. I opened up the PC and everything inside looks OK, no loose cables, not even dust or crap inside (we vacuumed it once every few months).

    Tried searching the internet, but other than finding stuff about the HeadStart II and III and Explorer, there's nothing about an LX-40 (40 is probably about the 40MB harddisk) model... only LX-CD (and that's a waaaayyy later model).

    So, eventually I ended up here and after reading all the IBM posts and a post about some Dutch dude having 2 broken harddisks in his HeadStart I decided to sign up Maybe you guys can help me? It would be really appreciated, since I wanna keep this baby (my first PC that tought me everything I know about DOS, BATCH, BASIC, PKZIP, PKUNZIP, ARJ, LHA and of course Bubble Bobble hehe)

    Thanx for reading and have a good one!

    Dennis
    Oh man, this isn't happening... it only thinks it's happening. - Kevin Flynn

    #2
    Wow, I'm not familiar with that one. Pics? I'd love to see one. I have an Explorer. Here is Mine.

    Also, welcome aboard, bunch of great guys and gals here.
    The ancients knew *more* than us...
    http://www.legendarytimes.com/forum/index.php They're baaaack!

    Come and see http://www.gamegavel.com for all your gaming needs! We have Zero-ohm resistors!

    Comment


      #3
      A 3-inch floppy drive will require a high-density controller in order to use 1.44 MB disks, which is rare (but not unknown) on XT-class machines. Otherwise with a standard double-density controller it will only read and write 720K disks. In order to format 720K disks at their full capacity, you will need DOS 3.2 or higher and a DRIVPARM command in CONFIG.SYS, such as DRIVPARM=/D:0 if the 3-inch drive is the A: drive or DRIVPARM=/D:1 if it is the B: drive.

      Comment


        #4
        It looks as if you already have 1.44MB support present if you can see the directory. I suspect that you simply need to run a BIOS Setup program.

        Does your system resemble the HeadStart III?

        GSETUP may do the trick if you find that there's no key combination that will get you into the BIOS setup and you lack a setup program disk.
        Reach me: vcfblackhole _at_ protonmail dot com.

        Comment


          #5
          Originally posted by Chuck(G) View Post
          GSETUP may do the trick if you find that there's no key combination that will get you into the BIOS setup and you lack a setup program disk.
          There is no CMOS on an 8088. Like I said, XTs which support high density floppy drive (from the factory) are rare, but not unknown. My CompuAdd 810 does (HD floppy and Western Digital IDE-XT hard drive controllers are built-in). In this case, the floppy drive types are set using DIP switches or jumpers -- whose settings will unfortunately probably be inscrutable without the owner's manual or other documentation.

          Comment


            #6
            This sounds similar to a problem I had on my Zenith SupersPORT. It has a 720K floppy, but DOS 6.22 kept treating it as a 360K floppy. I solved this by adding the following line to the config.sys file to specify that it was a 720K floppy drive.

            drivparm=/d:0 /f:2

            Comment


              #7
              Originally posted by vwestlife View Post
              There is no CMOS on an 8088. Like I said, XTs which support high density floppy drive (from the factory) are rare, but not unknown. My CompuAdd 810 does (HD floppy and Western Digital IDE-XT hard drive controllers are built-in). In this case, the floppy drive types are set using DIP switches or jumpers -- whose settings will unfortunately probably be inscrutable without the owner's manual or other documentation.
              Never say "never". I've had one--and it even used a MC146818 chip. But your exception is noted--such things are rare.

              I can't find a thing on the LX40, which makes me wonder what the heck really is under the hood. A DRIVPARM should fix the problem.
              Reach me: vcfblackhole _at_ protonmail dot com.

              Comment


                #8
                Hi again, just a quick word from me (I'm at work now)

                Well, dug up the good ol' manual yesterday and opened up the PC. There's one DIP switch bank with 8 switches. According to the manual, the only switch that has anything to do with floppy (I think) is switch 4, in OFF it's "FDC Enabled" (FDC = Floppy Disk Controller?) and in ON it's "FDC Disabled". Funny thing is, the manual that comes with it says "HeadStart LX-40 user's manual" on the cover and page 1 says "HeadStart II" and the system pic in the manual is also from a II (so the slimmer case with 3.5" and 5.25" drives next to each other as to on top of each other in my LX-40). Uhm, harddrive is indeed a MiniScribe 8450XT and both controllers (floppy and HDD) are on board. The display card is some CGA graphics card that has "ATI" printed on it. Funny thing is: it's got a switch to go mono/color and also the mouse (a BUS mouse) connector is on that card.

                I do remember that this thing was a bit exotic (as they said in the store back then, V&D in Holland, part of Vendex Holding) as in that it could handle both 720K and 1.44M 3.5" floppies (it can't handle 1.2M 5.25" floppies though, only 360K). From what I know when we got it, we had MS-DOS 3.31 on it. Still have that somewhere, but then my uncle (from whom we got this system) got a 386 and got MS-DOS 5.0 with it. So then we got a copy (on 2 3.5" 1.44M disks) and also installed MS-DOS 5.0 on our HeadStart. Somehow I also got PC-TOOLS 7.1 on the system and that also comes on 4 1.44M disks, so the system always handled 1.44M floppies OK. There was also some kind of tool called "fd.exe" you could load into memory and call with a hot key. That tool would then kind of auto-sense the floppy in drive a (either 720K or 1.44M) and format it accordingly.

                So yup, I always had 1.44M support and the fact that it gives a DIR off a 1.44M disk also makes it still read it. But when I start PC-TOOLS (or diskfix.exe for that matter), I can only see drives C: (40M), B: (360K) and A: (also 360K). And when I try to format drive A: it also comes up with a message it will format 9 tracks blabla sectors "type = 360K". If I just press enter to confirm it comes up with "Drive Not Ready: Abort, Retry, Fail?". Could maybe the floppy drive itself be faulty? (also some 3.5" drive with a Philips sticker on).

                As for the BIOS, there's an Award BIOS chip on board but it boots with "HeadStart LX BIOS, Vendex Systems 1987-1988" it does not show any "Press ?? key to enter BIOS". But AFAIK that wasn't possible with teh majority of XT computers (?). By the way, there's "Made by Philips Canada" stickers all over the thing. I thought these were made in Korea or something? Oh wait, I know, I have some kind of one off secret government project computer nobody knows of LOL

                Neh but serious, I'll try to get some pictures up... but if you look in google for a HeadStart Turbo-888XT system, mine looks the same, except with a 3.5" floppy drive as the top drive (the 888XT has two 5.25" above each other). Case looks the same, monitor is also a M-888-C monitor. The rest is pretty standard for the later XT models: 640K memory, the CGA adaptor, oh yeah and I also have an AT style (so F1-F12) keyboard as were most XT's had F1-F10 keyboards (well, at least all my friends had, they didn't have HD 3.5" floppies either and not 4 color CGA).

                Well, that's as much info as I can give now... Oh yeah and about that "DRIVEPARM", we never used that in our CONFIG.SYS. It was always a standard CONFIG.SYS that came with DOS (3.31 and 5.0). And the only thing in AUTOEXEC.BAT that's loaded is MOUSE.COM for the BUS mouse. I mostly had around 580K of memory free on this system, I can remember that.

                Thanx for all the replies, I really hope I can get this fixed... But since I can't find anything about this system anywhere (never seen one for sale, never seen another person have one, never seen one in a garage sale, never found anything on the internet), there's probably not much I can do about this. Could it be the BIOS chip got corrupted somehow and the drive parameters are off (dunno much about ones and zeros, though). But since there's no way to get into the BIOS of an XT I have no way of checking (or even repairing if it got off/corrupted). Or is that what GSETUP does? I think I'll get some of those old system tools, like sysinfo or something (can't remember the name). You know, those programs that would tell you how fast your PC is compared to the original IBM PC. Those also reported memory, disks etc... see what that comes up with. Maybe it's just PC-TOOLS screwing me over, since I get no errors when booting whatsoever.

                @NathanAllan: I also had an Explorer a while back... got it from someone, but when the harddisk died I tipped the system. It was nice though, with the hardrive in a caddy with fan, really funny. I think that one only did 720K 3.5" disks right?

                OK, have a nice one again!
                Oh man, this isn't happening... it only thinks it's happening. - Kevin Flynn

                Comment


                  #9
                  Oh yeah, I'll have a go with setting DRIVEPARM tonight if I have the time for it... I would think that if I set drive 0 to type 1.44M it would actually either work or getting me some kind of mismatch error or something. I'll also see what MS-DOS format comes up with (because PC-TOOLS renames FORMAT to FORMAT! so when using FORMAT the Central Point format/unformat comes up). So if it's just PC-TOOLS being screwy (would be first in my experience... and I've had PC-TOOLS since version 4.3 Deluxe), MS-DOS format would just do 1.44M fine. The floppy I did a DIR on and gave a listing was actually a Linux boot disk formatted in some XP computer, so I think the 1.44M support is still there...

                  Dennis
                  Oh man, this isn't happening... it only thinks it's happening. - Kevin Flynn

                  Comment


                    #10
                    OK guys,

                    Made some pictures (with my cell phone, sorry for the quality):





















                    As you can see from the last pictures, the manual is a HeadStart II manual... and only switch 4 is FDC ON/OFF. So uhm, any suggestions? Anyone with a HeadStart II that treated drive A: as 360K??

                    Maybe I'll make some more when it's back together again... Thanx for reading and have a good one!

                    Dennis
                    Oh man, this isn't happening... it only thinks it's happening. - Kevin Flynn

                    Comment


                      #11
                      You can always consider disabling the FDC and just inserting an ISA FDC card.
                      Je kunt ook overwegen om de FDC uit te schakelen en een ISA FDC kaart te installeren.
                      Last edited by Erik; January 22, 2011, 08:58 PM.

                      Comment


                        #12
                        Hi Dennis,

                        What I can find out about your system seems to indicate that it's based on a motherboard manufactured by Samsung for Philips Vendex. You also have a real-time clock that requires that a program called ST.COM be used to read and set the system time (note the coin cell on the motherboard).

                        Apparently the system was shipped with MS-DOS 3.3H, a sort of Compaq DOS 3.31-lookalike to support hard drive partitions larger than 32MB.

                        Since you can read a high-density floppy in your A: drive, there's support for it in the system BIOS. All you need to do is tell DOS that you have a 1.44MB drive, which can be done by inserting the following line into the CONFIG.SYS file on your boot (hard) drive:

                        DRIVPARM=/D:0 /F:7

                        That's it--DOS will now consider your A: drive to be a 1.44MB unit. If you create a disk to boot from A:, make sure that this statement appears in the CONFIG.SYS for that drive.
                        Reach me: vcfblackhole _at_ protonmail dot com.

                        Comment


                          #13
                          Hi Chuck (and who else reads this),

                          Well, tried the DRIVPARM setting and it ended me up having a floppy drive with no format at all Made some more pictures to clear things up (not solving anything unfortunately):

                          First off, entered the DRIVPARM setting into CONFIG.SYS and rebooted the machine... started DISKFIX (PCTOOLS 7.1) and it gave me this (note, A: has no size/format):


                          So then I removed the DRIVPARM setting and rebooted, this time booting from a 1.44M floppy disk:

                          As you can see it boots...

                          So, after rebooting (because you can't install Linux on a 8088 hehe) I did a DIR A: and this is what showed up (note the "bytes" and "bytes free"):


                          So, started Norton Disk Doctor... two 360K floppy drives apparently (PCTOOLS 7.1 also thinks that):


                          Started up CheckIT! (found that still on the harddisk):

                          Hmmmm, so maybe a 1.44M drive after all?

                          Did a disk check and it turned out OK:




                          System Check:




                          Disk Check:


                          But when I try PCTOOLS format or MS-DOS format I get this again:




                          So still unable to use/format/copy stuff onto/off 1.44M disks... weird though that CheckIT! does see it as a 1.44M 3.5" drive (and that should be correct, it has always worked that way without DRIVPARM or anything else). I must say I'm puzzled at this
                          Last edited by Denniske1976; January 21, 2011, 11:25 AM.
                          Oh man, this isn't happening... it only thinks it's happening. - Kevin Flynn

                          Comment


                            #14
                            I still think maybe it has some jumpers or DIP switches set incorrectly, because my CompuAdd 810 also has an Award XT BIOS dated 1989, and yet it supports a 1.44MB floppy drive with no problems in DOS.

                            Maybe you can try this program, which should tell DOS to recognize the drive as 3" 720K -- still not correct, but definitely better than acting as if it's 5" 360K!

                            ftp://ftp.oldskool.org/pub/tvdog/tan...isc/setbpb.zip

                            Comment


                              #15
                              You're running DOS 5.0? Try formatting with:

                              FORMAT A: /N:18 /T:80

                              or

                              [b']FORMAT A: /F:1440[/b]

                              DOS gets the drive capacity from the boot sector DPB when reading and writing. However FORMAT uses what the BIOS says, which obviously isn't right.
                              Reach me: vcfblackhole _at_ protonmail dot com.

                              Comment

                              Working...
                              X