Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

5160 BIOS Source Code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Plasma,
    Looks like the interrupt vector issue is solved. I programmed a couple of 27c256's and plugged 'em into u18 and u19 and it booted up perfectly. IFSHLP.SYS loaded ok and so did SBFMDRV.COM. Also, ROM BASIC comes up perfectly when the space bar is pressed durring the pause at startup.

    Now for the not so good news. Dos Navigator version 1.51 doesn't respond to input from the keyboard after it is started. The Control, Alt, and Shift keys cause the menu selections to change but none of the other keys work, and after enough key presses, the speaker starts to chirp as the buffer fills up. If you're not familiar with Dos Navigator, it can be found HERE. It's a very powerefull dos shell that ran great with IBM BIOS and a minimum V-20 proccessor. I don't think it will run on a 8088.

    Let me know if you need more info, and / or if you figure out the problem.

    Thanks for your help. I think "Super PC/Turbo XT BIOS" is great!! It could be super great if this issue is fixed!!

    P.S.
    I built the bios with MAX_MEMORY = 640, FAST_MEM_CHECK = 1, BOOT_DELAY = 3, all other options dissabled. I also tried it with the KEYB_SHIFT_FIX enabled, but that didn't make a difference. Just a shot in the dark.
    Last edited by ibmapc; March 6, 2012, 08:48 PM.

    Comment


      #17
      Sorry I haven't had a chance to look at this yet. I will try to have something for you by Saturday.

      Comment


        #18
        That's OK, no big rush.

        Comment


          #19
          Ok, I found the problem. DOS Navigator calls enhanced keyboard functions which are only found in the 1986 XT and later BIOSes (Int 16h ah=10h/11h). The 1982 IBM XT BIOS as well as all other clone BIOSes I tested (Phoenix, Award, and DTK) have the same problem with DOS Navigator because they do not support the enhanced functions either.

          However since my BIOS doesn't discard extended scan codes, this is easy to fix. I just mapped the enhanced functions to the standard ones, problem solved. I did a quick test with DOS Navigator and it seemed to work fine. The new version is up on my site, let me know if you find any issues.

          Comment


            #20
            I've been following this with interest - awesome work Plasma

            Comment


              #21
              That's awsome, Plasma! Can't wait to get home and burn another Eprom to try it out.

              Comment


                #22
                Plasma,
                I've been running version 2.3 for several hours now. Dos Navigator runs correctly now. However, there are a couple of new issues. First, the driver for my AST HotShot 286 accelerator, FDD.SYS, hangs durring startup. So, I temporarily rem'ed it out in config.sys. Also, other TSR's that use a "Hot Key" to launch, don't respond to the hot key. The accelerator works Ok without the driver, it's just stuck in 286 mode and can't be switched to Non accelerated V-20 mode without changing a jumper on the card.

                The attached HOTSHOT.ZIP file contains FDD.SYS and HOTKEY.COM. I don't know if FDD.SYS will do you any good without the card. HOTKEY.COM is a program that is used to determin the scan code returned when a key or combination of keys is pressed. Then, that scan code is used in config.sys to set the hotkey that triggers FDD.SYS to switch modes as follows; Device=FDD.SYS /key=xxxx where key = the scan code found with HOTKEY.COM. HOTKEY.COM won't run either, presumably for the same reason that FDD.SYS won't work.

                Also Dos Navigator hangs up if I launch it when Microsoft Network Client v3.0 for MS DOS is running. I'm not sure if this last problem is new or was there before the latest update.

                You've done a commendable job with "Super PC/Turbo XT BIOS" so far. I sometimes feel like maybe I'm asking to much to get it to run with everything that the 5/8/'86 IBM XT BIOS runs. Maybe that's why the IBM BIOS is so big(32K). Be sure to let me know if I'm driving you NUTS with all this!

                Regards,

                Greg

                Comment


                  #23
                  Hmmm ok. Is the HotShot problem new or was that also happening with v2.2?

                  Comment


                    #24
                    Originally posted by Plasma View Post
                    Hmmm ok. Is the HotShot problem new or was that also happening with v2.2?
                    The Hotshot problem is new, as is the TSR hot key problem. I think the trouble with the HotShot driver is related to the TSR problem as it uses a hot key to toggle the mode. Difference is, when FDD.SYS comes up in config.sys, it causes the system to hang. Other TSR's "appear" to load, but do not respond to the hot key.

                    Comment


                      #25
                      I have the Hotshot problem sorted out. Basically it was checking for enhanced keyboard support by calling int 16h/ah=05h to stuff a fake keystroke into the buffer and then trying to read it with int 16h/ah=10h. I added support for ah=05h and it appears to be working properly but I would like to test it some more. Can you tell me the other TSRs that were having problems with 2.3?

                      I assume DOS Navigator works ok with MS Network Client when using the 1986+ IBM XT BIOS? Can you tell me how far it gets before it hangs?

                      I should be thanking you for helping me improve the BIOS, more compatible is always better

                      Comment


                        #26
                        Glad you've got the HotShot problem worked out.

                        The TSR's that I've had trouble with are MS Network Client pop up window, and when running DR Dos 7.03 (I'ts setup to boot either PC Dos 7.0 or DR Dos 7.03) the Taskmgr does not respond to the Hot Key.

                        Yes, Dos Navigator runs with MS Network Client with '86 IBM XT BIOS. When running your bios, if Network client is running, Dos Navigator hangs at the beginning, as soon as the title is displayed. If I recall correctly, It doesn't require a power down, just a Cntrl-Alt-Del.

                        Thanks for your efforts here. I'm glad to help make "Super PC/Turbo XT BIOS" a better product. I only wish I had a better handle on Assembly Language programming. I've just recently tried to dabble with it but haven't yet been able to dedicate a lot of time studying it. Maybe some day I'll get a grasp on it.

                        Regards

                        Greg

                        P.S. Do you have a version available or can you tell me the changes in the code that makes the HotShot driver work?
                        Last edited by ibmapc; March 16, 2012, 04:13 PM.

                        Comment


                          #27
                          Sorry man, it looks like I made a mistake. The problem keeping the TSR's from seeing the "Hot Key" was not related to your Bios. I had made some changes to my Config.sys and Autoexec.bat files and the TSR's were either not loading or they were configured for a different hot key than what I thought. Hope you haven't wasted to much time trying to track down this problem. Please accept my sincere apologies. I'll try to not make this type of mistake in the future! Although, as I get older and grumpier it seems I catch myself blaming something for a problem and then not being able to look past it.

                          So, it looks like the only issues I'm seeing with Super PC/Turbo XT BIOS ver 2.3 is the HotShot driver, which you mentioned had been figured out, and the MS Network Client keeping Dos Navigator from loading.

                          Comment


                            #28
                            Ok no problem. I am working on some 101-key keyboard improvements and then I will look at the network client issue.

                            Comment


                              #29
                              Originally posted by Plasma View Post
                              Ok no problem. I am working on some 101-key keyboard improvements and then I will look at the network client issue.
                              Hey, Plasma;
                              Any progress on this? Do you anticipate releasing the next version soon?

                              Comment


                                #30
                                Yeah sorry I have been really busy lately. I still have some bugs to work out. I will try to get something done this week.

                                Comment

                                Working...
                                X