Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

286 Parallel Port cdrom no labelling, drivers unknown

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SpookyZalost
    replied
    Originally posted by SpidersWeb View Post
    So if I'm reading it correctly, you've got the IBM PS/2 Model 50 to load a driver and detect the CDROM? If so, that's an extremely good start.

    Did you add MSCDEX with the correct options in your AUTOEXEC.BAT file? <-- this is what actually assigns a drive letter and makes it accessible in DOS.

    p.s. drive wont be from the 1980's, more likely 1992-1995 would be my guess.
    well the drive lights up on bootup, it recieves signal, and I'm guessing there is some hardware communication, and the driver I used was the free dos one, as well as a few other generic ones, which seem to get part way but won't detect the drive completely, my thoughts are that it's because it's not internal, but that's just a guess.

    Below are some pictures I took of the unit, the last one being a stripped screw, of which there are at least 3

    https://dl.dropboxusercontent.com/u/...219_232734.jpg
    https://dl.dropboxusercontent.com/u/...219_232802.jpg
    https://dl.dropboxusercontent.com/u/...219_232915.jpg
    https://dl.dropboxusercontent.com/u/...219_232943.jpg

    there is no identifying information, my theory is that the case was bought and a drive put inside instead of a whole unit being bought.
    Last edited by SpookyZalost; February 19, 2014, 10:38 PM.

    Leave a comment:


  • SpidersWeb
    replied
    So if I'm reading it correctly, you've got the IBM PS/2 Model 50 to load a driver and detect the CDROM? If so, that's an extremely good start.

    Did you add MSCDEX with the correct options in your AUTOEXEC.BAT file? <-- this is what actually assigns a drive letter and makes it accessible in DOS.

    p.s. drive wont be from the 1980's, more likely 1992-1995 would be my guess.

    Leave a comment:


  • SpookyZalost
    replied
    Originally posted by Chuck(G) View Post
    So my first question is: Do you really have a parallel port drive or is it a SCSI device? Many devices of the time used the same DB25 connector that parallel devices used.

    What machine were you trying it on where it worked? Who made the CD-ROM box?

    Just trying to get some basic information...
    ok, I used it on my 486 which has a parallel port in the back, that one is running a light weight linux distro, (very lightweight) and it seemed to show up ok and I was able to mount it as a disc drive after some tweaking and config file editing.

    also tried it on my Pentium 3 which was running crunchbang, again worked with some tweaking, I didn't try it on a win 98 machine yet, but I probably should.

    the external case for the cd rom has no labeling at all, no stickers no model numbers, nothing, other than a label written on tape to give it a number probably for a server center or a computer lab, the screws are stripped so I decided against trying to open it to see what the manufactuerer is nor if it's a scsi or ide drive, I will see about having some pictures uploaded after work to give you guys a better idea about what I'm talking about.

    Leave a comment:


  • Chuck(G)
    replied
    Parallel port CDs usually aren't really parallel port--there's a bus replicator to SCSI or sometimes IDE in the box that hooks into a conventional CD-ROM. As far as I'm aware, there's nothing in the PS/2 BIOS that can identify any specific device on a parallel port--it's all done with loadable drivers.

    So my first question is: Do you really have a parallel port drive or is it a SCSI device? Many devices of the time used the same DB25 connector that parallel devices used.

    What machine were you trying it on where it worked? Who made the CD-ROM box?

    Just trying to get some basic information...

    Leave a comment:


  • SpookyZalost
    started a topic 286 Parallel Port cdrom no labelling, drivers unknown

    286 Parallel Port cdrom no labelling, drivers unknown

    ok, so I've waited a bit, made sure registration went through, researched a bit on the forum, did some google searching (how I originally found this place), but so far I'm having no luck, so I thought I would ask if anyone else might be able to shed some light on this dilema I'm having.

    I have a PS/2 Model 50 running MSdos 5.1, works fine, runs the original simcity really well, and I've recently gotten a parallel port CD rom drive, which hardware wise checks out, loads up on newer machines ect...

    now the computer bios picks up the parallel port cd rom, so I'm fairly certain this is a drivers issue, though I'm not sure where, and I've tried to use generic drivers without much more success than hardware being detected, I was hoping somebody could give me an idea how to go about getting my old 286 to detect the cd rom, which I believe is from around the same time (mid to late 1980's?), wost case, I may have to drill the screws because they are stripped so I can get at the case and see what the manufacturer of the drive is inside the enclosure, but I would like to avoid that if possible.

    I don't intend to play music or anything, just be able to read larger data chunks than what's on floppy discs, however slow that may be, though I do understand that the amount of memory available might be an issue, so I'm somewhat unsure if I can get this much farther.

    but if anyone might have an idea about how to get this working, I would love to hear some suggestions, about the only thing I haven't tried is finding an audio card with a parallel port CD connector, or installing some form of 286 compatible unix, other than that, I'm fairly stumped.

    any help would be appreciated, and thanks in advance!
Working...
X