Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

Headstart LX-CD

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by modem7 View Post
    What is the part number printed on that EPROM ?
    The large S symbol informs me that it is made by Signetics, but I cannot make out the part number.
    S 27C256 -15 FA , the sticker said 00181

    db
    You do not have permission to view this gallery.
    This gallery has 1 photos.

    Comment


      #32
      Is that 40-pin header an onboard IDE-XT (XTA) interface? If so, it may be conflicting with the XT-IDE card, unless you can find some way to disable it.

      Comment


        #33
        Yes, the HDD is supposed to be connected straight to the motherboard without a special interface card. I have no normal way to disable the onboard controller that I know of. I've searched and found in the manual the meaning of the dip switches, I've translated it from Dutch.

        Settings for dip switches
        1 On, No 8087 present (default)
        1 Off, 8087 present

        2 On, One diskette station present (default)
        2 Off, Two diskette stations present

        3 On, Parity chips installed (default)
        3 Off, No Parity chips installed

        4 On, Monochrome
        4 Off, Color (default)

        5 On, Disable parallel port
        5 Off,Enable parallel port LPT1 (default)

        6 On, Disable COM1
        6 Off, Enable COM2 (default)


        7 On, Disable COM 2 (default)
        7 Off, Enable COM2

        8 On, Disable Floppy controller
        8 Off, Enable onboard floppy controller (default)
        I've found in my stack two prospects for testing, one is a old 8 bit modem card which looks like it contains a EPROM the other is a EZ-2000 ethernet card, with a Novell bootrom, however that last one is a 18 ISA card.

        For the sake of sanity, if this computer does not accept bootroms, what options remain bar buying a original miniscribe and praying it will continue to work?

        db

        Comment


          #34
          Originally posted by Dirtbag View Post
          S 27C256 -15 FA , the sticker said 00181
          Thank you. I have added the ROM image to the collection at [here].

          Comment


            #35
            Originally posted by Dirtbag View Post
            For the sake of sanity, if this computer does not accept bootroms, ...
            Your "bootroms" should be "non-video bootroms" because the BIOS expansion ROM (boot ROM) in the VGA card is displaying "ATI VGAWONDER ..."

            I see that in post #8, member Denniske1976 (still active) indicated that he has/had a HeadStart LX-40 to which he added an XT-IDE.
            Presumably the LX-CD is the LX-40 but with a CD-ROM drive and card added ???
            He wrote, "... it took some work to be able to get the card working with the machine ..."
            Maybe Denniske1976 has the answer.

            Could it be that the Headstart LX does support non-video BIOS expansion ROM's (boot ROM's), but only in a narrow range of addresses.

            Comment


              #36
              Originally posted by Dirtbag View Post
              ... what options remain bar buying a original miniscribe and praying it will continue to work?
              So, using the 40-pin IDE header on the LX's motherboard.

              The LX is an 8-bit computer, and so it makes sense to me that the IDE interface is 8-bit (not 16-bit, the norm), requiring an 8-bit IDE drive. See the top-right corner of [here].

              A photo of the LX and its Miniscribe drive is in the first post at [here]. I cannot make out the drive's model number, something that is expected to inform us whether 8-bit or 16-bit. Maybe the author of that post is still active on vogons.org

              Perhaps the use of a low capacity 40-pin DOM ([example]), but one that can switch into 8-bit mode. Not an area of my expertise, and so someone else may comment on that.

              Comment


                #37
                According to post #8 it's a miniscribe 8450XT https://www.vcfed.org/forum/forum/ge...-cd#post583846 , there it's also said that a 64 mb DoM did work on a LX-40. After I'm not a bit drunk I'll go and order a / some DoM to test this.I don't mind testing with a couple of tenners on stake. It beats having this computer in store without being able to use it at all.

                Secondary is getting the CDROM drive to work. I've not been able to test that one yet.

                I can however note that adding a standard IDE CF thingamabob that I use in a multitude of computers makes the LXCD to not boot at all. All tough I might try again with another adapter that plugs in directly instead of on a bracket and cable.

                db

                Comment


                  #38
                  Sony CD drives of that era need to be checked for electrolytic cap leakage

                  Comment


                    #39
                    Originally posted by Dirtbag View Post
                    ... there it's also said that a 64 mb DoM did work on a LX-40.
                    I read that it was attached to the XT-IDE card, not to the 40-pin IDE header on the LX's motherboard.

                    Comment


                      #40
                      Originally posted by modem7 View Post
                      Thank you. I have added the ROM image to the collection at [here].
                      Two comments It's a Headstart LX CD, I have no idea if there is much difference between the LX CD and the LX40 but it might be.
                      Second comment, I grabbed the rom using a XGECU TL866 II plus programmer, not using debug. I pulled the chip from the mobo.

                      I tried thusfar a 16 bit videocard. upon booting the screen blinks brightly with

                      **** UMC SuperVGA UM85C408 70hz - 1991, 1992 *****
                      Bios version 1.04, BOARD VERSION ISA-1AV Data:09/29/93 DRAM: 1M

                      So it will accept a different bootrum, but won't continue with it. But as this is a 16 ISA card this is not entirely weird to not work.
                      (the ATI VGA wonder that is native to the system has a software utility to switch between 8 and 16 bit mode, with a warning in the manual not to put it to 16 bit)



                      Adding the 14.4 kbaud modem card (ISA 8 bit) has no influence upon the booting, nor can I find any reference in the memory that it has a bootrom.


                      Adding the EZ-2000 (16 ISA card) has influence on booting, as in, it halts it after sizing the system memory and the RAM buffer. So that that does an influence but I'm not helped by it in any way. However, I have no idea to what adress it is set. No jumper to read so either it's not configurable(unlikely) or it's set by software.



                      Also, I've read the explorer thread of Denniske1976 however he was helped by a bios 0.11 by hargle in combination with a DOM card on the XTIDE, might be looking badly for me as I've got XTIDE with CF only. Nor can I find the actual 0.11 bios to test this.

                      I've PM'ed Denniske1976 and hope he'll respond

                      db




                      Comment


                        #41
                        Originally posted by Dirtbag View Post
                        Two comments It's a Headstart LX CD, I have no idea if there is much difference between the LX CD and the LX40 but it might be.
                        Second comment, I grabbed the rom using a XGECU TL866 II plus programmer, not using debug. I pulled the chip from the mobo.
                        I have made those two changes to my web page.

                        Comment


                          #42
                          Okay, some progress has been made...

                          I'v obtained the Hargle 0,11 bios.

                          The bootbios will now show it self during boot. YAY

                          However, it wil not detect the CF card. It will scan for two but will not detect the one that is in there. So maybe I should have gone for a XTIDE with a IDE port. Probably will still do this.

                          However, after I uploaded the Hargle 0,11 via the XTIDE CFG program I cannot go back to the old BIOS, I tried uploading it via the config and via the programmer but after I've programmed the EEPROM with the version that came from it before I tried the 0,11 I still cannot save changes via the XTIDECFG.

                          Not really troubled by that latter one though, I still got about 7 suitable EEPROM's to plop in there to try another one

                          I was looking into the Glitchworks rev 4a, but the kit is not in stock.

                          I've been busy doing other stuff as well so progress was and will be slow

                          db

                          Comment


                            #43
                            Okay.. It's been a couple of days.....

                            I ordered and received two glitchworks Rev 4 cards. Also I've bought 2 DOM's (32 and 64 megabyte)

                            Assembled one GW card, cleaned it with alcohol after soldering (regretted it immediately) cleaned it with water and let it dry for a week or more.

                            I tried it in the headstart LX CD and got nothing. Fearing bad soldering or my alcohol fukkup I continued trying in the headstart III.

                            I got it fully working with the 64 mb DOM. Using the default version of universal bios that's on it upon delivery (I had to re write it after a failed testing however, glad I bought 2 cards) and setting like seen in the photo's.

                            Only weird thing is that it RAYXTIDE will note it used multiple adresses.

                            After that I put it in the Headstart LX CD and at first it would not do anything but boot from floppy.

                            I then pulled the EEPROM with the 1.1.5 original (from glitchworks) and put in my EEPROM with the Hargle 0.11 but that did nothing

                            I rewrote the Hargle bios first using the EEPROM writer after that it will show itself during boot, it will detect the Transend DOM, it blinks a couple of times with a screen displayed very shortly, then it will state that the BIOS is installed but will not continue. I gave it 15 minutes before deciding it had hung.

                            I then disabled the EEPROM on the card to be able to boot from floppy, reenabled the EEPROM on the card after booting and then I used XTIDECFG to flash the EEPROM with the hargle bin.

                            This gave me the same results.

                            Pff....



                            Grabbed a *blank* EEPROM from the stack and put it in the card and disabled EEPROM on the card to boot to dos.

                            After booting enabled the EEPROM and flashed the 2.0.0 Beta 3 R620 XT_IDE.bin to the EEPROM.

                            Booting goes straight to the floppy. Also I noticed that RAM BUFFER SIZE 0KB now shows during boot, it should be 128 k. On a video I made I see that with the hargle 0.11 this was also the case however there the screen isn't displayed very long.


                            Any suggestions would be greatly appreciated


                            I'm off doing something else for the moment....


                            db





                            Attached Files

                            Comment


                              #44
                              Originally posted by Dirtbag View Post
                              Only weird thing is that it RAYXTIDE will note it used multiple adresses.
                              That is something that needs investigation.

                              I wonder if it is related to something I see:
                              Refer to [here]. Your XT-IDE REV 4 card uses a 28C64 and therefore, the two '8K' switches on switch block SW2 should be on, but in the XT-IDE photo, those switches appear to be off to me.

                              Comment


                                #45
                                EUREKA

                                IT WORKS

                                You were correct, I had the 8k switches backwards, I put them in the correct settings, plugged the EPROM with the Hargle 0.11 in the card and it worked.

                                Still have the ram registering incorrect, but I can boot from the XTIDE and I've copied over the original menu's. Still have some trouble getting the original dos version on it thoug, I currently have dos 5.0 on it.

                                It should have a dutch DOS 3.31h installed and I have all the files. However... I have to have the original boot disc to get that going first. Because to install a certain dos version you need to boot that version. To boot that version you need the bootdisc. Goto 10 situation here.

                                BUT IT WORKS

                                I'll post photo's of the card for settings and upload the hargle rom so anyone looking for it can grab it here again

                                db
                                Last edited by Dirtbag; October 27, 2021, 02:41 PM.

                                Comment

                                Working...
                                X