Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

T1000 battery pinout

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    T1000 battery pinout

    I made the mistake of telling some work colleagues that I was interested in old computers, and one of them bought me a 1987 Toshiba T1000 that they saw in a junk shop (the one with the ROM hard drive, 512kB of RAM and 720kB floppy drive).

    It doesn't work, of course. I received it with all the screws missing from the case, and someone had half-inched the battery pack, so I suspect it may have been stripped for parts.

    Without the battery pack, it won't start up, at all. The power LED doesn't even come on. The battery's supposed to be a quartet of 1.2V nicads, producing 4.8V. I actually *have* some (pulled from my T3100SX), so I might try to bodge something up; the problem is that the battery connector has four pins, and there's no indication of what they do.

    The maintenance manual says that the voltage between pins 1&2 and pins 3&4 should be about 5V. This implies that pins 1 & 2 and pins 3 & 4 should be shorted together. Right now, with the 9V power supply connected, I'm seeing voltages ranging from about 4V to 9V across various pins, so that makes me kinda uncomfortable. Is shorting them together reasonable?

    Additionally, I'd rather like to run the thing without batteries entirely, purely off the mains; any ideas?

    #2
    Hey, look what I found. Not specs, but a decently high-res photo of somebody bodging up a new battery pack... with the red and black leads shorted together:



    (From here: http://www.pcworld.com/article/30018...of-ms-dos.html)

    Comment


      #3
      Originally posted by hjalfi View Post
      Hey, look what I found. Not specs, but a decently high-res photo of somebody bodging up a new battery pack... with the red and black leads shorted together:

      From here: http://www.pcworld.com/article/30018...of-ms-dos.html)
      Take another (good)look, the two red leads are connected to the white clip (+) on the battery pack and the black leads are connected to the black clip (-) on the battery pack. No shorting at all.
      Reach me: vcfblackhole _at_ protonmail dot com.

      Comment


        #4
        Sorry, that should have been phrased as 'both red leads and both black leads are shorted together'...

        Anyway, applying 5.1V (it wasn't happy with less) to the battery connector made it go beep and lights lit up and stuff. Eventually the drive pulsed. Typing 'DIR A:' and pressing return made the drive pulse again.

        But nothing came on the screen. Adjusting the contrast did nothing. It may be that it's set to the external display. I don't think I have anything which will display composite, and I haven't figured out how to change the display setting (I tried Fn plus every key on the keyboard, to no effect).

        Leaving the leads shorted together and then applying 9V to the external power socket caused the screen to flicker, the light lit briefly, then fade. Power cycling repeats this. The voltage across the battery terminals at this point is 9V. I'm going to put this as a very confused battery charger doing odd things.

        I now notice that the article I linked to stated that the battery voltage was 7.2V. I also found a forum thread saying the same thing. This is incorrect; the maintenance manual states firmly that the nominal voltage is 5V, min 4.8V, max 5.5V. Adjusting the battery voltage very slightly from 4.9V to 5.2V causes the power LED to change from red to green as it no longer thinks the battery is flat, so the hardware agrees.

        I don't think that it's worth experimenting more until I can rig up a battery, because I suspect that the power circuitry relies on having one present. Embarrassingly, though, I can't figure out how to get any of my existing nicad battery packs open --- they're all astonishingly well glued shut...

        Comment


          #5
          I have pretty good luck either tapping vigorously with a rawhide mallet or just throwing them on the (concrete) floor a few times. It usually succeeds in breaking the seams open. Same technique for "wall wart" power supplies.
          Reach me: vcfblackhole _at_ protonmail dot com.

          Comment


            #6
            The T1000 may be similar to the T1100 regarding the battery. See [here]. So, for a battery-less T1100, I can power it per [here].

            Comment


              #7
              Brute force worked to open the battery packs.

              I wired up a battery pack and let it charge for a while. Unfortunately, something bad seems to have happened and now the T1000 won't do anything on poweron --- the power light changes colour to indicate the battery status, and it does seem to be charging the battery, but now the computer itself is completely unresponsive. Where previously I'd get a beep and about 30s later see the FDD pulse, now I get nothing. Removing the battery again and applying 5V across the battery connector doesn't work either.

              I suspect that I've either broken it somehow or an elderly cap has given up the ghost.

              The caps all look good --- no goop, no bulging. There's a mild hot-electrical smell which may be due to a white ceramic resistor which gets warm during charge. One oddity is that the power LED stays green all the time the battery is connected, even if the mains is disconnected. That doesn't seem right.

              I'm not really sure how to proceed at this point.

              Comment


                #8
                I'd start by checking the larger capacitors first--it's not necessary for them to be bulging to be bad--and check that resistor's value. Its not unusual for a power resistor to change value drastically when it fails.
                Reach me: vcfblackhole _at_ protonmail dot com.

                Comment


                  #9
                  Please let me know how this turns out for you. I also have a T1000 with a similar issue. The power light comes on green for a second or two and turns off. Fortunately, I had the battery rebuilt using the original wires and pin header. I used (4) SubC NiCd NUN2100-CSF cells.

                  IMG_1251.jpg

                  Comment


                    #10
                    I think I'm going the shelve this one for a bit. I have a mini composite monitor (for a car reversing camera!) on order. Before doing anything irreversible, I want to check for video signal on the composite output. It's possible that my fiddling has somehow got it into a state where it's powering on successfully but not going through the usual boot sequence of a beep and a disk pulse. But it'll be a few weeks before it gets here.

                    Re the power light going on and then going off again: if it fades, then that's exactly the behaviour I saw when I shorted pins 1&2 and pins 3&4 on the battery connector, but didn't actually connect a battery. I think the battery's an integral part of the power supply and with it not present it simply won't run. So maybe your battery pack is toast.

                    If I knew more about electronics I'd be tempted to try connecting a 5V zener diode in place of the battery to see if that'll simulate the right voltage drop.

                    Comment


                      #11
                      Update: the composite monitor arrived. I plugged it in, powered up... nothing happened.

                      So either the signal being produced by the laptop isn't what the LCD composite monitor thinks of as being a signal, or else something in the computer is fried. Either I broke it while fiddling with it, or a capacitor has faded. I'm afraid I don't think I'm up to diagnosing that. I am on the lookout for an oscilloscope with a component tester, as that'll provide a really simple way to check for dead components, but removing them from the board for testing is beyond me and I doubt I'd get a clean signal testing them on the board.

                      The one remaining unknown is that the monitor is a modern LCD job which automatically switches on when it detects a signal, and it's not. Can anyone confirm (or, preferably, deny) that a 1990-ish mono composite signal is likely to work with this? Are there any NTSC/PAL-like gotchas here?

                      Comment


                        #12
                        Originally posted by hjalfi View Post
                        Leaving the leads shorted together and then applying 9V to the external power socket caused the screen to flicker, the light lit briefly, then fade. Power cycling repeats this. The voltage across the battery terminals at this point is 9V. I'm going to put this as a very confused battery charger doing odd things.
                        Is the original AC adapter 9V? IF you see 9V at the battery, something important was broken at or before that point, I'd reckon.
                        Twitter: @adambrisebois
                        Discord: YesterGearPC#0001
                        Youtube: YesterGearPC

                        Comment


                          #13
                          Originally posted by hjalfi View Post
                          Update: the composite monitor arrived. I plugged it in, powered up... nothing happened.
                          According to the T1000 summary document at [here], a keyboard sequence is required to switch screen output to the 'External display'. 'External' may include both RGB and composite ports.

                          Comment


                            #14
                            So I found an oscilloscope and had another go.

                            The PSU sort-of works, and is feeding sort-of 5V onto the board. I'm increasingly unhappy about it PSU, because the board voltage appears to be exactly what's coming out of the batteries, which can vary from 3V to 5.1V depending how tired they're feeling. So I've given up on the batteries and the 9V external power supply and am instead just feeding 5V directly into the battery terminals.

                            So now that it's got clean power, I can find 5V power lines at various points on the board, which means that power propagation is working. The composite port and the RGB port remain completely dead. There is some activity on the LCD connector. I found a 500khZ signal on one pin and a 2MHz signal on another pin, but the screen doesn't show anything. I tried to look for a clock on the processor but it's an exotic M80C88A QFP package and I couldn't find the pinout...

                            The first time I powered it up, it beeped. Then about 30 seconds later it beeped again, and the drive chugged, which indicates it was working through the bootup sequence. But it was disassembled on my bench and the screen was disconnected, so I didn't see anything, and it didn't do it again.

                            This feels like a marginally borked component. I can see power everywhere, so that suggests it's not the PSU, but the maintenance manual states that the LCD takes +5V and -22V, and I certainly didn't see -22V on any of the LCD connector pins. If the PSU has failed in some way where it's mostly failing to generate the right voltages, and the reset logic is waiting for all the exotic voltages to stabilise, that would explain the symptoms I'm getting...

                            Oh, and just to make life more fun, the manual on minuszerodegrees is for a different issue of the board than I actually have, so some of the jumpers are different.

                            There aren't very many PSU capacitors, and none of them are bulgy. I suppose I could just remove them all and test them, but given my soldering skills that risks irreparably damaging the board.

                            https://photos.google.com/photo/AF1Q...y8T-fsnAYdFUES

                            Comment


                              #15
                              More than just capacitors can die in power circuitry, I've had all sorts of grief with dead transistors, mosfets and diodes. Another annoyance is if an optocoupler goes away or starts misbehaving, it can cause the output power rails to go crazy or just fail to work.

                              Comment

                              Working...
                              X