Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

XTIDE Universal BIOS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    WIP I'm afraid

    Comment


      Originally posted by keropi View Post
      Wow, I missed the pre-built binaries links on the new homepage, where is it?
      The archive I posted above is not needed then since there is an official one
      It's not on the main page. I read the whole thing top to bottom in an attempt to work out how to download the binaries. I eventually just started clicking on all the links on the page one at a time in order to find them, this lead me here, then starting at the end I had to go back posts till I found the link here.

      Can I make a suggestion? If so, then the suggestion is simply to put the link to the binary downloads at the top of the page in a clear manner (like "Download the pre-compiled binaries here").

      Also, what is the current version? The main page goes on about V2.0.0 Beta 2, but the binaries are listed as Rxxx, so it is very difficult to correlate the version talked about in the wiki to the pre-compiled binary.

      IBM 5160 - 360k, 1.44Mb Floppies, NEC V20, 8087-3, 45MB MFM Hard Drive, Vega 7 Graphics, IBM 5154 Monitor running MS-DOS 5.00
      IBM PCJr Model 48360 640kb RAM, NEC V20,, jrIDE Side Cart, 360kb Floppy drives running MS-DOS 5.00
      Evergreen Am5x86-133 64Mb Ram, 8gb HDD, SB16 in a modified ATX case running IBM PC-DOS 7.10

      Comment


        To be honest I would ignore version numbers as the project is now just using build numbers. Always go with the latest build as it's in a bug fix state currently, i.e. very little new functionality has been added for a while.

        Download links, forums, bug tracker are all things I would like to do. Any volunteers able to muck in would always be welcome

        Comment


          Originally posted by pearce_jj View Post
          ... Always go with the latest build ...
          I have to disagree here. The latest version doesn't work on my "HIGHLY MODIFIED 5155". I can't get anything newer than r588 working, possibly due to timing issues. I have an AST HotShot 286 Accelerator running at 10mhz and at that speed the newer versions don't work. r588 works perfectly however.
          Last edited by ibmapc; January 8, 2017, 11:47 AM. Reason: Update speed of Hot Shot to 10mhz

          Comment


            Are you able to identify the component(s) that cause this?

            Comment


              Originally posted by Malc View Post
              The XT-IDE Universal Bios has a new home now.... http://www.xtideuniversalbios.org/
              I'm missing a link to the sources or aren't they available any more? (or did I miss something?)

              TXS for any info or link!
              With kind regards / met vriendelijke groet, Ruud Baltissen
              www.Baltissen.org

              Comment


                Browse source at the top

                http://www.xtideuniversalbios.org/br...rsalbios/trunk

                Comment


                  Originally posted by pearce_jj View Post
                  Browse source at the top
                  The problem is, and I realised this only after about 15 minutes: the site is displayed in Dutch. I started to notice when looking at one of the makefiles, on the top left of the text was the word 'regel' displayed, meaning line number in this case. Going back to the link you gave me, I noticed that the words 'Bron weergeven' were white-on-black. Then I realised that this meant I was looking at the source code part. The funny thing is, we Dutch also use the word 'sources', or more often 'source code'. The way 'bron' is used here is actually wrong, it should have been 'broncode' or even 'brontekst'. The Dutch version of Wikipedia uses 'brontekst' so one can have a look at the source code how the page has been written. And I assumed this 'Bron weergeven' meant the same. Not one hair on my head, and I have still a lot, thought about 'source code'.

                  Thanks!
                  With kind regards / met vriendelijke groet, Ruud Baltissen
                  www.Baltissen.org

                  Comment


                    I didn't know the site even had multi lingual functionality It's just standard trac though, bug should be sent to their mailing list I guess: https://trac.edgewall.org/wiki/MailingList

                    Comment


                      Originally posted by pearce_jj View Post
                      Are you able to identify the component(s) that cause this?
                      Not for sure. but it seems to work ok at 4.77 mhz which also uses the 8088 instead of the 286 at 10mhz on the HotShot. I posted previously HEREpost #307 and after.

                      Comment


                        PROBLEMS getting "Lo-Tech-Compact Flash Adapter" to initialize in ISA Slot on 8086 XT PC (Amiga Bridgeboard)

                        Hi,

                        I've been struggling few a while, trying many way to get a Lo-Tech 8 Bit ISA/IDE CF adapter working on my 8086 PC
                        The XT PC is is a Bridgeboard Accellerator card that is located inside a Amiga Chassis, (but the card mostly works indepedantly as a PC)

                        Specifically this version of the Adapter.
                        https://www.lo-tech.co.uk/wiki/Lo-te...er_revision_2b

                        I have a two computers to test with to ensure things work (ie Flash Card, SD Card works)

                        The purpose is to replace my existing old Hard Drive Controller / Hard Drive Combination (WORKING, but too small, too slow, too old):
                        - The Current Controller is a (ISA 8 Bit) Western Digital (MFM/RLL) HD Controller (Model # WD10020-27X)
                        http://stason.org/TULARC/pc/hard-dis...-driv-220.html
                        - The Current Hard Drive is a KALOK Ocatcon KL330 32 Mb
                        http://www.mfarris.com/hard_drives/k...lok_kl330.html

                        The above is fully working. Tested by Norton and Spinrite (100% Pass)
                        Base address is C800, and I've proven I can access it via (MS DOS "debug" via -g c800:5, to Access the interactive Low Level Format BIOS)

                        I've tried to replace the HD controller/Drive with a (Lo-Tech-Adapter and (IDE Drive, IDE-CF Adapter, IDE-SDcard Adapter), and nothing works in the 8086 XT PC.

                        To prove that the parts work I also tested in a 486 PC running MS DOS6.2

                        I tested with a Seagate Maxtor IDE Hard Drive (Works in 486)
                        http://redhill.net.au/d/23.php

                        I tested with a Syba IDE to CF Flash Adapter (Works in 486)
                        http://www.ebay.ca/itm/400815453925?...%3AMEBIDX%3AIT

                        I tested with a Secure Digital IDE to SD Card Adapter (Works in 486)
                        http://www.ebay.ca/itm/Secure-Digita..._qi=RTM2247628

                        They all work in some way in the 486 (Directly attached via BIOS/Montherboard) and work with ISA/IDE adapter (on the same 486)

                        None of the POSSIBLE combination work in the 8086 setup on the ISA/IDE Adapter
                        I even tried two versions of the X-IDE Image
                        - The standard Image
                        https://www.lo-tech.co.uk/downloads/...ster-slave.zip
                        - and the Late Init version for Tandy
                        https://www.lo-tech.co.uk/downloads/...-late-init.zip

                        None of above work in the 8086, but both work in the 486 (with a small glitch on the ISA/IDE adapter and Compact Flash)

                        In all configurations, I am picking up the Storage device as Master.

                        *** WHAT HAS BEEN NOTICED IS THIS ***
                        - Using the DEBUG "-g c800:0", I can see the lo-tech ISA/IDE adapter. I see the text for the banner message in Base Memory Location (I can also change jump and shift locations).
                        - ABOVE I see in 486 and 8086 (same location)

                        But in the 8086 it won't the ISA/IDE Card Won't Initialize.
                        Note the WD Controller on the same c800 address does initialize and I have a working C: Drive

                        I can provide more information, or do more tests.

                        Looking for some advice on how to debug more?
                        Maybe another X-IDE image to try (a mod)

                        Appreciate any assistance.

                        Here is a summary of the test configuration's and results in a PICTORAL TABLE

                        https://www.flickr.com/photos/147613...posted-public/

                        If anyone is interested in the Arctecture of the Amiga and Bridgeboard, here is the design of the computer in detail
                        https://archive.org/details/Commodor...1987_Commodore

                        Comment


                          Just to add, the issue is that the XTIDE Universal BIOS is not initialising with the device in the bridge board. The Western Digital controller however does.

                          Comment


                            SUCCESS!! Lo-Tech ISA/IDE-CF Adapter Working in Amiga / Bridgeboard (8086) XT PC. (Initialized X-TIDE)

                            So I finally got the Lo-Tech Adapter working with X-TIDE Universal BIOS. I almost gave up.

                            I had some luck and DOUBLE stumbled upon the solution.

                            I've tested a few times and appears to be consistent Positive.

                            Further testing and understanding of exactly how things work is needed.
                            I'm no expert on Either Amiga or Bridgeboard, but a ton of testing and luck made things work.

                            SUMMARY:

                            1) The Amiga Bridgeboard boots on Powerup, but doesn't Active till the JANUS.library loads via the AMIGA workbench Boot disk.
                            2) However that isn't enough to Initialize the Lo-Tech / X-Tide
                            3) After Amiga Boots up, to active the 8086 XT you launch the PC-Window (Where the 8086 XT PC runs in)
                            4) But that still by itself won't initialized the Lo-Tech / X-Tide (since by design the Amiga Architecture Disables AutoBoot when a Controller/Hard disk in inserted into the ISA SLot)
                            5a) To enable HARD file Autobooting a File (Aboot.CTRL) is normally placed in the AMIGA (SYS:PC/System folder)
                            5b) Normally the Aboot.CTRL file has an entry that Points to a previously created HARD file on the Amiga Side
                            5c) But if that file is there, the PC XT will boot from the File like a normal C: Drive
                            5d) During multiple testing, I by accident removed the HARD file Entry from the Aboot.CTRL file (to supress the error Message, since I removed the HARD FILE)
                            5e) Had I remove the file (not emptied it), things wouldn't work, since AUTOBOOT would be disabled (thus no initialization of LO-Tech/X-Tide)
                            6a) That still would be enough since if the Amiga sensed the Lo-Tech Adapter via INIT it wouldn't turn on AutoBooting
                            6b) So it's IDEAL that Lo-Tech does not get recognized on Power up on the PC XT ISA bus.
                            6c) The 2nd Stumble luck was I didn't reboot the Amiga, and I had the DOS Floppy disk out of the A: Drive
                            6d) Instead of Power Reboot, I did a CTRL-ALT-DEL to reboot the XT PC 8086 a 2nd time, while amiga side was up, and Autoboot enabled with the empty Aboot.CTRL File.
                            6e) That triggered a normal XT PC boot, and since JANUS.library on Amiga Side was already started, the boot was a Standard Phoenix BIOS boot
                            6d) That 2nd XT Boot now does a initialization of the Lo-Tech Adapter with X-Tide BIOS, and the IDE connected device boots

                            The X-TIDE Firmware Image I used in the Lo-Tech is the First one in above post. No the Delayed Init/Tandy version.

                            I tested with the IDE-Seagate Maxtor Drive and it works.
                            I also tested with the Secure Digital SD-Card Adapter and it works. (Picture below)
                            Haven't tested with the Compact Flash Adapter, but I'm pretty sure it will work.

                            Here is proof things worked. Retested a few times and the sequence describe above is working/consistent.

                            2017-02-27_Double-Reboot-AfterAmigaPartitionCreated-VintageSmall.jpg

                            Comment


                              Glad it's sorted, and thanks for posting the details.

                              Comment


                                Anyone had any luck using a flashed PROM with the latest version of the XUB on a 3Com 3C509-TP card? I can't seem to work out how to get it to work, it does work on the XT-IDE rev 3 card I have, so I know the BIOS is flashed right. I am guessing I need to somehow enable the ROM socket or put it at a certain address, but there are no jumpers on this card.

                                With the BIOS chip installed on the card, there is no XT-IDE BIOS screen at all in the 5170 I am trying to use it on.

                                Thanks in advance!

                                IBM 5160 - 360k, 1.44Mb Floppies, NEC V20, 8087-3, 45MB MFM Hard Drive, Vega 7 Graphics, IBM 5154 Monitor running MS-DOS 5.00
                                IBM PCJr Model 48360 640kb RAM, NEC V20,, jrIDE Side Cart, 360kb Floppy drives running MS-DOS 5.00
                                Evergreen Am5x86-133 64Mb Ram, 8gb HDD, SB16 in a modified ATX case running IBM PC-DOS 7.10

                                Comment

                                Working...
                                X