Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.

Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.

Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.

Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.

Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.

Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.

Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.

New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.

Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

XTIDE Universal BIOS v2.0.0 beta testing thread

  • Filter
  • Time
  • Show
Clear All
new posts

    I wonder if it's worth trying a separate serial card if you got one ?, Just to rule out problems with the serial on the xtide.


      Originally posted by Malc View Post
      I wonder if it's worth trying a separate serial card if you got one ?, Just to rule out problems with the serial on the xtide.
      A good idea, but I have none capable of 460k baud besides the XTIDE. And at 230k baud it's working properly with only about 10% throughput penalty. I can live with that.


        Hello guys, I just was trying to build the blobs under linux and it went mostly good. However, I had to fix something to make it work. Where can I submit the patch/suggestions? Thanks in advance.


          Posting bugs in this thread is the norm, There's no where else, However updates are few and far between these days, I always use windows xp.



            I am unable to have my 5.25 1.2M floppy drive properly recognized with ide_xt and ide_xtp. The drive is considered by the OS as a 360K one when such a bios is present. The drive works fine with ide_tiny, but then, no CF.

            My setup is:
            - PC Epson Equity II (NEC V30, 640 KB RAM, one 5.25 HD floppy, no extension board)
            - XT-CF Lite V4.1 (Address C800h, port 320h)
            - MS-DOS 6.2
            - Transcend CompactFlash Industrial CF300 128MB (TS128MCF300)
            - XTIDE bios r602 and previous (r528 customized from Sergey, r588...)

            Tests performed, without success:
            - Many changes of address and port on the XT-CF-Lite card, flashing both ide_xt and ide_xtp accordingly to port after running auto-configure in xtidecfg.
            - Build r602 on Linux with minimum DEFINES_COMMON in the makefile (progressively down to the options of DEFINES_XT_TINY). The floppy drive doesn't work as soon as MODULE_8BIT_IDE_ADVANCED is included, which is mandatory for CF support.

            When the drive is wrongly recognized, the same error as Drew noticed in #528 appears (unable to format the floppy).
            The functions 08h and 15h of int13 seem to be involved in floppy drives detection, so I tried calling them with debug utility. I'm not sure whether these functions are the only ones.

            Code I used for calling function 15h:

            xor ax, ax
            mov es, ax
            mov di, ax
            mov ah, 15
            mov dl, 00
            int 13
            int 3

            Function 15h result with drive recognized as HD (ide_tiny in ROM or ROM disabled):
            AX=0200 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
            DS=16AD ES=16AD SS=16AD CS=16AD IP=0108 NV UP EI PL NZ NA PE NC

            Result with ide_xt or ide_xtp in ROM:
            AX=0200 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
            DS=166E ES=166E SS=166E CS=166E IP=0109 NV UP EI NG NZ AC PE CY

            3 flags are different. I understand that the carry flag here means an error occurred in the function call.

            Function 08h with drive recognized as HD:
            AX=0140 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
            DS=16AD ES=16AD SS=16AD CS=16AD IP=0108 NV UP EI NG NZ AC PO CY

            Function 08h with drive recognized as 360K:
            AX=0100 BX=0000 CX=0000 DX=0000 SP=FFEE BP=0000 SI=0000 DI=0000
            DS=166E ES=166E SS=166E CS=166E IP=0108 NV UP EI NG NZ AC PO CY

            AX contains 0140 when the drive is fine, 0100 when ide_xt or ide_xtp is in the ROM.

            Thanks for your help!


              Freddy, have you tried adding a line to the config.sys to specify the drive parameters?


              DRIVPARM=/D:1 /F:1 /H:2 /S:9 /T:80

              More info:
              My Retro Collection:
              CBM: C64, Amiga 500 x2, 600 & 1200
              Apple's: IIc, Mac SE, LCII, LC630 & Power Mac G3/233 Desktop
              PC's: K6-III+ 500 System + Roland MT-32 & Tandy 1000 EX 640kb, 3.5" FDD, CF-IDE 4GB HDD
              Visit my Tindie store for Tandy 1000 Adapters for EX, HX, SX, SL, TX & TL etc


                Hello dJOS,

                I've tried DRIVPARM=/D:0 /F:1 in the config.sys (but no heads/sectors/tracks), without success. I've also tried DEVICE=C:\DOS\DRIVER.SYS /D:0 /F:1. Not better.
                Unfortunately, I don't have the computer at hand at the moment. I'll give your hint a try (with all the drive characteristics) ASAP, and keep track of what msd.exe shows.

                Thanks and Regards


                  I believe I have found a bug in how XUB builds the MODULE_COMPATIBLE_TABLES fixed-disk parameter table (Int 41h/46h) during initialization.

                  If RESERVE_DIAGNOSTIC_CYLINDER is not defined, the cylinder count in the FDPT is correct.

                  However, if it is defined, the cylinder count listed there is one-less than its proper value.
                  This is because the FDPT initialization routines call the same subroutine that the Int13 AH=08 handler uses to check for a cylinder count > 1024.

                  If I understand the AT BIOS source correctly, the Int13 legacy functions (AH < 19h) are what require the use of RESERVE_DIAGNOSTIC_CYLINDER, in that AH=08 was documented to return 2 less than the total cylinder count (zero-indexed with the landing zone as the "diagnostic cylinder"). This of course affect a number of other functions in the AT BIOS, but in the XUB it only affects AH=15h. The FDPT stored at Int41h was supposed to be the actual number of cylinders, heads, and sectors per track.

                  I found this issue after trying to use Windows 3.1 32-bit disk access with my QD6580 VLB controller. Each driver (WDCTRL,WDCDRV.386,MH32BIT.386,ONTRACKW.386) kept failing at phase 3 of real-mode initialization. Phase 3 is a check of the cylinder count of the FDPT vs Int13 AH=08 function.

                  I have attached a patch file with the changes in the 2 files that would resolve this issue. This is a "zero-byte" patch which just changes the call made during FDPT construction to after the RESERVE_DIAGNOSTIC_CYLINDER decrement. I have done some testing with PCem using various utilities and drivers and all seems well. Please let me know if I am missing any information or am just completely off-base. Thanks for your time.
                  Attached Files


                    Not sure where in the thread this may belong, but I thought I'd start at the end. Here's the background -- I'm resurrecting an old machine, and the CPU card has a BIOS that won't handle a drive over 504MB. So, I downloaded the 2.0B3 ROM and put it on a network card (@C8000), so I have that running.

                    I don't know whether it's the XT-IDE BIOS or controller, but I have found it very sensitive to both the drive vendor (I have a mix of old Maxtor, Quantum and WD drives, all 2.5GB or smaller) and the master/slave setting. The only combination I was able to get to work in order to copy the old drive was the old Maxtor 345MB drive as primary and a SanDisk 1GB CF card as secondary.

                    Once I copied everything over, the system will not boot off of the new drive even though XT-IDE shows the drive as the first master. If you use F2 to look at the boot menu, the first partition table entry is "81H Foreign File System" (or something like that) and the second is "80H SanDisk...". If I select the second entry, it boots just fine. I did check the drive with PartitionMagic and it shows only one partition (FAT16, Primary, Active). If you look at it with FDISK, the "foreign" reports as Drive C with 504MB size and Drive D as 997MB (which is the size of the CF card).

                    Not sure what to do about this, but at least I can boot it, although with manual intervention. I thought I'd report it in case it hasn't come up before. If there's an easy way to fix this, I'm all ears. Otherwise, maybe I'll copy everything off of the CF card, wipe it, and start over.

                    Web site:
                    Web site:


                      Sounds like you need to rewrite the master boot record on your cf card


                        Originally posted by maxtherabbit View Post
                        Sounds like you need to rewrite the master boot record on your cf card
                        Ahh, good point. I ran "fdisk /mbr" and by itself, that didn't help. So, I booted from a floppy, re-wrote the system using "sys", and then did fdisk/mbr again and it works. Running fdisk still shows two separate hard drives, one at 504 (D) and one at 977 (C), but if I check the size of the drive, it shows the right amount of free space. Kind of odd, but at least it boots properly now.

                        Thanks for reminding me about the MBR.
                        Web site:
                        Web site:


                          right, because that command only writes the MBR to the primary HDD in the system
                          so when you booted from the mechanical IDE drive and ran the command, it rewrote the MBR for the mechanical drive only

                          the way XUB handles booting from D: is by swapping the logical HDD assignments, booting from A: left the CF card assigned as HDD0


                            As a side note, I experienced two full-drive corruptions this weekend with the above setup, both when the drive reached 50% full, which would be just over 500MB (formatted capacity is 997MB). Once was unzipping a very large file (happened to be a ZIP archive of Microsoft Visual C++ 1.5 for Windows 3.1) and the second was installing the same from within Windows 3.1. The corruption required a full reformat and re-copying from the original drive (which I had saved onto another PC) because it seemed to destroy the MBR, FAT and directory.

                            I swapped the 1GB card for a 512MB one, and it seems to be working fine and there's enough empty space for me to get done what I need to get done for this project. So I'm not going to tempt fate by fiddling around with it any more. Moral of the story is to stock up on 512MB CF cards for these old machines

                            Web site:
                            Web site:


                              I've used 8G DOMs and cards with XUB 2.x without any issues, so I'm not sure why you experienced corruption. It might be related to something else. If you can, maybe you should try the disk media test of DISKTEST.EXE with the 1GB card with something like 16M or 32M sizes to see if you have something else going on.
                              Offering a bounty for:
                              - A working Sanyo MBC-775 or Logabax 1600
                              - Music Construction Set, IBM Music Feature edition (has red sticker on front stating IBM Music Feature)


                                Anybody has r519? I'd like to see if my eco-lite XTCF card would work with this version.

                                Also if someone can share the "idedtct" program that searches for all installed hdd's, that would be great!