Announcement

Collapse

Forum etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


"PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

XTIDE Universal BIOS v2.0.0 beta testing thread

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trixter
    replied
    That's a direct contradiction to what you wrote earlier. Does the XUB work in an IBM BIOS 5170, or not?

    As for 8-bit vs. 16-bit, I didn't say I would use it permanently; I said I would test it.

    Leave a comment:


  • Malc
    replied
    Originally posted by Trixter View Post
    That's very encouraging. The next time I refurbish a 5170 or 5162, I'll deliberately install the latest XUB on an XT-IDE card and run tests.
    I wouldn't recommend using an 8-bit XT-IDE in a 16-bit AT, It's a lot slower, Much better off using a 16-bit controller in the AT, I still use the AMI bios in my 5170 because the known issues still exist with the 5170 IBM bios fitted.

    Leave a comment:


  • Trixter
    replied
    Originally posted by Malc View Post
    he was using the XUB r602 and a 16-bit controller with Original IBM Bios in his 5162 with no problems, I had been using the AMI Bios in my 5162 for a long time, I fitted the Original IBM Bios back in my 5162 and found that with the Original IBM 5162 bios fitted, 16-bit IDE / floppy controller and XUB r602 it did indeed work just fine, What changed in the XUB or when it changed i don't know.
    That's very encouraging. The next time I refurbish a 5170 or 5162, I'll deliberately install the latest XUB on an XT-IDE card and run tests.

    Leave a comment:


  • Malc
    replied
    Originally posted by Krille View Post
    I see. Your last two posts here seemed to indicate that 16-bit interfaces would work, at least if using the newer versions of IBMs system BIOS, but I guess I misunderstood then? That's too bad.
    In post #21 of that thread i was referring to my 5162, Previously "maxtherabbit" had posted that he was using the XUB r602 and a 16-bit controller with Original IBM Bios in his 5162 with no problems, I had been using the AMI Bios in my 5162 for a long time, I fitted the Original IBM Bios back in my 5162 and found that with the Original IBM 5162 bios fitted, 16-bit IDE / floppy controller and XUB r602 it did indeed work just fine, What changed in the XUB or when it changed i don't know.

    In post #22 IIRC The XUB + IBM 5170 Bios + XT-IDE OR 16-bit controller was a complete failure
    What worked was an old Seagate hard drive + 16-bit controller + IBM 5170 Bios and No XUB.

    I wonder what jumper JP5 does on that DTK controller?
    Dunno, it'll be interesting to know though, I don't have one of them controllers.

    Leave a comment:


  • Krille
    replied
    I see. Your last two posts here seemed to indicate that 16-bit interfaces would work, at least if using the newer versions of IBMs system BIOS, but I guess I misunderstood then? That's too bad.

    I wonder what jumper JP5 does on that DTK controller?

    Leave a comment:


  • Malc
    replied
    Originally posted by Krille View Post
    ....As far as I know, this applies only to XT-IDE cards. Presumably he is using a regular 16-bit IDE interface since he is using a NIC to host the XUB.
    This applies to both the XT-IDE cards and 16-Bit IDE / Floppy controllers when used in the 5170 with Original IBM Bios, Swapping out the IBM Bios for the AMI bios or the likes makes all the problems go away. However there are 16-Bit IDE / Floppy controllers out there that supposedly work with the IBM Bios https://stason.org/TULARC/pc/hard-di...-PTI-2-26.html Scroll down to "User configurable settings" JP5, Whether that includes the 5170 IBM Bios i don't know.

    Leave a comment:


  • Krille
    replied
    Originally posted by JohanLu View Post
    Now I just made a copy of that card to a 16GB card (as I filled the 256Mb I wanted a bigger one) but XTIDE does not seem to find the disk.
    So the CF card is not being detected by the XTIDE Universal BIOS? Are you by any chance using the beta 3 version available from here? If so, use the latest version from here instead.

    Originally posted by Trixter View Post
    You should be aware that the original IBM 5170 BIOS, all three revisions, have an incompatibility with the XUB that has not yet been adequately explored. The result is that bits are silently corrupted to/from the media after booting. If you replace your AT's BIOS with an AMI equivalent, these problems go away.
    As far as I know, this applies only to XT-IDE cards. Presumably he is using a regular 16-bit IDE interface since he is using a NIC to host the XUB.

    Leave a comment:


  • Trixter
    replied
    "I just made a copy" hides a great deal of information. Generally, you should format new media on the target system itself to ensure properly translation. If you fdisk /mbr on the AT, then format c: /s on the AT, and it boots properly with everything recognized, THEN you take it out of the system and copy files to it.

    You should be aware that the original IBM 5170 BIOS, all three revisions, have an incompatibility with the XUB that has not yet been adequately explored. The result is that bits are silently corrupted to/from the media after booting. If you replace your AT's BIOS with an AMI equivalent, these problems go away.

    Leave a comment:


  • JohanLu
    replied
    Asking in this thread instead of creating a new one.

    Running a XTIDE bios in my 5170, with a 256mb CF card it recognizes the card, boots fine on any of the 30Mb partitions I created. Can also use larger (than 32MB) partitions, even if I have not booted on them (yet)... The XTIDE BIOS sits on a 3COM NIC. The IDE controller came with the 5170 (I tried some of the IDE that I had laying around which did not work with the floppy, don't know if this controller was something special, the MFM is not anymore in the computer and I did not get it with the computer.

    Now I just made a copy of that card to a 16GB card (as I filled the 256Mb I wanted a bigger one) but XTIDE does not seem to find the disk.

    I run the exact same type of card (and setup) in a newer computer, where it works. There the IDE card is of a newer model. Its a SanDisk Ultra 16GB 50MB/s. That was the "best" available from my local store. Maybe a 1GB would have been better, but that was not available on the shelf, and as the 16GB worked good in my other computer I thought it was a safe pick. And yes, I tried the both cards in the newer computer and both were detected.

    Did search for info, but did not find anything I think point me in the right direction. Is there a limitation for the 5170 for max size of the actual card?

    Leave a comment:


  • Trixter
    replied
    Originally posted by ki4swy View Post
    Disable smilies when posting, as this was mangled. The link in this post is correct.

    Leave a comment:


  • Malc
    replied
    Originally posted by ki4swy View Post
    ok, i think i may have figured this out.. it appears i have to use the config program to set up the eeprom file before writing to my eeprom.
    Yes you must configure the XUB correctly using the XTIDECFG.COM config program FIRST before writing to Eprom / EEprom, Modem7 has info on the 4 original revisions of the XT-IDE Here that may help.

    Leave a comment:


  • ki4swy
    replied
    ok, i think i may have figured this out.. it appears i have to use the config program to set up the eeprom file before writing to my eeprom.

    Leave a comment:


  • ki4swy
    replied
    So using the -xt.bin from http://www.xtideuniversalbios.org/binaries/ boots to "D000 ROM" and just hangs..

    I wish i saved the rom i had before

    Leave a comment:


  • ki4swy
    replied
    I have this board:

    https://retrobrewcomputers.org/doku....a:xt-ide:start

    from this thread:

    http://www.vcfed.org/forum/showthrea...support-thread

    I will try the prebuild binaries you posted and see if i have better luck, they do look different then the ones i have.

    Leave a comment:


  • Malc
    replied
    where are you getting the XUB binaries from ?, The Official XUB Pre-Built Binaries Download Centre is here: http://www.xtideuniversalbios.org/binaries/
    Also what revision of the XT-IDE board do you have: Rev 1 / 2 / 3 or 4,

    The Original Rev 1 XT-IDE did not support the "Chuck" Mod when released, The Chuck mod came after and some folk did the modification to their Rev 1 boards, The Rev 2 / 3 and 4 XT-IDE's support Hi Speed mode aka the "Chuck mod" via jumpers. Did you configure the XUB using XTIDECFG.COM correctly setting "Device type" to "XTIDE rev 2 or modded rev 1"

    Leave a comment:

Working...
X