Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

8bit Friendly ISA VGA cards

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hi,

    Today i tested some ISA-16 videocards with Juko ST XT turbo board with NEC V20 and 8088 CPUs. I tried Trident TVGA8900D, Trident TVGA9000C and Realtek RT3105E. Both Trident's card without success. With TVGA9000C i tried to change the video-BIOS from version 4.3 to 4.5 without positive result. Also i tried change "Slow mode address detect"/"Fast mode address detect", "Standart BIOS wait states"/"Extended BIOS wait states" hardware config with help pull-down resistors. No result. Work perfect in 386 board ISA-8 slot and don't working at XT board at all. I don't know which differences...

    So, Realtek RT3105E video-card work good in XT isa-8 bit slot. No jumpers on the board, full auto-detect.

    Comment


      #17
      Originally posted by Tronix View Post
      Work perfect in 386 board ISA-8 slot and don't working at XT board at all. I don't know which differences...
      Makes you wonder... Perhaps it uses 286+ instructions in its BIOS code?
      That's the only logical explanation I can think of, if it works in an 8-bit slot on a 386.
      http://scalibq.wordpress.com/just-ke...o-programming/

      Comment


        #18
        Originally posted by Scali View Post
        Makes you wonder... Perhaps it uses 286+ instructions in its BIOS code?
        That's the only logical explanation I can think of, if it works in an 8-bit slot on a 386.
        Unfortunately, i don't think so... I tried load trident BIOS on the 8088 emulator (PCEm) and its worked wery well.

        Comment


          #19
          Originally posted by Tronix View Post
          Unfortunately, i don't think so... I tried load trident BIOS on the 8088 emulator (PCEm) and its worked wery well.
          I've seen plenty of code that works fine in emulators, but was completely broken on real hardware
          PCem doesn't simulate the FPU interface of an 8088/8086 properly, for example.
          http://scalibq.wordpress.com/just-ke...o-programming/

          Comment


            #20
            Originally posted by Scali View Post
            I've seen plenty of code that works fine in emulators, but was completely broken on real hardware
            PCem doesn't simulate the FPU interface of an 8088/8086 properly, for example.
            Yep, i know but it is not suitable for the current situation. I do some experements: i modify Super PC/XT BIOS, part checking ROM-extensions and their checksums. I added sound notification long beep-short beep-long beep if add-rom bios checksum failed:

            Code:
            	call	checksum_entry			; Find ROM checksum
            	;jnz	@@bad_rom			;   bad ROM
            jz load_rom
            	push bx
            	mov	bl, 2				;   long beep
            	call	beep
            	mov	bl, 1				;   short beep
            	call	beep
            	mov	bl, 2				;   long beep
            	call	beep
            	pop bx
                       jmp @@bad_rom         ; go away
            load_rom:
            and... i listen long-short-long beep when Trident card inserted into my XT board.. So, main BIOS found 0x55AAh add-rom signature but other bytes corrupted and checksum failed. Then I have tried dump data from C000 segment over COM-port (because i don't look anything on the screen) with help Int 14h interrupt:
            Code:
            ;	mov ah,00h 
            ;	mov al,0E3h 	;9600,8N1
            ;	mov dx,0
            ;	int 14h    
            
            ;	mov ax,0c000h              ;video BIOS seg
            ;	mov ds,ax
            	
            ;	mov ah,1
            ;	mov al,'O'
            ;	mov dx,0
            ;	int 14h
            ;	mov ah,1
            ;	mov al,'K'
            ;	mov dx,0
            ;	int 14h                        ;send "OK"
            	
            ;	mov cx,08000h             ;32kb
            ;	xor si,si                       ;offset = 0
            ;loop_out:
            ;	lodsb
            ;	mov ah,1
            ;	mov dx,0
            ;	push cx
            ;	int 14h
            ;	pop cx
            ;	loop loop_out
            but failed again - through the terminal i don't see anything. I am using "new" multi-io card based on Winbond W83758 chip with FIFO and other "new" features. I think that's the case.

            In any case, the problem seems hardware.

            Comment


              #21
              Today i booted system with CGA video card and non-working VGA Trident TVGA9000C card together. I was able to dump ROM bios from C000h segment to disk and copmpare it with original BIOS. Dump similar to original BIOS but contain 0xFF bytes at random locations. Every time when i make new dump 0xFF bytes changed locations. I am not discovered dependings. Random places, random 0xFF bytes. Of course, calculated checksum of dump never matches to checksum of original ROM. So, i think it's totaly hardware problem around TVGA8900D and TVGA9000C chips. Maybe, to remedy the situation the presence of buffer like 74LS245 on the data bus, i am not sure...

              Comment


                #22
                hello
                dont know if this card is the most advanced 8bit card ? .. i dont know if it demands 386 or do run in 8088 PC's ??
                seems like a 8/16bit bios switch , but do data transfer also run in 8 bit ?
                http://www.ebay.com/itm/Number-Nine-...-/351704210182

                I am saving money, and going to outbid on this auction.
                /cimonvg

                Comment


                  #23
                  I just tried an ATI MACH32 16 bit on my Tandy 1000 TX and it seems to work fine.

                  Comment


                    #24
                    I have a Trident with the TVGA9000i-3 chipset. It has an 8 bit/16 bit jumpers, but definitely it doesn't work neither in my 5160, nor in my XT clone, 8088 based.

                    I tried D4.01E and D3.51 firmware, no changes. The computer seems to boot, but there's no output signal (monitor goes into stand-by mode).

                    Comment


                      #25
                      Hi guys .

                      This vga card has cl gd5401 cirrus logic ic ,but does all with this ic work on any 8 bit isa xt machine?


                      http://www.recycledgoods.com/media/c...-card-4.39.jpg

                      And do i need drives on dos boot or is it plug n play?

                      Best REgards

                      JOSÉ

                      Comment


                        #26
                        The very first post of this thread lists the chipset, so it might work.

                        All ISA VGA cards do not require drivers to work for booting and normal DOS usage.
                        Offering a bounty for:
                        - A working Sanyo MBC-775 or Logabax 1600
                        - Music Construction Set, IBM Music Feature edition (has red sticker on front stating IBM Music Feature)

                        Comment


                          #27
                          Another one for the list

                          http://www.vgamuseum.info/index.php/...3-hmc-hm86314q

                          Hualon Microelectronics HM86314Q

                          it even has drivers for Windows 286/386 2.1!!!

                          as you can see IMG_20170212_202107.jpg

                          Comment


                            #28
                            For all Olivetti M24 machines; even when jumpering both the P8 board and the mainboard to disable onboard, some cards that have compatibility like the VGA Wonder XL will simply freeze the machine with nothing to display.

                            SpeedStar 24X with the "16-bit" BIOS access jumper disabled (set open) will make the machine boot, but no video is shown. I'm not even sure if that card is 8-bit compatible at all, actually.
                            Join the penny pincher army today!

                            Comment


                              #29
                              Confirmed cards with no absolute compatibility for the Olivetti M24 in any way; SpeedStar 24X, Paradise VGA 16, ATI VGA Wonder XL, and the later ISA Dolch PitViper models. Even if the machine can POST and boot, you can indicate whether the video card is actually found if there is a beep after all the startup tests have succeeded.
                              Join the penny pincher army today!

                              Comment


                                #30
                                I used a Tsenglabs ET4000-based VGA card on my AT&T 6300 for a time.

                                I tend to go by chipset rather than brand. It's less confusing that way.
                                Reach me: vcfblackhole _at_ protonmail dot com.

                                Comment

                                Working...
                                X