Announcement

Collapse

Forum Rules and Etiquette

Our mission ...

This forum is part of our mission to promote the preservation of vintage computers through education and outreach. (In real life we also run events and have a museum.) We encourage you to join us, participate, share your knowledge, and enjoy.

This forum has been around in this format for over 15 years. These rules and guidelines help us maintain a healthy and active community, and we moderate the forum to keep things on track. Please familiarize yourself with these rules and guidelines.


Rule 1: Remain civil and respectful

There are several hundred people who actively participate here. People come from all different backgrounds and will have different ways of seeing things. You will not agree with everything you read here. Back-and-forth discussions are fine but do not cross the line into rude or disrespectful behavior.

Conduct yourself as you would at any other place where people come together in person to discuss their hobby. If you wouldn't say something to somebody in person, then you probably should not be writing it here.

This should be obvious but, just in case: profanity, threats, slurs against any group (sexual, racial, gender, etc.) will not be tolerated.


Rule 2: Stay close to the original topic being discussed
  • If you are starting a new thread choose a reasonable sub-forum to start your thread. (If you choose incorrectly don't worry, we can fix that.)
  • If you are responding to a thread, stay on topic - the original poster was trying to achieve something. You can always start a new thread instead of potentially "hijacking" an existing thread.



Rule 3: Contribute something meaningful

To put things in engineering terms, we value a high signal to noise ratio. Coming here should not be a waste of time.
  • This is not a chat room. If you are taking less than 30 seconds to make a post then you are probably doing something wrong. A post should be on topic, clear, and contribute something meaningful to the discussion. If people read your posts and feel that their time as been wasted, they will stop reading your posts. Worse yet, they will stop visiting and we'll lose their experience and contributions.
  • Do not bump threads.
  • Do not "necro-post" unless you are following up to a specific person on a specific thread. And even then, that person may have moved on. Just start a new thread for your related topic.
  • Use the Private Message system for posts that are targeted at a specific person.


Rule 4: "PM Sent!" messages (or, how to use the Private Message system)

This forum has a private message feature that we want people to use for messages that are not of general interest to other members.

In short, if you are going to reply to a thread and that reply is targeted to a specific individual and not of interest to anybody else (either now or in the future) then send a private message instead.

Here are some obvious examples of when you should not reply to a thread and use the PM system instead:
  • "PM Sent!": Do not tell the rest of us that you sent a PM ... the forum software will tell the other person that they have a PM waiting.
  • "How much is shipping to ....": This is a very specific and directed question that is not of interest to anybody else.


Why do we have this policy? Sending a "PM Sent!" type message basically wastes everybody else's time by making them having to scroll past a post in a thread that looks to be updated, when the update is not meaningful. And the person you are sending the PM to will be notified by the forum software that they have a message waiting for them. Look up at the top near the right edge where it says 'Notifications' ... if you have a PM waiting, it will tell you there.

Rule 5: Copyright and other legal issues

We are here to discuss vintage computing, so discussing software, books, and other intellectual property that is on-topic is fine. We don't want people using these forums to discuss or enable copyright violations or other things that are against the law; whether you agree with the law or not is irrelevant. Do not use our resources for something that is legally or morally questionable.

Our discussions here generally fall under "fair use." Telling people how to pirate a software title is an example of something that is not allowable here.


Reporting problematic posts

If you see spam, a wildly off-topic post, or something abusive or illegal please report the thread by clicking on the "Report Post" icon. (It looks like an exclamation point in a triangle and it is available under every post.) This send a notification to all of the moderators, so somebody will see it and deal with it.

If you are unsure you may consider sending a private message to a moderator instead.


New user moderation

New users are directly moderated so that we can weed spammers out early. This means that for your first 10 posts you will have some delay before they are seen. We understand this can be disruptive to the flow of conversation and we try to keep up with our new user moderation duties to avoid undue inconvenience. Please do not make duplicate posts, extra posts to bump your post count, or ask the moderators to expedite this process; 10 moderated posts will go by quickly.

New users also have a smaller personal message inbox limit and are rate limited when sending PMs to other users.


Other suggestions
  • Use Google, books, or other definitive sources. There is a lot of information out there.
  • Don't make people guess at what you are trying to say; we are not mind readers. Be clear and concise.
  • Spelling and grammar are not rated, but they do make a post easier to read.
See more
See less

C.Itoh CIT 100 Maintenance Manual

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    C.Itoh CIT 100 Maintenance Manual

    There doesn't seem to be any online.
    Lots of User Manual copies, no service/maintenance info.
    Anyone have one?!
    http://abitoutofplace.wordpress.com/

    #2
    Yes this is correct, I dont have one and just searched around on the /net and dont find one. so yes no maint is available to the best of my knowledge

    mb.

    Comment


      #3
      Here's a thought.

      The CIT-100 is essentially a shameless knockoff of the VT100, right down to being able to interchange keyboards, AFAIK. There's plenty of good maintenance info on the DEC product; perhaps it would be a help?

      We used several of the CIT 220 terminals back in the day--I really liked them.
      Reach me: vcfblackhole _at_ protonmail dot com.

      Comment


        #4
        Originally posted by Chuck(G) View Post
        Here's a thought.

        The CIT-100 is essentially a shameless knockoff of the VT100, right down to being able to interchange keyboards, AFAIK. There's plenty of good maintenance info on the DEC product; perhaps it would be a help?

        We used several of the CIT 220 terminals back in the day--I really liked them.
        some pictures of the board in the CIT would quickly determine how close the circuitry is.
        it's not going to be exact, since there are custom video asics in a vt10x

        Comment


          #5
          Thanks folks I'll get some pics uploaded.
          Yes its a knock off but perhaps not terribly interchangeable, as that is the chatter
          on the web, but not confirmed.
          I have a VT102 to compare to if thats the case.
          I was hoping this request might shake loose someone who has
          the manual leading to it getting scanned and made available.
          http://abitoutofplace.wordpress.com/

          Comment


            #6
            OK here's a bunch of pics.
            https://imgur.com/a/fClBw

            A short synopsis: Had two CIT101's that I pulled out of the basement of MOS Technology during that recent cleanout.
            These were in rough shape, one was complete but the screen was knocked in, the other
            was missing the top cover, had worse water damage, but had an intact tube albeit with some burnin. Decided to try to make one good terminal. I happen to have a CIT101 kbd.

            Power supply 5v and 12v checked out. I reseated the socketed ICs and gave it a try.
            The keyboard indicated one fault detected in post. Not bad!
            Tube did not heat up; no glow.
            I swapped for the other video board, still no glow.
            Don't know what's up with that, 12v is getting to the video board.

            I attached a composite monitor to the back panel video out. There was signs of life there but not
            well formed video. Close examination of the board showed that I had bent some pins
            on the NV memory part. Fixed that, still no good video. Then found pins got broken
            on two other ICs that were corroded. Fixed that. The video change a bit, still not right,
            but the POST now ran clean!

            When I turn on the terminal, I can see some almost well formed video picture before it
            breaks up. I think the display is trying to show a cursor but the pixels are strewn across and down
            the screen. I have some confidence that the 8085 micro is doing a lot of stuff that is "right".
            I'm going to scope this soon.

            The only thing I can think of to do next is replace the few electrolytic caps on the board.
            They cluster around some transistors, which might be the video related.

            That's where I'm at.
            Last edited by dmemphis; March 11, 2018, 07:02 PM. Reason: clarify video out.
            http://abitoutofplace.wordpress.com/

            Comment


              #7
              Video *was* like this.
              https://youtu.be/eqciItk-KaQ

              I then noticed that the video tracked going in and out of setup, a good sign!
              Managed to hsync the monitor with the knob and got:
              https://i.imgur.com/OU6Oa0G.jpg
              What a thrill.
              It was short lived. The hsync changed and lock was lost an unrecoverable.
              Thought maybe it was the monitor, so I tried another with the same results.
              https://youtu.be/P3hh1M8I0ew

              The scope looks like this, 5v & 50uS per div. (10x probe),.
              Those hsyncs are 112uS apart... I think that's wrong.
              https://i.imgur.com/tXmCRzO.jpg

              I also discovered that the tube is glowing- I had to turn out the lights to see it.
              But there is nothing on the screen... that's something I'll tackle when the composite video out
              is right on the back panel.

              That's all for today, all in all not bad progress.
              http://abitoutofplace.wordpress.com/

              Comment


                #8
                Are you getting any anode high voltage to the CRT?
                Reach me: vcfblackhole _at_ protonmail dot com.

                Comment


                  #9
                  Thanks... I need to find out...
                  I'm a software guy and half a digital hardware guy... so I don't know what to measure there
                  without some web research on the methods for such measurements around the CRT.
                  http://abitoutofplace.wordpress.com/

                  Comment


                    #10
                    Just be careful--I doubt that the anode HV has enough current to kill you, but a bit of carelessness could be unpleasant. Bad FBTs aren't unusual in the CRT world; the same goes for bad HOTs. Start with the horizontal output transistor first.
                    Reach me: vcfblackhole _at_ protonmail dot com.

                    Comment


                      #11
                      Will do. I'm reading up on the FBT and HOT.

                      Any comments about the scope photo of the composite video?
                      I figure I have to trace back to the video generation and see why the timing and
                      amplitude are off.

                      The video board has some "oversized" electrolytic caps- 10uf 25v and 4.7uf 25v- over 1 inch high
                      and about 1/2 inch diameter. Is there a reason for this? My replacements
                      (considering doing a recap) would be really tiny by comparison.

                      Is this thing worth it?!
                      http://abitoutofplace.wordpress.com/

                      Comment


                        #12
                        Consider the age of the board. Capacitors have steadily gotten smaller over the years as technology has improved.

                        You can always get a larger sized modern caps by raising the WV on the replacement. So, instead of 25V, take a look at 50V ones.

                        The antique radio buffs sometimes get around this issue by gutting the innards of the old cap and using the "can" to conceal a modern unit.
                        Reach me: vcfblackhole _at_ protonmail dot com.

                        Comment


                          #13
                          OK thanks.
                          The size of other caps on the board are on par with moderns.
                          The size difference on these two was so sever I thought maybe they had a special property.
                          For example, ultra low ESR or something.
                          I'm not concerned with the appearance so I'll replace them at will.
                          http://abitoutofplace.wordpress.com/

                          Comment


                            #14
                            Do check to see that they're not non-polarized caps; i.e. the + and/or - should be very clearly marked. If they're non-polar and you substitute a regular polarized one, you'll end up releasing magic smoke.
                            Reach me: vcfblackhole _at_ protonmail dot com.

                            Comment


                              #15
                              Originally posted by dmemphis View Post
                              Thanks folks I'll get some pics uploaded.
                              do you have any way to dump the eproms?

                              Comment

                              Working...
                              X